TD-W9980: Installing DSL modem firmware


#3

ok now is it overwritten. But no connection to isp everything is at 0.Please can somebody tel me what i exactly to configure. This so crazy hard to configure.

in the list of types is not 993.5 is this correct?


#4

Please help.


#5

Make sure to specify the firmware file (and path) in the network configuration, for example:

config dsl 'dsl'
        [...]
        option firmware '/lib/firmware/xcpe_579517_573F01.bin'

#6

ok thank you... i test it tomorrow. Can you tell me the path for the config file please?


#7

That would be /etc/config/network


#8

must i fill out the isp data to connect establish the vdsl sync?


#9

No, it should synchronize even with missing/wrong credentials.


#10

Hi Takimata,

i think the sync is done :blush: thx but i have no internet :smiley: must i configure openwrt? routing,bridging or something else? i read that i must make a vlan but this is not relevant for dslmodem only for router-only right?
PPPOE ist filled with the correct data but i chance nothing from config. My line is a Vodafone VDSL 100 from
germany. Sorry for my really BAD english :smiley:

here my logstatus

Status: UP
Line State: showtime_tc_sync [0x801]
Line Mode: G.993.5 (VDSL2 with down- and upstream vectoring)
Annex: B
Profile: 17a
Data Rate: 101.235 Mb/s / 27.021 Mb/s
Max. Attainable Data Rate (ATTNDR): 107.776 Mb/s / 28.702 Mb/s
Latency: 0.13 ms / 0.0 ms
Line Attenuation (LATN): 8.5 dB / 10 dB
Signal Attenuation (SATN): 8.5 dB / 9.6 dB
Noise Margin (SNR): 6 dB / 9.7 dB
Aggregate Transmit Power(ACTATP): 0.6 dB / 14.5 dB
Forward Error Correction Seconds (FECS): 0 / 2753
Errored seconds (ES): 0 / 6
Severely Errored Seconds (SES): 0 / 0
Loss of Signal Seconds (LOSS): 0 / 0
Unavailable Seconds (UAS): 111 / 111
Header Error Code Errors (HEC): 0 / 0
Non Pre-emtive CRC errors (CRC_P): 0 / 0
Pre-emtive CRC errors (CRCP_P): 0 / 0
Line Uptime: 41s
ATU-C System Vendor ID: Broadcom 177.140
Power Management Mode: L0 - Synchronized
Tue Oct 17 19:18:12 2017 daemon.info odhcpd[730]: Using a RA lifetime of 0 seconds on br-lan
Tue Oct 17 19:18:13 2017 daemon.info pppd[23105]: Plugin rp-pppoe.so loaded.
Tue Oct 17 19:18:13 2017 daemon.info pppd[23105]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Tue Oct 17 19:18:13 2017 daemon.notice pppd[23105]: pppd 2.4.7 started by root, uid 0
Tue Oct 17 19:18:28 2017 daemon.warn pppd[23105]: Timeout waiting for PADO packets
Tue Oct 17 19:18:28 2017 daemon.err pppd[23105]: Unable to complete PPPoE Discovery
Tue Oct 17 19:18:28 2017 daemon.info pppd[23105]: Exit.
Tue Oct 17 19:18:28 2017 daemon.notice netifd: Interface 'Internet' is now down
Tue Oct 17 19:18:28 2017 daemon.notice netifd: Interface 'Internet' is disabled
Tue Oct 17 19:18:28 2017 daemon.notice netifd: Interface 'Internet' is enabled
Tue Oct 17 19:18:28 2017 daemon.notice netifd: Interface 'Internet' is setting up now
Tue Oct 17 19:18:28 2017 daemon.info pppd[24199]: Plugin rp-pppoe.so loaded.
Tue Oct 17 19:18:28 2017 daemon.info pppd[24199]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Tue Oct 17 19:18:28 2017 daemon.notice pppd[24199]: pppd 2.4.7 started by root, uid 0

#11

On which interface is pppoe running? To use my VDSL line I have to use ptm0.34.
The 'xfer_mode' is ptm

config dsl 'dsl'
        [...]
        option xfer_mode 'ptm'

#12

In germany you typically need vlan tag 7.


#13

Hey Mijzelf,

me the same config... here
VLAN explained with default scenario of most LEDE routers
in this example table you can see WAN port but in my gui isnt a WAN port,

only this

CPU (eth0) LAN 1 LAN 2 LAN 3 LAN 4

and you choose only 'OFF' and 'tagged' no untagged

here my network config


root@LEDE:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd90:6603:3462::/48'

config atm-bridge 'atm'
        option vpi '1'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'

config dsl 'dsl'
        option annex 'b'
        option tone 'bv'
        option xfer_mode 'ptm'
        option firmware '/lib/firmware/vdsl.bin'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.254'

config interface 'wan'
        option ifname 'ptm0.7'
        option proto 'pppoe'
        option username 'username'
        option password 'passwort'
        option ipv6 'auto'

config device 'wan_dev'
        option name 'ptm0'
        option macaddr 'c4:6e:1f:5e:9c:23'

config interface 'wan6'
        option _orig_ifname '@wan'
        option _orig_bridge 'false'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'
        option type 'bridge'
        option ifname 'ptm0 ptm0.7'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 2 4 5 6t'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '6t'
        option vid '7'


#14

no chance... cant connect to isp :frowning:


#15

Use only ptm0.7 here; remove ptm0 and the bridge.

This VLAN definition could be part of setting up your device as a simple VDSL Modem. Otherwise, it is not needed.


#16

Done. But same result... no connection :confused:


#17

Please login to the device with putty or ssh, run the following commands and post their output.

brctl show
ip link ls dev ptm0.7

You could also try rebooting or power-cycling the device.


#18

I find the problem... Login data was incomplete
It's working now but the modem ist sooooo slow
Sync is at 100k but downloadspeed with cable
Is 50k. Starting at 68k and pendling to 50k.
With the fritzbox 7430 is this 90-93k.

Only one question is this a config problem or is this a firmware problem or hardware to old or broken?


#19

Any idea...?


#20

#21

Your point being?


#22

I have same Problem. The reason for the slowdown is written in the Forum post i linked.