TD-W8980 Ver:1.1


I have a TP link router which I was able to flash from the UI, apparently something went bad there and the router is not operational.

Here is my setup:
Debian -> Arduino -> router

From the Arduino my RX maps to the lower of the 4 JTAG pins (the one further away from the CPU. The next one maps to Arduino's TX and the third one maps to one of arduino's ground pins.

When the router gets powered on and minicom runs, the I get 4 bursts of data from the router and then a steady receiving. Now I have set up minicom to 115200 8N1 but the data received looks like garbage. I have tried some combinations of baud rates but while I receive data from the router it looks unintelligible.

The guide mentions that I need to connect the left side of R225 to GND. By this I understand the GND of my arduino or the GND of the router? I also tried the pad next to it but it also does not seem to work. In fact when I short that pad I do not get any input.

I sense because my hardware is v1.1 instead of v1.0 I guess something might be off? If someone could point me to the direction I need to take I would very much appreciate it because my knowledge about the hardware is rather limited.


Ground on both machines must be connected together. Use an ohmmeter to confirm which of the 4 pins is ground. It will connect to the metal shield plates and the antenna outer conductors, all of those are ground.

One of the 4 pins is 3.3 volts, do not connect that one to anything.

Grounding R225 is only if you have a "hard brick" because the bootloader has been erased and needs to be replaced. If you are getting data out of the serial port you don't need to do that.


I just got a digital multimeter and I measured the voltage on the pins. Pins 1,3,4 have 3.25-3.30 voltage while pin 2 seems to be GND.

Due to the top pin having a different shape than the others I assumed that this was the power, so I have connected pin2 to GND, pin3 to TX0 and pin4 to RX0, then I plug the router.

What happens is that the TX led lights up 4 times then stays on. I guess these are messages from the bootloader?

But the point is, I have minicom open on ttyACM0 at 115200 8N1 with no software/hardware flow control and the data I get is unreadable by me.

I experimented with different baud rates (with all the other settings staying the same). I get data but it is not readable.

Any idea what setting I have to change on minicom? I can keep switching but I am not even sure if I am on the right track here.

I have the same router and I had the same problem. As it turned out the USB to TTL adapter I was using was not compatible for some reason. Fortunately I had ordered 2 different ones. One was the fake pl2303 one from china and it worked flawlessly while the other one which had a different chip didn't work.

You csn also try swapping the TX and RX pins and it may work. But if it doesn't then it's possible that the TTL adapter or board that you are using may not be compatible or so I believe.