TD-W8970 transparent bridge

Hello

i bought cheaply Xiaomi mi 4A gigabit router and i want to move whole stuff to this device. Currently im using TP-link TD-W8970 with openwrt also. I have ADSL line so i want to still use tplink as adsl modem and xiaomi as router. I want to avoid double nat and firewall. But there i have problem. I dont know how to configure TPlink as transparent bridge. Here is my current network config of TPlink. Any help is appreciated.

config interface 'loopback'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'
	option device 'lo'

config globals 'globals'

config atm-bridge 'atm'
	option vpi '0'
	option vci '35'
	option atmdev '0'
	option nameprefix 'dsl'
	option payload 'bridged'
	option encaps 'vc'

config dsl 'dsl'
	option xfer_mode 'atm'
	option firmware '/lib/firmware/vr9-A-dsl.bin'
	option annex 'a2p'
	option ds_snr_offset '0'

config interface 'lan'
	option proto 'static'
	option ip6assign '60'
	option _orig_ifname 'eth0.1 radio0.network1'
	option _orig_bridge 'true'
	option device 'br-lan'
	list ipaddr '192.168.1.1/16'

config interface 'wan'
	option _orig_ifname 'ptm0'
	option _orig_bridge 'false'
	option proto 'pppoe'
	option username 'xxxxx'
	option password 'xxxxx'
	option ipv6 '0'
	option peerdns '0'
	option keepalive '2 5'
	list dns '8.8.8.8'
	list dns '8.8.4.4'
	list dns '62.233.233.233'
	list dns '87.204.204.204'
	option device 'dsl0'

config device 'wan_dev'
	option macaddr 'xx:xx:xx:xx:xx:xx'
	option name 'dsl0'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '2'
	option ports '6t 5t 0t 2t 4t'

config bridge 'type'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '1'
	option ports '6t 5 0 2 4'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'
	list ports 'tap0'

config device
	option name 'br-guest'
	option type 'bridge'
	list ports 'eth0.2'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option ports '6t 4t'
	option vid '3'

config device
	option type 'bridge'
	option name 'br-wan'
	option mtu '1500'

W8970 uses same vrx268 SoC as HH5a

See section 9.8 for configuring bridge mode for 'upto' OpenWrt 21 for HH5a:
https://openwrt.ebilan.co.uk/viewtopic.php?t=266

I assume your ISP supports DHCP or PPPoE protocol.