Td w8968v4 go back to oem

i have installed openwrt on td i want to back oem frimware. please help me.

Hey Guy,
i had tested the firmware openwrt-brcm63xx-generic-TD-W8968-squashfs-cfe.bin on TP-Link TD-W8968 v4 and works fine.

1 - poweroff the equipament;
2 - with the reset button pressed, turn on, wait 5 seconds..
3 - browser to url and put the firmware openwrt-brcm63xx-generic-TD-W8968-squashfs-cfe.bin
4 - after configure .. update the packages, connect via ssh and run the commands:
opkg update
opkg list-upgradable
lookup the packages names to upgrade..
opkg upgrade <packages>

finally the environment will be stable..

What happened when you reflashed the OEM firmware?

It say illegal image.

I've never heard of that error message.

  • Can you copy/paste that error message?
  • What happens if you try sysupgrade -f ?

When I try sysupgrade -f it flash the image but router don't work.only power led flash.

Did you follow the instructions to flash OEM?

I also try this but when browse the OEM bin say illegal image


I've already noted that that error message is unknown. Also, I have no clue what "browsing the image" means, please clarify.

TD w8968v4 have cfe bootloader. It requires cfe firmware file.

Image uploading failed. The selected file contains an illegal image.

Please read it

  • I don't understand why you're showing me that, I asked you to provide a copy of this error.
  • Also, I asked about flashing via sysupgrade, the Wiki page shows flashing to OpenWrt from stock using an OEM restoration GUI. If this flash method is still available and isn't working, you likely have a bigger issue unrelated to OpenWrt.

If you want assistance, please copy/paste your error!


The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.

Can anyone have solution of it.

Have you consulted the OEM forums?

You never described what this means. You have to provide more details.

It seems you used the CFE method here ...but have you tried the other method (TFTP)???

How know
Rx tx gnd
And which usb TTL adaptor use.

If there are no details provided on the device page, you can use a voltmeter to determine Positive and Ground/Earth. From there, the two remaining pins are: Tx and Rx.


i will tried cfe tftp method but a error came up
Loading ...
Finished loading 8236996 bytes
Firmware tag version [1] is not compatible with the current Tag version [6].
*** command status = -1

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.