TD-LTE on OpenWrt

Hi . I have EP06-E module and ZBT router .
according this link I install 4G module and working right :

how can I set TDD or FDD on OpenWrt ?
I bought TD-LTE service and insert SIM CARD inside router and set APN on setting but cannot connect to Internet . I talked to support and they said set the settings to FDD. But they don't have any information about OpenWrt and they can't guide me.

TDD (Time-division duplexing) and FDD (Frequency Division Duplexing) are the attributes of the radio band used, this have nothing to do with OpenWrt.

Start from the basics. Show the output of cat /sys/kernel/debug/usb/devices

1 Like

I know . EP06 support both TDD and FDD , my question is how can I select TDD or FDD for connect to internet.

You're on the wrong way.

1 Like

for config 4G I install 'qmi-utils' package according above link I sent.
do you can guide me for config TD-LTE?

I have no idea what is "TD-LTE".
Please provide the information I requested earlier and I'll guide you further. No pictures, please.
Make sure you're running the latest official OpenWrt version and not the software preinstalled by ZBT.

1 Like

It is the same as LTE-FDD and LTE-TDD.

Which LTE Bands does your mobile network use and who is the mobile network?


It should not matter if connected on a FD or TD mode. This is a modem setting, as @hecatae said, you can lock out the TD bands which will then require a FD connection (if possible). Settings like this are done by issuing AT commands to the modem card on its ttyusb control port.

Using automatic APN (leave the APN field blank) works in almost all modern cases. The carrier should have stored the APN that should be used on the SIM card and the modem will read it.


I tested with empty APN not connecting .

sim detected

root@OpenWrt:~# qmicli --device=/dev/cdc-wdm0 --device-open-proxy --uim-get-card-status
[/dev/cdc-wdm0] Successfully got card status
Provisioning applications:
        Primary GW:   slot '1', application '1'
        Primary 1X:   session doesn't exist
        Secondary GW: session doesn't exist
        Secondary 1X: session doesn't exist
Slot [1]:
        Card state: 'present'
        UPIN state: 'not-initialized'
                UPIN retries: '0'
                UPUK retries: '0'
        Application [1]:
                Application type:  'usim (2)'
                Application state: 'illegal'
                Application ID:
                Personalization state: 'ready'
                UPIN replaces PIN1: 'no'
                PIN1 state: 'disabled'
                        PIN1 retries: '3'
                        PUK1 retries: '10'
                PIN2 state: 'enabled-not-verified'
                        PIN2 retries: '3'
                        PUK2 retries: '10'
        Application [2]:
                Application type:  'isim (5)'
                Application state: 'detected'
                Application ID:
                Personalization state: 'unknown'
                UPIN replaces PIN1: 'no'
                PIN1 state: 'not-initialized'
                        PIN1 retries: '0'
                        PUK1 retries: '0'
                PIN2 state: 'not-initialized'
                        PIN2 retries: '0'
                        PUK2 retries: '0'

signal status :

root@OpenWrt:~# uqmi -d /dev/cdc-wdm0 --get-signal-info
        "type": "wcdma",
        "rssi": -59,
        "ecio": 8

Shouldn't the type above be LTE?

You should not leave the APN field blank. Put there the APN name given by your provider.
Use proper IPv4/IPv6 settings.

I tested both . with APN and empty APN . only IPV4 and IPv4/IPv6.

You don't need to play with the settings. Configure APN and IP type as advised by your provider then describe the issue (if any).

provider just told me set APN . I set APN and Connection failed. I asked them and they told me try connection mode to FDD .
I don't know how to select FDD.
there is no GUI option for select FDD like other router firmwares.

to set the connection mode to FDD, you have to choose the bands using AT commands.
Now as I do not know what your local LTE bands are or who the mobile operator is, I'm unable to advise which bands to lock to as you seem to be unwilling to provide this information.

Sorry, I forgot to reply your message. I use MTN IRANCELL

In LTE -or in cellular networks in general- the uplink and downlink can be separated (which is called FDD or frequency division) or together on one part of the band (TDD, time division). And whether FDD or TDD is being used is defined in the LTE band definition itself. Common FDD bands eg. in Europe are B1, B3, B7, a TDD band would be B38 (not so common AFAIK).

So if you want to understand the situation in your country/area I can recommend to check, which allows you to filter for country/PLMN Id(provider) and also band. On a brief check your provider seems to use B1, B3 and B7, but the webpage you're referring to claims the availability of TDD band B42.
So if your contract now only supplies service on B42 band, you should check whether there's a cell tower for B42 in your area. Cellmapper is crowd-supplied so possibly not precise, but you can ask that your provider as well.
On a glance of the spec sheet of your EP06-E modem..... there's no B42 mentioned



Halberd Bastion advises TDD-LTE is only Band 42

1 Like

thank u everyone . problem resolved .
MTN Irancell use Band 42 and module EP06-E not support Band 42.
:pray: :hibiscus:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.