TD-8970 as AP+STA but same subnet and without isolating clients

I have a main (provider) router and a TpLink that i use as Ap+STA.

The main router has 192.168.1.1 ip and i want the tplink to use 192.168.1.200 ip.
The tplink wifi has a different SSID and different password.

To do all this i changed the lan interface ip, i joined the main router's wifi as a client, i changed the wan phyisical interface to the radio (the one that joined the main router's wifi) and i added to the lan's physical interfaces the client wifi and the ap wifi.

So what i've got is an ap that gets internet access from the main wifi but its clients aren't visible or pingable from the main network. For example, i have a samba server plugged in the ethernet port of the tplink and with my smarphone if i'm in the tplink wifi i can access it, if not i can't.

I want to be able to connect to any file sharing system and to connect to the configuration of any of the routers indipendently on what network i'm in. How i should do it?

Before flashing OpenWrt i used the WDS option while disabling DHCP on the tplink router but with openwrt i cannot replicate what i had before.

I don't quite understand your configuration. You might want to post these files from /etc/config/:

  • dhcp
  • network
  • wireless

Note that the wan interface on the OpenWrt device should be unused. All relevant interfaces should be part of its lan bridge.

WDS is a good solution for what you want to achieve, if supported by your devices.
However, often WDS is only compatible between firmware and hardware from the same vendor.
I cannot say if it will work in your case, just try it again once you are sure the rest of the config is correct.

Ok, sorry if i took a long time to post. Here it is all you want.

Dhcp:

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv6 'server'
	option ra 'server'
	option ra_management '1'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

Network:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd3b:26fe:917b::/48'

config atm-bridge 'atm'
	option vpi '1'
	option vci '32'
	option encaps 'llc'
	option payload 'bridged'
	option nameprefix 'dsl'

config dsl 'dsl'
	option annex 'a'
	option tone 'av'
	option ds_snr_offset '0'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.1.200'
	option gateway '192.168.1.1'
	list dns '1.1.1.1'
	list dns '1.0.0.1'

config interface 'wan'
	option proto 'pppoe'
	option username 'username'
	option password 'password'
	option ipv6 '1'

config device 'wan_dsl0_dev'
	option name 'dsl0'
	option macaddr 'f8:1a:67:5b:16:0d'

config interface 'wan6'
	option ifname '@wan'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 2 4 5 6t'

config interface 'wwan'
	option proto 'dhcp'

Wireless:

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
	option htmode 'HT20'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

config wifi-iface 'wifinet1'
	option ssid 'TheNewSasso'
	option device 'radio0'
	option mode 'sta'
	option key 'jT6Cl2bXMg56jY0eX4iMhB7Q'
	option encryption 'psk2'
	option network 'wwan wan lan'

I also followed the guide that a guy made in this post How to?... Client + AP. Part 2

but i realized ad the end that my technicolor tg789vac v2 TIM main router doesn't support static routes.

Edit:
i don't know if wds would work. The TIM Technicolor router has stock firmware and i cannot flash any version of openwrt. So there is no way to set the main router as AP(WDS).

Since WDS worked with the stock TP-Link firmware, I suggest to try this again under OpenWrt as follows.

option network specifies a single network interface the wireless interface is attached to.
Change this to 'lan'.

To enable WDS, add:

	option wds '1'

option network 'lan' is OK, keep it.

Side note: you might want to add option country and set it to a value suitable for your location. However, this is not needed to make WDS work. Apply this change last, if at all.

You might want to disable the wan and wan6 interfaces.

Remove the wwan interface.

Disable DHCPv4, DHCPv6 and router advertisements for the lan interface:

	option dhcpv6 'disabled'
	option ra 'disabled'
	option ignore '1'