Take minutes until getting an IP

Hi,

I have a setup of two APs (FritzBox 7320 and Linksys WRT1900ACS) with OpenWRT. Both APs serve two WiFi networks (normal and guest) via VLANs. DHCP is relayed by a OPNsense router.

The fritzbox works just fine. But with the Linksys router I have an annoying issue with some clients at least: It takes minutes until then they get connected. Then it seems to be fine until they leave the area of the Linksys AP. In the log of the DHCP server see that there is an request and that the server sends an answer but that seems to be received by the client.

What could the cause? The issue is independent of ieee80211r and the wifi network used. It was observed since the upgrade to 21.02. 19.07 was fine.

Thank in advance.

Best,
wrter

EDIT: Can the issue caused by DSA? I use the WAN port as uplink to the switch < - > router

EDIT2: The Linksys is on 21.02.2 already

Network config of the Linksys AP:


config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd0c:c4f9:559c::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        option stp '1'
        list ports 'wan.23'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '$ip'
        option gateway '$gateway'
        list dns '$dns'
        list dns_search '$search'
        option delegate '0'

config interface 'wan'
        option proto 'none'
        option device 'br-wwan'

config device
        option type '8021q'
        option ifname 'wan'
        option vid '29'
        option name 'wan.29'

config device
        option type 'bridge'
        option name 'br-wwan'
        list ports 'wan.29'
        option stp '1'

config device
        option type '8021q'
        option ifname 'wan'
        option vid '23'
        option name 'wan.23'

I've just read the guide:

Is my approach to handle the ports as single interfaces or have I to use bridge VLANs?

Try using bridge vlan filtering:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd0c:c4f9:559c::/48'

config device
        option name 'br-wan'
        option type 'bridge'
        list ports 'wan'

config bridge-vlan
        option device 'br-wan'
        option vlan '23'
        list ports 'wan:t'

config bridge-vlan
        option device 'br-wan'
        option vlan '29'
        list ports 'wan:t'

config interface 'lan'
        option device 'br-wan.23'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '$ip'
        option gateway '$gateway'
        list dns '$dns'
        list dns_search '$search'
        option delegate '0'

config interface 'wan'
        option proto 'none'
        option device 'br-wan.29'

I would create a wired or wireless management interface to get access to the AP in case something goes wrong.

config interface 'management'
        option device 'lan1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '$management_ip'
2 Likes

Thank you very much :slight_smile:

Finally I've this configuration:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd0c:c4f9:559c::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        option stp '1'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        list ports 'wan'

config interface 'lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '$ip'
        option gateway '$gw'
        list dns '$dns'
        list dns_search '$domain'
        option delegate '0'
        option device 'br-lan.23'

config interface 'wan'
        option proto 'none'
        option device 'br-lan.29'

config bridge-vlan
        option device 'br-lan'
        option vlan '23'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        list ports 'wan:t'

config bridge-vlan
        option device 'br-lan'
        option vlan '29'
        list ports 'wan:t'

Strange that it worked partly with old configuration and not just not at all.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.