Tailscale can't access subnet devices in subnet router mode

Tailscale version: 1.24.2-3
Your operating system & version: Openwrt 22.03.2 running on Mi Wifi Mini router

Hello,
I am running tailscale on Openwrt as a subnet router advertising my local subnet of 172.26.31.0/24

When i connect via my android phone through tailscale app,
i can access the router that tailscale is running on successfully. (It’s IP is 172.26.31.100)

But there are 3 more Openwrt devices in the same subnet. (172.26.31.101, 172.26.31.102, 172.26.31.103). I can’t access those.

My Openwrt router can ping (not tailscale ping) all those devices.

Also,
My Network has 4 VLAN’s
VLAN 1 : 172.26.31.0/24 (LAN Subnet)
VLAN 2 : 172.26.1.0/24 (WAN Subnet)
VLAN 3 : 172.26.32.0/24 (IOT Devices Subnet)
VLAN 4 : 172.26.30.0/24 (Guest Devices Subnet)

When i install and configure tailscale on openwrt, i get a tailscale0 device, of which i make a Interface with DHCP protocol in Openwrt.
I see no option of specifying which VLAN does this tailscale0 device should be able to access.
I think this should be done automatically via the subnet i provided to tailscale for subnet routing. So, it should pickup the correct VLAN and configure ip routes on Openwrt device.
But it’s not working.

Does anyone else has similar setup?

Some pics

Things i have tried:

  1. Adding the tailscale0 into the br-lan bridge device. But still doesn’t work.
  2. Adding a ‘relayd’ bridge between br-lan and tailscale interface. No luck.

Note: I have also posted the same post in tailscale forums.