T5740/BCM57780 network: Generic X86 OpenWrt


I try to install OpenWRT on a T5740 HP Thin client.This PC has a BCM57780 network controller.
I took the generic version (32 bits, Atom N280 CPU) SQUASHFS, then EXT4 versions. I install that by copying the .img on a USB key (dd if=... of=/dev/sdb). This step is OK.

When I reboot the T5740 with this key, startup is OK, and I can access the console.

But I have no access to the ethernet controller. ifconfig -a return only the local ip.

I think this is due to the lack of these packages in the img file:

  • kmod-phy-broadcom_5.4.154-1_i386_pentium4.ipk
  • kmod-phylib-broadcom_5.4.154-1_i386_pentium4.ipk
  • kmod-libphy_5.4.154-1_i386_pentium4.ipk

I try to add these package in the USB key (on a Linux PC), but the access is read only.

How to add the BCM57780 to the Generic X86 OpenWrt, without Ethernet communication link, (except maybe the serial port)?

I saw some interesting webpages on that topics, but each time some details are missing (I am electronic and firmware engineer, who try to deeper understand Linux !)

Maybe I have to compile the whole OpenWrt with these packages?

Thank you!

That is the correct procedure, but the issue with the ro flash drive is on your Linux pc, and has nothing to do with openwrt.

You could however try to (re)mount the flash drive with the option -o rw (if using cli).
I'm sure there's some nice windowed UI for doing it too, but I'm a cli kind of guy, sorry.

Easiest way is to build an image with the imagebuilder, and add these two packages: kmod-tg3 and kmod-phy-broadcom

1 Like

Yes that would be a tg3 chip. You could also mount the USB drive partition 2 (the ext4 rootfs) on another Linux computer and copy the .ipk files somewhere into that filesystem. Then boot OpenWrt on the target computer and run opkg install filename from the console.

1 Like

Thank you all for your help.
but I did not progress on this topic...
On Ubuntu, I copied the 3 *.IPK files in the rootfs/tmp directory.
I modified the permissions and changed the owner of these files. Now root.

I boot on OpenWrt with that usb key, but when in console mode, I cannot see any IPK file in the tmp directory!
I am a bit lost...

Thank you!

Did you try the imagebuilder?

If you write to /tmp in the ext4 rootfs partition, it will just be overridden by the OS mounting the default RAM disk onto /tmp. Files stored in /tmp on the flash drive will not be accessible.

Instead use the already existing /root directory, which is the default directory when you log in.


It works!
I copied the ipk files in the root directory of the USB key with a Linux PC.
I rebooted the PC with the OpenWrt linux key.
I ran OPKG with the 3 IPK files as arguments stored in root directory
and my broadcom network was present!

I changed its IP address from to because my lan is in 192.168.0.x (edit network file with CLI)

I was able to access it using Luci.

But, I was not able to update OPKG packages in Luci.
I filled the root password, but the issue remain.
I solved the issue when I filled a gateway IP address and a DNS ip address in the network menu.

Then I updated all the available packages with Luci and installed kmod-usb-net-rtl8152 because I wanted to install a second ethernet port with a TP-Link UE300 USB Ethernet dongle.

I think it works. The device appears in the list.

Now, I want to install a package for my huawei E3372 LTE usb key. I will look for its package and the configuration.

I will train to configure the OpenWrt router as I want:
WAN on an ethernet or LTE/USB port, Lan on an ethernet port.
OpenVPN client or wireguard client running in OpenWrt.

And try to install a USB webCam to see remotely the wild animals emerging from the forest!
Thank you.

I think I will have some question in a near future...I keep you posted!


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.