Syupgrade to 21.02.1 not sticking on AVM Fritz!Repeater 3000

It appears that there is no 21.02.1 image for the AVM Repeater 3000 - is supposed to be the right file, but after flashing it, the firmware identifies as OpenWrt 21.02.0 r16279-5cc0535800. Am I missing something here?

What version were you upgrading?

I'm not sure what the initial version was supposed to be, either 21.02.0 or 21.02.1, but that was some months ago and I've upgraded/tried to upgrade since. Today when redoing some wifi settings, I noticed the old version number and thought I had used the wrong image by accident, so I upgraded again, and that's when I realized the FW version stayed the same.

Sounds like the sysupgrade may not have worked.

SSH in to the device and run the following...

ubus call system board; \
uci export network; uci export wireless; \
uci export dhcp; uci export firewall; \
head -n -0 /etc/firewall.user; \
ip -4 addr ; ip -4 ro li tab all ; ip -4 ru; \
ip -6 addr ; ip -6 ro li tab all ; ip -6 ru; \
ls -l  /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/* ; head -n -0 /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/*

Note: Redact any passwords, MAC addresses, and your public IP.

Post the results in preformatted text, by using the icon highlighted in red...

OpenWRT Posting Icons

Thank you for trying to help here, but I'm not at all sure in what my network configuration has to do with sysupgrade failing. However, I can certainly run the upgrade via CLI (I had not a considered a possible sysupgrade error, since the device rebooted and all).

That command shows all of your configurations, and if in fact the upgrade failed, there may be clues.

If you don't want to run it, your call.

Good luck.

Here's the hardware information:

	"kernel": "5.4.143",
	"hostname": "repeater",
	"system": "ARMv7 Processor rev 5 (v7l)",
	"model": "AVM FRITZ!Repeater 3000",
	"board_name": "avm,fritzrepeater-3000",
	"release": {
		"distribution": "OpenWrt",
		"version": "21.02.0",
		"revision": "r16279-5cc0535800",
		"target": "ipq40xx/generic",
		"description": "OpenWrt 21.02.0 r16279-5cc0535800"

I don't see what influence the network configuration would have on sysupgrade not working - before its starts, the file is already uploaded (in this case via LuCi). If it is is indeed sysupgrade failing and not an incorrect image file for a relatively obscure target, it is not failing because of a networking problem.

As mentioned, all of your configs are shown...not just network.


The upgrade failed.

Well yes, that was why I was posting my question in the first place.

Your issue statement was...

Clearly, there is...

Clearly, the upgrade from the version you had (21.02.0) failed.

See this thread...

That thread would seem to be about the initial installation using eva_ramboot, and not sysupgrade? (Not trying to be snarky here, but I don't see how it relates.)

Did you try the update over SSH or through the web UI?

You'll get more feedback from the upgrade process through SSH. I think sysupgrade has a -v switch for added verbosity.

It does...

Yes. Unfortunately, just after listing all the config files it is saving, it closes the shell. I would need a serial console to see more, it seems.

root@<hostname>:/tmp# sysupgrade -v -c -k openwrt-21.02.1-ipq40xx-generic-avm_fritzrepeater-3000-squashfs-sysupgrade.bin 
<timestamp> upgrade: Saving config files...
<timestamp> upgrade: Commencing upgrade. Closing all shell sessions.
Connection to <hostname> closed by remote host.
Connection to <hostname> closed.

Yes, that is indeed normal behaviour. You could try killing wireless before running sysupgrade again:

# /sbin/wifi down

Often some process refusing to die can make sysupgrade abort, and wifi's been the culprit there more than once.

If that doesn't work, either hook up serial or, since .0 to .1 is supposed to be painless, back up your settings and flash a factory image through the recovery procedure for your hardware.

Unfortunately, there is no recovery method listed. Any point in using firstboot or sysupgrade -n? The initial setup instructions for the AVM Fritz!Repeater 3000 involved (so only the sysupgrade image and the boot loaders were ever written to flash).

Using the ramboot script with the sysupgrade image (if the instructions were such) should be sufficient, and at that point you'll be sure it gets flashed.

Did you try killing the wifi already like I suggested?

I tried together with nohup to prevent to killing the wifi from terminating the command execution. Unfortunately, that didn't change anything. (At the moment I don't have either a long enough ethernet cable nor a non-headless device with an ethernet port do a direct connection at the point of installation of the repeater. I am reluctant to undo the installation work, so I'll get an ethernet adapter next week instead.)

Have you tried resetting the router to the default state first, and then applying the upgrade? Make a backup before you do this, of course. Although unlikely, it is always plausible that something in the configuration (or any user installed packages) could be messing up the upgrade process.