Sysupgrade problem on TP Archer C50 (MT7620)

Hi. I can't use sysupgrade to update my router. It shows this message:

If I use -F (force upgrade) it runs but show error: "erase block failed" but still get a new snapshot version (should I ignore it ?).
If I install lede from stock firmware it get rejected with code "4503". I hope these problems will be fixed soon :relaxed:

There are indeed several known issues with C50 images at the moment. @mkresin already staged a proposed fix for your metadata validation problem above, see .

The code 4503 error is due to the lack of a proper factory image for the C50, this is something we hope to address soon.
@NeoRaider worked on this but needs a user with access to the hardware in order to test things. Some earlier preliminary tests led to soft-bricks though, so testing images absolutely requires serial port access.

Are you in the situation to be able to test such changes?

Thank for the useful info :grinning: As a normal user and have a history of 5 bricked router I think I should stay away from testing my new router :cold_sweat: