Sysupgrade Image check failed

Hi all,

I want to change firmware on onion omega2s+ board, but when i run root@OpenWrt:/tmp# sysupgrade -n openwrt-ramips-mt76x8-omega2p-squashfs-sysupgrade.bin

i face this error i cannot understand why this is happend

Wed Apr 27 08:50:27 UTC 2022 upgrade: Device onion,omega2p not supported by this image
Wed Apr 27 08:50:27 UTC 2022 upgrade: Supported devices: omega2p
Image check failed.

Omega2s vs Omega2p

's' is a variant, that only differ in the packaging, according to ('s' means surfacemount)

The plus(+) variants have twice the RAM/Flash: 128/32 vs 64/16. For the non-surfacemount variant both RAM/Flash variants are supported, afaict.

So, I think, only the "compatible boardname" for one of the existing images needs to be adapted to include the SurfaceMount Variants.

Screenshot from 2022-04-27 16-56-35

How to adapted ? I have only 2 options and i select omega2+.

So you have already unsuccessfully tried tftpbooting this initramfs (= Does not change anything in your Hardware) the official precompiled OpenWrt release from bootloader, sending the commands via serial ?

Or does your board not have a LAN port?

I can use both serial or ssh

So, when you connect via Serial, interrupt the bootloader, and then connect the Ethernet cable, then you see messages in the console about "Link up", or some something like that?

If yes, then I'd run dnsmasq in tftp-server mode on my laptop, connect that via Ethernet to your Onion Device, and then (attemp to) tftpboot the initramfs linked above from U-Boot. (And then hope for meaningful output)