Hello friends and contributors of OpenWRT, I turn to all those who may be able to find a solution to the flashing of the device in question. It is now known that GL.inet provides the proprietary firmware full of bugs as well as obsolete, so I already tried in THIS POST to replace the proprietary firmware with OPENWRT LUCI following the official procedures ath this link

The result after flashing with "openwrt-19.07.3-ar71xx-generic-gl-ar750s-squashfs-sysupgrade" was the BRICK of the device.

I ask all of you what the mistakes that I make in the procedure or possibly to make a fix.

Chiedo a tutti voi quali possano essere gli errori che commetto nella procedura o eventualmente di fare un fix.

Have you looked at and followed what others have done?

Thanks for the info, I seem to have understood that the RELASE that manages to SYSUPGRADE the device is the STABLE "openwrt-19.07.2-ar71xx-generic-gl-ar750s-squashfs-sysupgrade".
Did I get it right?

flash this:
from gl.inet uboot recovery:
then edit network for internet connectivity via ssh:

vi /etc/config/network

option dns ''  
option gateway ''


Nothing to make friends, even uploading the NAND file "openwrt-ath79-nand-glinet_gl-ar750s-nor-nand-squashfs-factory.img" the AR750S router goes to BRICK. The WIFI LEDs after the flashig remain off and it is not possible to access the interface.

What am I doing wrong I don't understand?

from gl.inet uboot recovery should work correctly, i have no idea from luci or ssh.. if you still cant flash it you should contact gl.inet support maybe defective unit.

Yes, but once loaded, that firmware sends the device to brick.

I answered in your other thread. Please don’t cross post - it creates confusion and splits the conversation.

1 Like

Ok, mission accomplished!

I was talking about wifi led because the GL.inet official guide said that the 2G led of the completed flash device should have come on, I know very well that access to the interface must be done with lan cable.

The mistake I made through SSH was to query instead of This error did not allow me to verify the correct outcome of the flashing.

Ok finally the OPENWRT Firmware is installed, the version I used for the AR750S device is the following: -generic-gl-ar750s-squashfs-sysupgrade.bin

I'm guessing that it is because the GL.inet stock firmware has wifi enabled by default. OpenWrt does not, of course, and therefore that LED will likely be off until wifi is enabled by the user.

Right... this is why it is really important to be very specific about what exactly your symptoms are and what you have tried to do in as much detail as possible -- you did not clearly indicate that you were attempting to connect to the router at until relatively recently.

Also, please refer to the documentation for OpenWrt (not the Gl.inet stuff) -- it very clearly states the address of the admin web GUI (LuCI) on this page. There is tons of useful information in the docs and wiki articles.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.