Sysupgrade "failed" on my BananaPi R3, now in boot loop

I've been running SNAPSHOT on my BPI-R3 for a few months now, upgrading (auc) every couple of weeks. Yesterday, the upgrade seemed to work, but the r3 is now in a boot loop, with this:

   Verifying Hash Integrity ... crc32+ sha1+ OK                                 
   Uncompressing Kernel Image                                                   
ERROR: Failed to allocate 0xa747 bytes below 0xc0000000.                        
device tree - allocation error                                                  
FDT creation failed!                                                            
resetting ...

I can boot the recovery system from eMMC, but I'm not sure how to actually perform recover from it.

I tried using the latest sysupgrade image from SNAPSHOT, and ended up with the same error.

I have a backup, and can start from scratch if required, but would prefer not to.
Thanks for any help

Sounds like a change was made to the device-tree that caused an issue. Usually that gets fixed pretty fast.

Are you booting off sdcard normally? Did you try a new sdcard image? If you have a spare sdcard it's worth a check.

No, been booting from eMMC as I dont trust sdcards for squat.

Recovered the "hard" way -- using tftp to flash emmc bl31 and uboot, and then the sysupgrade (perhaps I didn't need to do the last step). Then loaded my old config, and back up running now.

1 Like