Sysupgrade error installing stock firmware (EA8100 v2)

I'd like to return ONE of the two partitions on my EA8100 v2 router back to the stock firmware. Installing openwrt seemed to do it on both partitions and I'd like to correct that and maybe even temporarily run the stock firmware until some other issues are solved.

The present openwrt is accessible only via ssh, and so I've run the sysupgrade -F filename.img
but the results are always immediately:

upgrade: Commencing upgrade. Closing all shell sessions.

Command failed: Connection failed

root@OpenWrt:/tmp# Connection to closed by remote host.

Router then reboots and is effectively just reset. I've checked that the firmware is 100% and actually it was the same file I used previously.
Any help would be appreciated!

See the git-commit instructions -;a=commit;h=0c721434ea56044cdc1c13554c970b82471bc43e

@jsjsjs sound like you've had a bad day! I'm confused by the title and the substance; Are you saying you've tried to "sysupgrade the EA8100 Downloads Ver.

And I trust you've been all over the

Not much information on the TOH

You need a miracle like what @okibcn did here:

this implies the other partition is still holding the original firmware. But that is not the case.

Yes exactly. that's the file I tried to put back on to no avail.

That main doc only provides a solution to restore by resetting three times to get it onto the other partition where the original firmware resides. But if I've had to install the firmware on both partitions as a result of following the first part of that doc, then there is no original stock firmware to reset to.

Dang, I was Cheering for Jim's advice..bummer!!

Yes this is all so strange. I've worked with openwrt ages ago, but with perhaps slightly more compatible hardware that gave less issues.

Confirm that OpenWrt is actually on both partitions -

Get the current partition -

SSH in and run /usr/sbin/fw_printenv -n boot_part

Reboot to the Primary partition -

/usr/sbin/fw_setenv boot_part 1 && reboot

Reboot to the Secondary partition -

/usr/sbin/fw_setenv boot_part 2 && reboot