SysUpgrade build error on MT76x8

I'm trying to create a new build for the TP-Link Archer C20 v4 [MT76x8] but it only gives an error related to the kernel, this has happened other times but it had been resolved, now that the kernel went to version 6.1 it happened again.

Collected errors:
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 6.1.82~3b38fd3dd9ba67d6a9bedb4c2bd9ef4b-r1) for kmod-nf-reject
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 6.1.82~3b38fd3dd9ba67d6a9bedb4c2bd9ef4b-r1) for kmod-nf-reject6
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 6.1.82~3b38fd3dd9ba67d6a9bedb4c2bd9ef4b-r1) for kmod-nf-log
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 6.1.82~3b38fd3dd9ba67d6a9bedb4c2bd9ef4b-r1) for kmod-nf-log6
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 6.1.82~3b38fd3dd9ba67d6a9bedb4c2bd9ef4b-r1) for kmod-crypto-crc32c
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 6.1.82~3b38fd3dd9ba67d6a9bedb4c2bd9ef4b-r1) for kmod-nft-core
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for dnsmasq-full:
 * 	kernel (= 6.1.82~3b38fd3dd9ba67d6a9bedb4c2bd9ef4b-r1)
 * opkg_install_cmd: Cannot install package dnsmasq-full.
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 6.1.82~3b38fd3dd9ba67d6a9bedb4c2bd9ef4b-r1) for kmod-nft-offload
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for firewall4:
 * 	kernel (= 6.1.82~3b38fd3dd9ba67d6a9bedb4c2bd9ef4b-r1)
 * opkg_install_cmd: Cannot install package firewall4.
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 6.1.82~3b38fd3dd9ba67d6a9bedb4c2bd9ef4b-r1) for kmod-gpio-button-hotplug
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 6.1.82~3b38fd3dd9ba67d6a9bedb4c2bd9ef4b-r1) for kmod-leds-gpio
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 6.1.82~3b38fd3dd9ba67d6a9bedb4c2bd9ef4b-r1) for kmod-crypto-aead
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 6.1.82~3b38fd3dd9ba67d6a9bedb4c2bd9ef4b-r1) for kmod-crypto-hmac
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 6.1.82~3b38fd3dd9ba67d6a9bedb4c2bd9ef4b-r1) for kmod-crypto-sha512
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 6.1.82~3b38fd3dd9ba67d6a9bedb4c2bd9ef4b-r1) for kmod-crypto-rng
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 6.1.82~3b38fd3dd9ba67d6a9bedb4c2bd9ef4b-r1) for kmod-crypto-gf128
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 6.1.82~3b38fd3dd9ba67d6a9bedb4c2bd9ef4b-r1) for kmod-mac80211
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 6.1.82~3b38fd3dd9ba67d6a9bedb4c2bd9ef4b-r1) for kmod-mt7603
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-mt7603:
 * 	kernel (= 6.1.82~3b38fd3dd9ba67d6a9bedb4c2bd9ef4b-r1)
 * opkg_install_cmd: Cannot install package kmod-mt7603.
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 6.1.82~3b38fd3dd9ba67d6a9bedb4c2bd9ef4b-r1) for kmod-mt76x0e
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-mt76x0e:
 * 	kernel (= 6.1.82~3b38fd3dd9ba67d6a9bedb4c2bd9ef4b-r1)
 * opkg_install_cmd: Cannot install package kmod-mt76x0e.
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 6.1.82~3b38fd3dd9ba67d6a9bedb4c2bd9ef4b-r1) for kmod-nf-ipt
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 6.1.82~3b38fd3dd9ba67d6a9bedb4c2bd9ef4b-r1) for kmod-ipt-core
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 6.1.82~3b38fd3dd9ba67d6a9bedb4c2bd9ef4b-r1) for kmod-lib-crc-ccitt
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for ppp:
 * 	kernel (= 6.1.82~3b38fd3dd9ba67d6a9bedb4c2bd9ef4b-r1)
 * opkg_install_cmd: Cannot install package ppp.
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for ppp-mod-pppoe:
 * 	kernel (= 6.1.82~3b38fd3dd9ba67d6a9bedb4c2bd9ef4b-r1)
 * opkg_install_cmd: Cannot install package ppp-mod-pppoe.
make[2]: *** [Makefile:189: package_install] Error 255
make[1]: *** [Makefile:154: _call_manifest] Error 2
make: *** [Makefile:274: manifest] Error 2

https://openwrt.org/faq/cannot_satisfy_dependencies

1 Like

Always have to wait a few days then?

or use the persistent kmod repo going 3 mo back, as described in the link.

1 Like

Download from https://mirror-03.infra.openwrt.org/snapshots/targets/ramips/mt76x8/
and https://mirror-03.infra.openwrt.org/snapshots/targets/ramips/mt76x8/kmods/6.1.82-1-3b38fd3dd9ba67d6a9bedb4c2bd9ef4b/

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.