Syncthing on LEDE 17.01.4

Good Morning,

I wonder if anyone has tried to use Syncthing in LEDE 17.01.4?
I tried to use it on TP-Link wdr3600 v1 and wdr1043nd v1 and I did not succeed.

If you're referring to this service...

Yes, this service. It's have a MIPS version, but isn't work on LEDE.
On OpenWRT 14.07 it's works.

I have been running syncthing on my R7800 with LEDE 17.01.4 with no issues. Make sure you pick the right architecture and have enough RAM on the router. I am using an external USB drive as a storage.

TL-WR1043ND v1 has 32MB RAM. Certainly not enough.

When I use the MIPS version on wdr3600 v1 the service return the mensage.

Illegal instruction

And when I use MIPSLE version it's return

./syncthing: line 1: syntax error: unexpected "("

The router cpu.

$cat /proc/cpuinfo
system type             : Atheros AR9344 rev 2
machine                 : TP-LINK TL-WDR3600/4300/4310
processor               : 0
cpu model               : MIPS 74Kc V4.12
BogoMIPS                : 278.93
wait instruction        : yes
microsecond timers      : yes
tlb_entries             : 32
extra interrupt vector  : yes
hardware watchpoint     : yes, count: 4, address/irw mask: [0x0ffc, 0x0ffc, 0x0ffb, 0x0ffb]
isa                     : mips1 mips2 mips32r1 mips32r2
ASEs implemented        : mips16 dsp dsp2
shadow register sets    : 1
kscratch registers      : 0
package                 : 0
core                    : 0
VCED exceptions         : not available
VCEI exceptions         : not available

Oh, absolutely not enough RAM: "syncthing" never reported less than 25..30MB used RAM sometimes spiking up to 100MB and over. Was not an issue on a router with 512MB.

What do you get if you run the common below

file syncthing

One of the requisites of Syncthing is, that the device where is going to run, have an Floating Point Unit (FPU).

FPU is enable by default in LEDE and newer Openwrt builds in devices that have FPU by hardware, like the ARM routers

In previous builds of Openwrt, mips devices that lacks of FPU support, had FPU enabled by software emulator, but now, in the standard builds of LEDE and newer Openwrt builds FPU emulation it's disable. In order to get again support for FPU in devices that lack of hardware FPU, you need to build your own LEDE/Openwrt build and enable again FPU emulation.

Currently, I'm running Syncthing in my mips device using my custom build with FPU emulation. the performance in my MT7620N device (single core @ 580MHz) it's not good but not so bad, but definitely you need at least 128 MB of ram in your device.



Thanks for the reply.

It's works after enable FPU. I installed on three routers, a WDR3600, WR1043nd and a MR3020;

Now I have other problem, the routers can't connect over pptp connection. it's works only on a same subnet.

I installed the CA certificates and set the listening address as default and the communication between router and my laptop works.
I will try to connect two routers.