Switched to OpenWRT, degraded throughput by 85%


I've got a Linksys E8450, ran it for a few weeks on my connection using the default Linksys firmware, and I was getting (Off my phone yet) of -
Download - 234Mb/s
Upload - 11Mb/s

Idle - 20 ms / 5 jitter
Download - 184 ms / 58 jitter
Upload - 134 ms / 49 jitter

Packetloss - 0

After everything seemed fine for a few weeks, I've switched over to OpenWrt 22.03.5 r20134-5f15225c1e.

Running it, I'm consistently getting -

Download - 31.6Mb/s
Upload - 11.7Mb/s

Idle - 22ms / 6 jitter
Download - 21ms / 5 jitter
Upload - 61ms / 37 jitter

Packet Loss - 0

Its a pretty stock install, except it does run OpenVPN ONLY for a P-t-P with another site for those IPs only.

Looking at interfaces -

wan       Link encap:Ethernet  HWaddr D8:EC:5E:98:D0:E3  
          inet addr: A.B.C.D  Bcast: A.B.C.D Mask:
          inet6 addr: 2604:2000:4fc0:7:4856:1a49:c9a5:7878/128 Scope:Global
          inet6 addr: fe80::daec:5eff:fe98:d0e3/64 Scope:Link
          RX packets:142440219 errors:0 dropped:0 overruns:0 frame:0
          TX packets:37360973 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:80002583936 (74.5 GiB)  TX bytes:13304413846 (12.3 GiB)

wlan0     Link encap:Ethernet  HWaddr D8:EC:5E:98:D0:E5  
          inet6 addr: fe80::daec:5eff:fe98:d0e5/64 Scope:Link
          RX packets:22952870 errors:0 dropped:0 overruns:0 frame:0
          TX packets:39611695 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:7515291990 (6.9 GiB)  TX bytes:41135410414 (38.3 GiB)

wlan1     Link encap:Ethernet  HWaddr D8:EC:5E:98:D0:E6  
          inet6 addr: fe80::daec:5eff:fe98:d0e6/64 Scope:Link
          RX packets:25465888 errors:0 dropped:0 overruns:0 frame:0
          TX packets:46588398 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:7199336085 (6.7 GiB)  TX bytes:39529638732 (36.8 GiB)

Any thoughts/pointers/etc why it would degrade this much?

Thanks, Tuc

SQM (or something similar) keeping latency sensible?
Your original latency/ping was terrible, unusable. (134-184 ms)

Do not have SQM installed. This is basically a default install, configured for my SSIDs, network ip addressed, DHCP static leases, OpenVPN for a private IP /24, and thats it.

Is this on wifi? How fast is the Internet from a PC with a wired (gigabit) LAN connection through this router? The E8450 with OpenWrt has no problem routing at much higher than your 240 Mb ISP speed.

If you turned WMM off, wifi will be forced down to the g standard (54 Mb raw radio rate), which allows about 35 Mb throughput best case. Also make sure your country is set-- to the same country on both radios-- for best wifi performance. On the main status page you should see the radio rates and MCS for each connected client. It needs to be of course more than 250 Mb to handle full ISP speed.


This is Wifi, 5GigHz. I checked by plugging into one of the 4 ports and basically got the same speed, maybe a Mb/s or two more.

WMM is on. Country is and has been set to US the entire time. My client tends to cycle through a few different speeds. Right now its - 1080.6 Mbit/s, 80 MHz, HE-MCS 10, HE-NSS 2
1134.2 Mbit/s, 80 MHz, HE-MCS 11, HE-NSS 2, HE-GI 1. When I ran a speedtest off my Mac (Speedtest binary) I was getting 960.7 Mbit/s, 80 MHz, HE-MCS 9, HE-NSS 2
1134.2 Mbit/s, 80 MHz, HE-MCS 11, HE-NSS 2, HE-GI 1


Can you try disabling 802.11ax and switching to ac?

It might be related to this issue

Hi. Thanks. Same results, but this isn't just a WiFi issue. Same speeds via ethernet

My suggestions;

Enable flow offloading in the firewall.
Test with the vpn disabled
Traceroute your speed test site to make sure it’s not being routed through the vpn
Reset openwrt to defaults, test with only your wan connection enabled - no other config

If that doesn’t give you a hint on what’s going on then post your network and firewall configs



So, last night my home network started to get worse (10Mb/s) and worse (.9Mb/s), became incredibly intermittent and finally failed totally.

It was weird, the Linksys would stop responding, then respond again, and go away, etc. But oddly when I had a second of clarity, I checked the logs. UGH, looked like the wan connection kept coming and going. Maybe it was an ethernet cable?? So I replaced and restarted everything. Still flaky. So I put a better ethernet cable (Broke out my secret Cat-8 stash) and no better. Great, hardware issue, so immediately jumped online to get another device to sent out. Funny enough, last time I called the cable company, they said the modem I bought wasn't approved to run at the speeds we bought so I bought a replacement. But, because the wife owns the account and would have to call I never really ended up replacing it. I figured this was as good a time as any since I was completely down, and it seemed the cable provider now allowed you to do it totally online. So, I switched one Surfboard out for a much newer/higher capacity model (Has a 25G ethernet port, seriously??). I plugged the Linksys in and rebooted it.

Weird, my internet symbol on the laptop showed internet connection again. Thats weird. For giggles I tried a few googles and stuff, hrm, not bad. So I ran a speedtest on my laptop and phone.

Um, er, ah. Heh. Well, what da ya know. Somewhere between 186 and 200 consistently. (5 minute string of profanity here). The friggin modem was the issue. I guess it was a pure coincidence that the day that I moved the Linksys from Stock to OpenWRT it picked that day to start going on me. I didn't even think of it because I did a speed test MINUTES before the upgrade and got in the 180's.

I'm sorry for wasting everyones time, but things are looking good this morning too.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.