Switch VLAN Device does not get a MAC

Hi.

I have a problem...I like to add a new VLAN for my IoT devices and the VLAN device will get a MAC if connected to an old bridge device only. If I connect it to the new IoT device the MAC is not there and it cannot be used. If I connect it ti e.g. br-LAN everything is fine. Any ideas why that could happen? I fixed this in creating randomly new bridge devices and then it suddenly worked...

Cheers,
Nils



`
config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdf7:00bb:ef96::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth1.1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.178.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'eth0.2'
	option macaddr 'deleted'

config interface 'wan'
	option device 'eth0.2'
	option proto 'pppoe'
	option username 'deleted'
	option password 'deleted'
	option ipv6 'auto'

config interface 'wan6'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'
	option device '@wan'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '1t 2 3 4 6t'
	option description 'WAN'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0t 5'
	option vid '2'
	option description 'LAN'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option ports '1t 6t'
	option vid '3'
	option description 'Guest'

config interface 'GUEST'
	option proto 'static'
	option ipaddr '192.168.179.1'
	option netmask '255.255.255.0'
	option device 'br-GUEST'
	option ipv6assign '60'
	option ip6assign '64'

config device
	option type 'bridge'
	option name 'br-GUEST'
	list ports 'eth1.3'

config route
	option interface 'lan'
	option target '192.168.177.0'
	option netmask '255.255.255.0'
	option gateway '192.168.178.6'

config interface 'IoT'
	option proto 'static'
	option ipaddr '192.178.180.1'
	option netmask '255.255.255.0'
	option type 'bridge'
	option device 'br-IoT'

config device
	option type 'bridge'
	option name 'br-IoT'
	list ports 'eth1.4'

config switch_vlan
	option device 'switch0'
	option vlan '4'
	option ports '1t 6t'
	option vid '4'
	option description 'IoT'

`