Switch suddenly deconfigures

I have a very strange problem with my TP-Link Archer C7 v2....

Around two months ago I started configuring some more interfaces for splitting my network. Additionally I wanted to make those VLANs accessible for my second AP. So I came up with this switch configuration:

This worked out until Tuesday night when suddenly I lost internet access on all devices (I did not change any config since at least one month).
Solving the problem:

  • Reboot: Everything looks fine but does not work
  • Check swconfig: Looks fine
  • Reset switch with swconfig and reboot: Looks fine but did not help
  • Remove all VLANs except WAN (1): Works
  • Add the other VLANs again: works

This was strange enough....

6h later:
Same problem again... I knew how to solve it....

Next day:
So I checked for a firmware update and upgraded to OpenWrt 19.07.6 r11278-8055e38794 / LuCI openwrt-19.07 branch git-21.022.31068-7129723.

This night:
Same problem once again. At least the solution was the same, too. :slight_smile:

Conclusion:

  • Two different firmware versions
  • Switch deconfigures without any config change
  • reboot does not help
  • swconfig always shows a proper config
  • Simplifying and then redoing the config solves the problem

Does anybody know this problem? How can I solve it?

Thanks for your help
Raphael

If it does it again, can you run (if you have WiFi):

/etc/init.d/network restart

I'm quite sure I did that too, but a reboot also restarts "network" and a reboot does not help...

I would also check (keep checking, in case you notice problems next time) and taking a closer look (potential file corruption?) at /etc/config/network.

This is my config: /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd01:39ad:9459:3f00::/56'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.0.0'
        option dns '1.1.1.1 8.8.8.8 8.8.4.4'
        option ip6assign '64'
        option _orig_ifname 'eth1.2 wlan0 wlan1'
        option _orig_bridge 'true'
        option ipaddr '10.2.1.1'
        option ip6hint '2'
        option ifname 'eth1.2'

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'

config interface 'wan6'
        option proto 'dhcpv6'
        option reqaddress 'force'
        option ifname '@wan'
        option ip6prefix '56'
        option reqprefix '56'

config switch 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '6 1'

config interface 'iot'
        option _orig_ifname 'radio1.network2'
        option _orig_bridge 'false'
        option proto 'static'
        option type 'bridge'
        option ifname 'eth1.3'
        option ipaddr '10.3.1.1'
        option netmask '255.255.0.0'
        option dns '1.1.1.1 8.8.8.8 8.8.4.4'
        option ip6assign '64'
        option ip6hint '3'

config interface 'guest'
        option type 'bridge'
        option proto 'static'
        option ipaddr '10.4.1.1'
        option netmask '255.255.0.0'
        option dns '1.1.1.1 8.8.8.8 8.8.4.4'
        option ip6assign '64'
        option ip6hint '4'
        option _orig_ifname 'eth1.4 wlan0-1 wlan1-2'
        option _orig_bridge 'true'
        option ifname 'eth1.4'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '2'
        option ports '0t 2 3 5t'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option vid '3'
        option ports '0t 4 5t'

config switch_vlan
        option device 'switch0'
        option vlan '4'
        option vid '4'
        option ports '0t 5t'

Im also facing same case as yours my switch working fine

WAN working perfectly just everything using LAN disconnected due to switch deconfigured this so damn strange ngl

how i solve it : upgrade my Dell switch frimware & reconfigure all VLAN it been for like month still working greatly

  • So it wasn't working fine???
  • Just curious, how was your issue/solution related to OpenWrt?