Switch ports "disabled"?

Hi all,
first post here!
Wanna say a HUGE "thank you" for the great work in this project.

I've just set up a new openwrt router. Here the specs:

OpenWrt
Model Netgear R6220
Architecture MediaTek MT7621 ver:1 eco:3
Firmware Version OpenWrt 18.06.1 r7258-5eb055306f / LuCI openwrt-18.06 branch (git-18.228.31946-f64b152)
Kernel Version 4.14.63

The router is working as an access point for some wireless clients, and as OpenVpn peer in a ptp VPN link.
Pretty happy with it.

Only one issue, at the moment: seems the lan ports of the switch are "disabled".
When I connect an Ethernet cable to one of the switch ports of the router, the link seems to
go up, but I can't get an ip address via DHCP, and even manually setting an ip in the laptop, the
OpenWrt router does not respond to ping.
While in the wireless network DHCP is working fine.

Maybe I've messed up the lan bridge?

Seems to me the lan interface is set up correctly

br-lan:
eth0
wlan0
wlan0-1

Here the configuration:

cat /etc/config/network:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd24:2a03:8e8b::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ifname 'eth0'

config device 'lan_dev'
	option name 'eth0.1'
	option macaddr '78:d2:94:7d:d7:41'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'pppoe'
	option username 'XXX'
	option password 'XXX'
	option ipv6 'auto'
	option demand '0'
	option persist '1'
	option holdoff '5'
	option keepalive '500 2'

config device 'wan_dev'
	option name 'eth0.2'
	option macaddr '78:d2:94:7d:d7:40'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 6t'
	option vid '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6t'
	option vid '2'

config interface 'vpn0'
	option ifname 'tun0'
	option proto 'none'
	option auto '1'

and the output of ifconfig -a command:

br-lan    Link encap:Ethernet  HWaddr 78:D2:94:7D:D7:40  
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::7ad2:94ff:fe7d:d740/64 Scope:Link
          inet6 addr: fd24:2a03:8e8b::1/60 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1166405 errors:0 dropped:0 overruns:0 frame:0
          TX packets:719146 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1593912440 (1.4 GiB)  TX bytes:53729287 (51.2 MiB)

eth0      Link encap:Ethernet  HWaddr 78:D2:94:7D:D7:40  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:735959 errors:1 dropped:2 overruns:0 frame:0
          TX packets:1191083 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:121964212 (116.3 MiB)  TX bytes:1709127934 (1.5 GiB)
          Interrupt:16 

eth0.2    Link encap:Ethernet  HWaddr 78:D2:94:7D:D7:40  
          inet6 addr: fe80::7ad2:94ff:fe7d:d740/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:735948 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1190912 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:108715776 (103.6 MiB)  TX bytes:1699519192 (1.5 GiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:24108 errors:0 dropped:0 overruns:0 frame:0
          TX packets:24108 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2954961 (2.8 MiB)  TX bytes:2954961 (2.8 MiB)

pppoe-wan Link encap:Point-to-Point Protocol  
          inet addr:X.X.X.X  P-t-P:X.X.X.X  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:734143 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1189191 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3 
          RX bytes:102756643 (97.9 MiB)  TX bytes:1673280191 (1.5 GiB)

tun0      Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  
          inet addr:10.0.0.1  P-t-P:10.0.0.2  Mask:255.255.255.255
          inet6 addr: fe80::189a:96e:6691:efa5/64 Scope:Link
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:686217 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1116997 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          RX bytes:51253955 (48.8 MiB)  TX bytes:1553316667 (1.4 GiB)

wlan0     Link encap:Ethernet  HWaddr 78:D2:94:7D:D7:40  
          inet6 addr: fe80::7ad2:94ff:fe7d:d740/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:529056 errors:0 dropped:0 overruns:0 frame:0
          TX packets:334577 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:729792327 (695.9 MiB)  TX bytes:32054824 (30.5 MiB)

wlan0-1   Link encap:Ethernet  HWaddr 7A:D2:94:7D:D7:40  
          inet6 addr: fe80::78d2:94ff:fe7d:d740/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:642479 errors:0 dropped:0 overruns:0 frame:0
          TX packets:384810 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:880788455 (839.9 MiB)  TX bytes:36125299 (34.4 MiB)

wlan1     Link encap:Ethernet  HWaddr 78:D2:94:7D:D7:44  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

Do I miss something?
Any suggestion to solve the issue would be really appreciated.

Regards,
francis3

Well compared to mine your missing a;

option enable_vlan '1'

Under this;

config switch
option name 'switch0'
option reset '1

what's the output from this command (change your MAC addresses before posting );

swconfig dev switch0 show | grep -A 15 Global

Thank you for your quick answer.

Enabled the VLAN under the switch section.

root@OpenWrt:~# swconfig dev switch0 show | grep -A 15 Global
Global attributes:
        enable_vlan: 1
        mib: Switch MIB counters
PPE_AC_BCNT0: 0
PPE_AC_PCNT0: 0
PPE_AC_BCNT63: 0
PPE_AC_PCNT63: 0
PPE_MTR_CNT0: 0
PPE_MTR_CNT63: 0
GDM1_TX_GBCNT: 0
GDM1_TX_GPCNT: 0
GDM1_TX_SKIPCNT: 0
GDM1_TX_COLCNT: 0
GDM1_RX_GBCNT1: 0
GDM1_RX_GPCNT1: 0
GDM1_RX_OERCNT: 0

best regards,
francis3

Under lan you want ifname lan_dev, not eth0 -- or get rid of the lan_dev section entirely and connect lan to eth0.1.

Don't connect anything to plain eth0 when there are VLANs on eth0, use eth0.X to specify the VLAN, which is 1 for the 4 LAN ports and 2 for the WAN port.

in the lan section
I've added eth0.1 and removed eth0 as suggested.

Everything seems fine now.

Many thanks,
francis3

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.