Swapping router to BPI-R4 - PPPoE not connecting

Hi all. I'm trying to swap from a Linksys WRT1900ACS running OpenWrt 19.07.3 to a BananaPi R4 running a manufacturer provided OpenWrt 21.02 snapshot in preparation for my ISP (Zen Internet, UK) offering a greater-than-gigabit package. I'm having trouble getting PPPoE working on the BPI but I know it works on the Linksys. The ppp debug logs show both devices make an LCP config request but only the Linksys gets a response. It looks kinda like a one way connection, the BPI receives ConfReqs but its sent ConfReqs and ConfAcks don't turn up? I'd be grateful if someone can tell me what's going wrong or what config to check:

Linksys syslog (working):

Sun May 19 00:22:12 2024 daemon.notice netifd: Interface 'wan' is setting up now
Sun May 19 00:22:12 2024 daemon.err insmod: module is already loaded - slhc
Sun May 19 00:22:12 2024 daemon.err insmod: module is already loaded - ppp_generic
Sun May 19 00:22:12 2024 daemon.err insmod: module is already loaded - pppox
Sun May 19 00:22:12 2024 daemon.err insmod: module is already loaded - pppoe
Sun May 19 00:22:12 2024 daemon.info pppd[3164]: Plugin rp-pppoe.so loaded.
Sun May 19 00:22:12 2024 daemon.info pppd[3164]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Sun May 19 00:22:12 2024 daemon.notice pppd[3164]: pppd 2.4.7 started by root, uid 0
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]: Send PPPOE Discovery V1T1 PADI session 0x0 length 12
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]:  dst ff:ff:ff:ff:ff:ff  src c0:56:27:d4:e2:8a
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]:  [service-name] [host-uniq  5c 0c 00 00]
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]: Recv PPPOE Discovery V1T1 PADO session 0x0 length 51
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]:  dst c0:56:27:d4:e2:8a  src f8:13:08:40:81:43
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]:  [service-name] [AC-name acc-aln2.mr-mid] [host-uniq  5c 0c 00 00] [AC-cookie  04 8f e1 74 26 a9 8f f5 a4 9c d5 83 1c 70 05 87]
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]: Send PPPOE Discovery V1T1 PADR session 0x0 length 32
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]:  dst f8:13:08:40:81:43  src c0:56:27:d4:e2:8a
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]:  [service-name] [host-uniq  5c 0c 00 00] [AC-cookie  04 8f e1 74 26 a9 8f f5 a4 9c d5 83 1c 70 05 87]
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]: Recv PPPOE Discovery V1T1 PADS session 0x1074 length 12
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]:  dst c0:56:27:d4:e2:8a  src f8:13:08:40:81:43
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]:  [service-name] [host-uniq  5c 0c 00 00]
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]: PADS: Service-Name: ''
Sun May 19 00:22:13 2024 daemon.info pppd[3164]: PPP session is 4212
Sun May 19 00:22:13 2024 daemon.warn pppd[3164]: Connected to f8:13:08:40:81:43 via interface eth1.2
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]: using channel 1
Sun May 19 00:22:13 2024 kern.info kernel: [  134.341270] pppoe-wan: renamed from ppp0
Sun May 19 00:22:13 2024 daemon.info pppd[3164]: Renamed interface ppp0 to pppoe-wan
Sun May 19 00:22:13 2024 daemon.info pppd[3164]: Using interface pppoe-wan
Sun May 19 00:22:13 2024 daemon.notice pppd[3164]: Connect: pppoe-wan <--> eth1.2
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]: sent [LCP ConfReq id=0x1 <mru 1492> <magic 0x917fa97a>]
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]: rcvd [LCP ConfReq id=0x8a <mru 1492> <auth chap MD5> <magic 0x1f4050f8>]
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]: sent [LCP ConfAck id=0x8a <mru 1492> <auth chap MD5> <magic 0x1f4050f8>]
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]: rcvd [LCP ConfAck id=0x1 <mru 1492> <magic 0x917fa97a>]
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]: sent [LCP EchoReq id=0x0 magic=0x917fa97a]
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]: rcvd [CHAP Challenge id=0x1 <439b643c5c3fcdc2fa8fb696e630f72de737801ecb094615a4faa0f7daf7211f13055b7045a8b2bfb769569e99cdcb0205cb9fd054e665f96107f13dfe>, name = "acc-aln2.mr-mid"]
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]: sent [CHAP Response id=0x1 <ee7b0462be3383190e32347eded36b49>, name = "redacted"]
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]: rcvd [LCP EchoRep id=0x0 magic=0x1f4050f8]
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]: rcvd [LCP ConfReq id=0x1 <mru 1500> <auth chap MD5> <magic 0x9c159b43>]
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]: sent [LCP ConfReq id=0x2 <mru 1492> <magic 0xf2fa3119>]
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]: sent [LCP ConfAck id=0x1 <mru 1500> <auth chap MD5> <magic 0x9c159b43>]
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]: rcvd [LCP ConfAck id=0x2 <mru 1492> <magic 0xf2fa3119>]
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]: sent [LCP EchoReq id=0x0 magic=0xf2fa3119]
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]: rcvd [CHAP Challenge id=0x1 <55c63f80e126cbba0bbc590c775a2d98>, name = "cor1.lond1"]
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]: sent [CHAP Response id=0x1 <5306cc50688130e1b677c970e1aa506f>, name = "redacted"]
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]: rcvd [LCP EchoRep id=0x0 magic=0x9c159b43]
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]: rcvd [CHAP Success id=0x1 "Authentication success,Welcome!"]
Sun May 19 00:22:13 2024 daemon.info pppd[3164]: CHAP authentication succeeded: Authentication success,Welcome!
Sun May 19 00:22:13 2024 daemon.notice pppd[3164]: CHAP authentication succeeded
Sun May 19 00:22:13 2024 daemon.notice pppd[3164]: peer from calling number F8:13:08:40:81:43 authorized
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]: sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]: sent [IPV6CP ConfReq id=0x1 <addr fe80::fd21:f369:0b63:31c9>]
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]: rcvd [IPCP ConfReq id=0x1 <addr 51.148.72.21>]
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]: sent [IPCP ConfAck id=0x1 <addr 51.148.72.21>]
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]: rcvd [IPV6CP ConfReq id=0x1 <addr fe80::4afd:8eff:feaa:a4c7>]
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]: sent [IPV6CP ConfAck id=0x1 <addr fe80::4afd:8eff:feaa:a4c7>]
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]: rcvd [IPCP ConfNak id=0x1 <addr 51.148.148.169> <ms-dns1 212.23.3.100> <ms-dns2 212.23.6.100>]
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]: sent [IPCP ConfReq id=0x2 <addr 51.148.148.169> <ms-dns1 212.23.3.100> <ms-dns2 212.23.6.100>]
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]: rcvd [IPV6CP ConfNak id=0x1 <addr fe80::0000:0000:0000:0001>]
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]: sent [IPV6CP ConfReq id=0x2 <addr fe80::0000:0000:0000:0001>]
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]: rcvd [IPCP ConfAck id=0x2 <addr 51.148.148.169> <ms-dns1 212.23.3.100> <ms-dns2 212.23.6.100>]
Sun May 19 00:22:13 2024 daemon.notice pppd[3164]: local  IP address 51.148.148.169
Sun May 19 00:22:13 2024 daemon.notice pppd[3164]: remote IP address 51.148.72.21
Sun May 19 00:22:13 2024 daemon.notice pppd[3164]: primary   DNS address 212.23.3.100
Sun May 19 00:22:13 2024 daemon.notice pppd[3164]: secondary DNS address 212.23.6.100
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]: Script /lib/netifd/ppp-up started (pid 3287)
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]: rcvd [IPV6CP ConfAck id=0x2 <addr fe80::0000:0000:0000:0001>]
Sun May 19 00:22:13 2024 daemon.notice pppd[3164]: local  LL address fe80::0000:0000:0000:0001
Sun May 19 00:22:13 2024 daemon.notice pppd[3164]: remote LL address fe80::4afd:8eff:feaa:a4c7
Sun May 19 00:22:13 2024 daemon.debug pppd[3164]: Script /lib/netifd/ppp6-up started (pid 3288)
Sun May 19 00:22:13 2024 daemon.notice netifd: Network device 'pppoe-wan' link is up
Sun May 19 00:22:13 2024 daemon.notice netifd: Interface 'wan' is now up

BPI R4 syslog (failing):

Wed Nov  1 08:16:43 2023 daemon.notice netifd: Interface 'wan' is setting up now
Wed Nov  1 08:16:43 2023 daemon.info pppd[1995]: Plugin rp-pppoe.so loaded.
Wed Nov  1 08:16:43 2023 daemon.info pppd[1995]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.8
Wed Nov  1 08:16:43 2023 daemon.notice pppd[1995]: pppd 2.4.8 started by root, uid 0
Wed Nov  1 08:16:43 2023 daemon.debug pppd[1995]: Send PPPOE Discovery V1T1 PADI session 0x0 length 12
Wed Nov  1 08:16:43 2023 daemon.debug pppd[1995]:  dst ff:ff:ff:ff:ff:ff  src aa:42:3b:df:a1:22
Wed Nov  1 08:16:43 2023 daemon.debug pppd[1995]:  [service-name] [host-uniq  cb 07 00 00]
Wed Nov  1 08:16:43 2023 daemon.debug pppd[1995]: Recv PPPOE Discovery V1T1 PADO session 0x0 length 51
Wed Nov  1 08:16:43 2023 daemon.debug pppd[1995]:  dst aa:42:3b:df:a1:22  src f8:13:08:40:81:43
Wed Nov  1 08:16:43 2023 daemon.debug pppd[1995]:  [service-name] [AC-name acc-aln2.mr-mid] [host-uniq  cb 07 00 00] [AC-cookie  27 bc e1 76 6f b5 88 8d c4 90 9b 95 9c b8 34 8d]
Wed Nov  1 08:16:43 2023 daemon.debug pppd[1995]: Send PPPOE Discovery V1T1 PADR session 0x0 length 32
Wed Nov  1 08:16:43 2023 daemon.debug pppd[1995]:  dst f8:13:08:40:81:43  src aa:42:3b:df:a1:22
Wed Nov  1 08:16:43 2023 daemon.debug pppd[1995]:  [service-name] [host-uniq  cb 07 00 00] [AC-cookie  27 bc e1 76 6f b5 88 8d c4 90 9b 95 9c b8 34 8d]
Wed Nov  1 08:16:43 2023 daemon.debug pppd[1995]: Recv PPPOE Discovery V1T1 PADS session 0x1073 length 12
Wed Nov  1 08:16:43 2023 daemon.debug pppd[1995]:  dst aa:42:3b:df:a1:22  src f8:13:08:40:81:43
Wed Nov  1 08:16:43 2023 daemon.debug pppd[1995]:  [service-name] [host-uniq  cb 07 00 00]
Wed Nov  1 08:16:43 2023 daemon.debug pppd[1995]: PADS: Service-Name: ''
Wed Nov  1 08:16:43 2023 daemon.info pppd[1995]: PPP session is 4211
Wed Nov  1 08:16:43 2023 daemon.warn pppd[1995]: Connected to f8:13:08:40:81:43 via interface br-wan
Wed Nov  1 08:16:43 2023 daemon.debug pppd[1995]: using channel 74
Wed Nov  1 08:16:43 2023 kern.info kernel: [ 2549.008162] pppoe-wan: renamed from ppp0
Wed Nov  1 08:16:43 2023 daemon.info pppd[1995]: Renamed interface ppp0 to pppoe-wan
Wed Nov  1 08:16:43 2023 daemon.info pppd[1995]: Using interface pppoe-wan
Wed Nov  1 08:16:43 2023 daemon.notice pppd[1995]: Connect: pppoe-wan <--> br-wan
Wed Nov  1 08:16:43 2023 daemon.debug pppd[1995]: sent [LCP ConfReq id=0x1 <mru 1492> <magic 0xb6e5028c>]
Wed Nov  1 08:16:43 2023 user.warn : skip line without '=' Default
Wed Nov  1 08:16:43 2023 user.warn : skip line without '='
Wed Nov  1 08:16:43 2023 user.warn : skip line without '=' Default
Wed Nov  1 08:16:43 2023 user.warn : skip line without '='
Wed Nov  1 08:16:43 2023 user.warn : skip line without '=' Default
Wed Nov  1 08:16:43 2023 user.warn : skip line without '='
Wed Nov  1 08:16:43 2023 user.warn : skip line without '=' Default
Wed Nov  1 08:16:43 2023 user.warn : skip line without '='
Wed Nov  1 08:16:43 2023 user.warn : skip line without '=' Default
Wed Nov  1 08:16:43 2023 user.warn : skip line without '='
Wed Nov  1 08:16:43 2023 user.warn : skip line without '=' Default
Wed Nov  1 08:16:43 2023 user.warn : skip line without '='
Wed Nov  1 08:16:43 2023 daemon.debug pppd[1995]: rcvd [LCP ConfReq id=0x7d <mru 1492> <auth chap MD5> <magic 0x1eaa8317>]
Wed Nov  1 08:16:43 2023 daemon.debug pppd[1995]: sent [LCP ConfAck id=0x7d <mru 1492> <auth chap MD5> <magic 0x1eaa8317>]
Wed Nov  1 08:16:43 2023 user.warn : skip line without '=' Default
Wed Nov  1 08:16:43 2023 user.warn : skip line without '='
Wed Nov  1 08:16:43 2023 user.warn : skip line without '=' Default
Wed Nov  1 08:16:43 2023 user.warn : skip line without '='
Wed Nov  1 08:16:43 2023 user.warn : skip line without '=' Default
Wed Nov  1 08:16:43 2023 user.warn : skip line without '='
Wed Nov  1 08:16:43 2023 user.warn : skip line without '=' Default
Wed Nov  1 08:16:43 2023 user.warn : skip line without '='
Wed Nov  1 08:16:45 2023 daemon.info avahi-daemon[4996]: Joining mDNS multicast group on interface br-wan.IPv6 with address fe80::a842:3bff:fedf:a122.
Wed Nov  1 08:16:45 2023 daemon.info avahi-daemon[4996]: New relevant interface br-wan.IPv6 for mDNS.
Wed Nov  1 08:16:45 2023 daemon.info avahi-daemon[4996]: Registering new address record for fe80::a842:3bff:fedf:a122 on br-wan.*.
Wed Nov  1 08:16:46 2023 daemon.debug pppd[1995]: rcvd [LCP ConfReq id=0xff <mru 1492> <auth chap MD5> <magic 0x1eaa8317>]
Wed Nov  1 08:16:46 2023 daemon.debug pppd[1995]: sent [LCP ConfAck id=0xff <mru 1492> <auth chap MD5> <magic 0x1eaa8317>]
Wed Nov  1 08:16:46 2023 daemon.debug pppd[1995]: sent [LCP ConfReq id=0x1 <mru 1492> <magic 0xb6e5028c>]
Wed Nov  1 08:16:49 2023 daemon.debug pppd[1995]: rcvd [LCP ConfReq id=0xff <mru 1492> <auth chap MD5> <magic 0x1eaa8317>]
Wed Nov  1 08:16:49 2023 daemon.debug pppd[1995]: sent [LCP ConfAck id=0xff <mru 1492> <auth chap MD5> <magic 0x1eaa8317>]
Wed Nov  1 08:16:49 2023 daemon.debug pppd[1995]: sent [LCP ConfReq id=0x1 <mru 1492> <magic 0xb6e5028c>]
Wed Nov  1 08:16:52 2023 daemon.debug pppd[1995]: rcvd [LCP ConfReq id=0xff <mru 1492> <auth chap MD5> <magic 0x1eaa8317>]
Wed Nov  1 08:16:52 2023 daemon.debug pppd[1995]: sent [LCP ConfAck id=0xff <mru 1492> <auth chap MD5> <magic 0x1eaa8317>]
Wed Nov  1 08:16:52 2023 daemon.debug pppd[1995]: sent [LCP ConfReq id=0x1 <mru 1492> <magic 0xb6e5028c>]
Wed Nov  1 08:16:55 2023 daemon.debug pppd[1995]: rcvd [LCP ConfReq id=0xff <mru 1492> <auth chap MD5> <magic 0x1eaa8317>]
Wed Nov  1 08:16:55 2023 daemon.debug pppd[1995]: sent [LCP ConfAck id=0xff <mru 1492> <auth chap MD5> <magic 0x1eaa8317>]
Wed Nov  1 08:16:55 2023 daemon.debug pppd[1995]: sent [LCP ConfReq id=0x1 <mru 1492> <magic 0xb6e5028c>]
Wed Nov  1 08:16:58 2023 daemon.debug pppd[1995]: rcvd [LCP ConfReq id=0xff <mru 1492> <auth chap MD5> <magic 0x1eaa8317>]
Wed Nov  1 08:16:58 2023 daemon.debug pppd[1995]: sent [LCP ConfAck id=0xff <mru 1492> <auth chap MD5> <magic 0x1eaa8317>]
Wed Nov  1 08:16:58 2023 daemon.debug pppd[1995]: sent [LCP ConfReq id=0x1 <mru 1492> <magic 0xb6e5028c>]
Wed Nov  1 08:17:01 2023 daemon.debug pppd[1995]: rcvd [LCP ConfReq id=0xff <mru 1492> <auth chap MD5> <magic 0x1eaa8317>]
Wed Nov  1 08:17:01 2023 daemon.debug pppd[1995]: sent [LCP ConfAck id=0xff <mru 1492> <auth chap MD5> <magic 0x1eaa8317>]
Wed Nov  1 08:17:01 2023 daemon.debug pppd[1995]: sent [LCP ConfReq id=0x1 <mru 1492> <magic 0xb6e5028c>]
Wed Nov  1 08:17:04 2023 daemon.debug pppd[1995]: sent [LCP ConfReq id=0x1 <mru 1492> <magic 0xb6e5028c>]
Wed Nov  1 08:17:04 2023 daemon.debug pppd[1995]: rcvd [LCP ConfReq id=0xff <mru 1492> <auth chap MD5> <magic 0x1eaa8317>]
Wed Nov  1 08:17:04 2023 daemon.debug pppd[1995]: sent [LCP ConfAck id=0xff <mru 1492> <auth chap MD5> <magic 0x1eaa8317>]
Wed Nov  1 08:17:07 2023 daemon.debug pppd[1995]: sent [LCP ConfReq id=0x1 <mru 1492> <magic 0xb6e5028c>]
Wed Nov  1 08:17:08 2023 daemon.debug pppd[1995]: rcvd [LCP ConfReq id=0xff <mru 1492> <auth chap MD5> <magic 0x1eaa8317>]
Wed Nov  1 08:17:08 2023 daemon.debug pppd[1995]: sent [LCP ConfAck id=0xff <mru 1492> <auth chap MD5> <magic 0x1eaa8317>]
Wed Nov  1 08:17:10 2023 daemon.debug pppd[1995]: sent [LCP ConfReq id=0x1 <mru 1492> <magic 0xb6e5028c>]
Wed Nov  1 08:17:11 2023 daemon.debug pppd[1995]: rcvd [LCP ConfReq id=0xff <mru 1492> <auth chap MD5> <magic 0x1eaa8317>]
Wed Nov  1 08:17:11 2023 daemon.debug pppd[1995]: sent [LCP ConfAck id=0xff <mru 1492> <auth chap MD5> <magic 0x1eaa8317>]
Wed Nov  1 08:17:13 2023 daemon.warn pppd[1995]: LCP: timeout sending Config-Requests
Wed Nov  1 08:17:13 2023 daemon.notice pppd[1995]: Connection terminated.
Wed Nov  1 08:17:13 2023 daemon.debug pppd[1995]: Send PPPOE Discovery V1T1 PADT session 0x1073 length 28
Wed Nov  1 08:17:13 2023 daemon.debug pppd[1995]:  dst f8:13:08:40:81:43  src aa:42:3b:df:a1:22
Wed Nov  1 08:17:13 2023 daemon.debug pppd[1995]:  [host-uniq  cb 07 00 00] [AC-cookie  27 bc e1 76 6f b5 88 8d c4 90 9b 95 9c b8 34 8d]
Wed Nov  1 08:17:13 2023 daemon.info pppd[1995]: Sent PADT
Wed Nov  1 08:17:13 2023 daemon.notice pppd[1995]: Modem hangup
Wed Nov  1 08:17:13 2023 daemon.info pppd[1995]: Exit.
Wed Nov  1 08:17:13 2023 daemon.notice netifd: Interface 'wan' is now down

Linksys /etc/config/network:

# cat /etc/config/network 

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdcf:a209:4676::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth1.2'
        option proto 'pppoe'
        option password 'redacted'
        option ipv6 'auto'
        option username 'redacted'

config interface 'wan6'
        option ifname 'eth1.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6t'

BPI R4 /etc/config/network

# cat /etc/config/network 

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd4c:2e0e:5dc3::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'eth1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'br-wan'
        option type 'bridge'
        list ports 'lan0'
        list ports 'eth2'

config interface 'wan'
        option device 'br-wan'
        option proto 'pppoe'
        option ipv6 'auto'
        option username 'redacted'
        option password 'redacted'

Lan0-3 are gigabit ethernet, Lan0 is marked WAN. Eth1 and 2 are 10gbit SFP+ ports, eth2 is marked WAN. I'm using lan0 at the moment, I intend to use eth2 in future.

There isn't really any point trying to debug the vendor SDK, it's old and uses a very different kernel and other proprietary bits and pieces.

It appears you are using firmware that is not from the official OpenWrt project.

When using forks/offshoots/vendor-specific builds that are "based on OpenWrt", there may be many differences compared to the official versions (hosted by OpenWrt.org). Some of these customizations may fundamentally change the way that OpenWrt works. You might need help from people with specific/specialized knowledge about the firmware you are using, so it is possible that advice you get here may not be useful.

You may find that the best options are:

  1. Install an official version of OpenWrt, if your device is supported (see https://firmware-selector.openwrt.org).
  2. Ask for help from the maintainer(s) or user community of the specific firmware that you are using.
  3. Provide the source code for the firmware so that users on this forum can understand how your firmware works (OpenWrt forum users are volunteers, so somebody might look at the code if they have time and are interested in your issue).

If you believe that this specific issue is common to generic/official OpenWrt and/or the maintainers of your build have indicated as such, please feel free to clarify.

I was also sceptical of making an unverified vendor image internet accessible but they have hardware offload while current snapshots don't AFAIK.

You were absolutely right to suggest switching to a known good image. I loaded up OpenWrt SNAPSHOT r26355-52a225cba4, installed Luci, set up pppoe on the WAN bridge and it worked first time. Thank you!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.