Supporting ZSUN Wifi Card Reader (16MB Flash, 64MB RAM, AR9331)

@puteulanus ... upgrading from 20190603-openwrt-18.06.1 to 20190606-openwrt-18.06.1-rec requires all steps mentioned in the 18.06.1-rec announce message or is the u-boot already the same?

...or is an even newer version in your pipeline and skipping the *-rec version would make sense?

Do the non-rec and the rec version require different imagebuilders?

Questions over questions... what about collecting the answers in a (or your GitHub-)Zsun-wiki?

1 Like

Yeah, upgrade from 18.06.1 to 18.06.1-rec need all steps, the u-boot are different.

I have removed 18.06.1 building to avoid confusion. Thought 18.06.1 still can build from source, I recommand to use 18.06.1-rec.

Non-rec and the rec version has different image struct, so they need different imagebuilders.

@catalinii In 18.06.1-rec I add kmod-usb-storage and mount my tf card seem works Supporting ZSUN Wifi Card Reader (16MB Flash, 64MB RAM, AR9331)

3 Likes

@puteulanus, great work on the recovery feature. It already saved my device once.

Yes with 18.06 I was able to get the sdcard to work, thanks for that. I believe the issues was on version 17.

Thank you

3 Likes

Thanks for everyone involved in the port, especially puteulanus.
My situation is that my Zsun device is still untouched. So it is the original firmware and no openwrt or LEDE on it.
I'm a bit confused about the changed u-boot and I don't understand where I should start.
I guess there is no way to flash the newest version right away, but what version is the recommended version to start from? Can someone point me to the right direction where to start from and what order is recommended?

1 Like

I will be getting two new devices in a week or so (customs is slow here) if nobody beats me to it, I'll try to write down the exact steps to get them up and running with the latest openwrt we have available including u-boot.

3 Likes

where can you find these devices?

Got mine here:

2 Likes

Can someone post the instructions needed to get OpenWRT on zsun? I have one flashed with OpenWRT from 2017. Do I need a new u-boot?

Let's wait for @JuggernauT to solve this... in a week or so we all should know more :wink:

1 Like

I had my first try yesterday, failed miserably but didnt brick anything...
Hopefully another attempt today.

/J

3 Likes

I cant even install openwrt on my Eaget A50. I have tried the samba method now both on linux and windows and all I get back is Status -2 or something like that.

I would like to try the socat method again, because that is what worked last time (and first time) I tried, but that was many years ago, and I cant seem to find the files I need to get that method to work. You need openwrt-ar71xx-generic-zsun-sdreader-kernel.bin and openwrt-ar71xx-generic-zsun-sdreader-rootfs-squashfs.bin. Anybody know where to get those? Most of the links supplied earlier had a time limit or has been removed. Sadness.

So it seems I am on pause until I know what I did wrong with the samba method or if the files for the socat method reemerges

Cheers,
/J

sources are always ready , i test for compile at this time

but .. problem … ???

I will try to set up a virtualbox and see if I can compile the sources... it seems my native installation (Fedora 30) cant anyway...

for compilation i use debian and i can compile openwrt without problem

make -j4 abort and requiert to look log after run make j1 -V=s …

I am not a native english speaker so not sure what you are trying to say.

"i can compile openwrt without problem"

seems to contradict

"make -j4 abort"

Last time I tried and succeeded I used ubuntu, many years ago.

@JuggernauT here are copies I have of those files (including checksums just in case).

openwrt-ar71xx-generic-zsun-sdreader-kernel.bin
SHA-256: 6E63F123DA72076157C01479680678972292D4191485228C795EABFF57FCAE1A
openwrt-ar71xx-generic-zsun-sdreader-rootfs-squashfs.bin
SHA-256: 0E252D9F4BC496FEF8A67F0EFBDB8CC3BF2FA08BB1B7115D8D4AB8E02660CE96

Hope they help.

thanks... I just realized that they are actually contained in the SD100*tar.gz file, which I do have... so I had them all along... ah well, its slowly coming back to me now =)

/J

2 Likes

yes , i can compile without errors normal git files

but with zsun git i make -j4 and i have error : -> make -j1 V=s for find the problem ...

Ok, bricked my first device, hopefully not forever.

So I managed to get openwrt 15.05 on there using the tftp method. The samba method did not work for me in Windows 10 or Linux (Fedora 30).
After that I installed the lede-unlocked, because it is bootable from two points,
The lede-unlocked.bin is a special firmware, with two kernels one at0x9FBE0000 and one at 0x9FEB0000.
So far so good. Next step is to install the new u-boot. so I scp:ed the file over to /tmp on the device
scp u-boot_rec.bin root@192.168.1.1:/tmp
Then I ssh:ed in (using putty) and did:
mtd write u-boot_rec.bin u-boot
and then I cleared uboot env like this:
mtd erase u-boot-env
This uboot is supposed to be able to boot from 0x9FBE0000 and 0x9FDE0000, the first one of which is supported by the lede-unlocked.bin that is installed.
I then executed the command reboot from the device in the hope that it would boot from the new u-boot still booting lede-unlocked.
But that did unfortunately not happen. It blinks three times, then the led is not flashing anymore and no interface shows up. If I put an sd-card in the device while it blinks it mounts it so I have access to the sdcard from linux.

Where did I go wrong here?

/J

I just successfully flashed an Eaget A50 (ZSUN clone) with the new uboot and rec firmware exactly like
puteulanus described.

What's the easiest way to get a firmware with openvpn precompiled? I can't seem to get it running. Can anyone help? I don't need OpenVPN help, we need a fix like this:

because something's wrong in the image provided as I got an error referencing liblzo as well as kernel dependency errors with openvpn as in link posted above (sorry for linking but guess it's needed to understand what's my problem)

.

1 Like