Supporting ionik Wifi Cloud Hub (8MB Flash, 64MB RAM, RT5350F, battery, 8€)

Hello everybody!

I wonder if this portable battery powered device will get LEDE support?

*System-On-Chip: Ralink RT5350F system-on-a-chip, running at around 350MHz
*Flash: cFeon Q64-104H - 8 MBytes NAND flash chip (ENQ64-104HIP)
*RAM: 2x32MBytes SDRAM chips
*USB Port: 1x USB A Host Port, 1x micro USB Port (data & charging)
*SD Card Reader
*Battery: 1900mAh rechargeable
*Serial: yes - inside
*And more like a button, reset hole, a RGB LED, ...

Very nice hardware/software summery and source:

The device is very cheap but not usable with the stock firmware

There is also a device called Strontium Mobile Wifi Cloud (Sri-CUBa-3KW) with same specs but a bigger 3000mAh battery.

And two interesting youtube videos about the (maybe most shitty) vendor/stock firmware on earth:

How safe is a Wifi Cloud Hub Router (from hackers)?

Showing various security issue of the Wifi-Cloud Hub

Just found this one here:

Porting OpenWRT to ionik Wifi Cloud Hub:

Interesting little UFO, especially at the price

Looks like there are some RT5350F-based devices already supported:[CPU*~]=RT5350F

I didn't immediately find a US source, so I probably won't be tearing into one. Edit: doesn't appear to carry it either

Any idea on the battery life? I know an ESP8266 consumes around 15 mA in "light sleep" and significantly more with the radio active, so I'd imagine you'd need to keep it on the USB adapter. Still, at under 10€, looks interesting. Might have to have one shipped to me on my next European trip.

Yes, looks like most of the work is done. There is something like a build recipe specially for this hardware here (
... even with LED (without E :wink: ) support.

I have no idea how to build it or how to get official LEDE support for it? Anyone know's what to do? :relaxed:

on you will find the Strontium Mobile Wifi Cloud with a 3000mAh battery but the price is $40


Power consumption

The measurements were taken with a USB power monitor, so don't expect any precision. Since they were taken on the 5V voltage, you need to convert everything to the battery voltage or use Watts for a precise power estimation. The unit does some kind of trickle charging that can vary/increase the 5V current by 100mA during certain periods.

Example: 340mA @ 5V is about 531mA @ 4V (on battery, assuming 80% converter efficiency). Or 1.7W, easier to work with.

Idle, bridge mode: 340mA. Estimated battery time 4h8m.
As above, but with a USB stick plugged in: 400mA. This means that just plugging in a USB stick reduces the battery time by 1h18m to 3h30m.
Copy 8GB of data from HFS+ USB stick (Apple-formatted) via Samba (network): 540-640mA.
Cpu at full load seems to take ~70mA of current, so only a 20% increase.
With all network interface disabled, at idle: 260mA.
Unit off: 10mA or 100mA. The 10mA is likely from the blue LED, the 100mA is the trickle current as noted above, it does not draw this at all times.
Unit off, USB and SD inserted: 170mA. It seems that just the USB interface by itself is drawing 70mA at all times.

With the above data I can derive the consumption of various components:

baseline: 1.3W
USB inserted: 0.35W
CPU max TDP: 0.35W
WiFi: 0.4-1.2W


But I'm almost sure the values will be much better on LEDE (I have another 3050F device with same battery and it runs for ages!)

I'm currently packing up all this info into a 18.06.snapshot (post .2 from 2019-03-01) , as these pods are currently available even as low as €2 .
Works fine, and I'll published some images soon. However I didn't commit anything back, so let's try this as a first-timer :slight_smile:

  • Currently a bit struggling with forced enabling of Wifi, where I didn't find a canonical solution which the Wiki pages indicates, so built a new one for the ralink target only. Maybe someone ones about the proper approach (cite Wiki: " If the device has ethernet ports, the wireless is turned OFF by default.") ?

  • USB modules didn't load properly for some reason, so added a bunch of modules to the .

  • firmware upgrade from the gui seems to require a padded uboot image included, so currently firmware upgrade will be only via telnet access or serial console to the rescue image.

  • TODO: trying to get rid of the rescue image if everything works, because this gives 1MB of valuable flash to jffs.

edit openwrt/package/kernel/mac80211/files/lib/wifi/

at the end of file remove this line:

Yes, this works, but would enable wifi on all devices. There is obviously a reasoning behind to not do this (see the wiki article on wireless), although I don't really see the point.
However, I build a uci-defaults script, postponed until wireless config is generated, which enables wlan for this particular board.
I was asking because the wiki implies there is already such a script, which I'm unable to find.

Anyway, if anyone wants to give it a try:

To flash from USB:

# root/91657853
cd /media/Disk1
# cd /media/sda1
mtd_write write openwrt-18.06-snapshot-r7704-9ee8c8daf4-ramips-rt305x-ionik-cloud-hub-squashfs-sysupgrade.bin mtd5

This works for LogiLink UA0175, WL0156, possibly WL0157, WiFi-S1 ...

gpios works, again.
Messed up the dts before when trying to get uartf running...

Did anyone test this out, and maybe found glitches?

I found one problem, the box seems to fail on creating an encrypted AP; unencrypted AP or station (any) works... actually didn't use this until yesterday...


I just got a bunch of this devices (for 2 €) :open_mouth::smile:

can you please specify what you mean by "encrypted AP".
Is it no WPA or WPA2 or just no SSL Login.


It's WPA2 that does not work, didn't try WPA.
But honestly I didn't test any further the last months and try to find a reason or fix...

1 Like

@netadair can you maybe give some more details on your build configuration. I would like to have a try to build the kernel image by myself and to check some options on the WPA2 stuff...

1 Like

@Opal @netadair so I tried a little bit. It could be the date and time has to be set before WPA2 is working. You can also first of all start with WPA/WPA2 mixed and later switch to WPA2. Thats how WPA2 worked without any changes on the firmware of @netadair for me.

1 Like

Hello schreinerman,

at the moment I'm still stuck at aonother project. But the next one I'd love to do is to "dive deeper" into this device.

@netadair I second this request.

can you maybe give some more details on your build configuration.

This would give a proper starting point :slight_smile: