Support TP-Link Archer C6U v1

Hi friends!
Please tell me when you can expect support for this router? Archer C6U v1


There is a PR pending for the EU version:


Very good news! I am glad to hear it.
I hope this will also work for the RU region.
Thank you guys. I'm really looking forward to it! With love

1 Like

OpenWrt: TP-Link Archer C6U v1

1 Like

Support has been merged into master, but we need testing on 21.02 if you want this device available in 21.02. I have created builds based on 21.02 HEAD (they will be almost identical to RC2, which is around the corner).

Images can be found here. Please test (do not keep settings when flashing from master) and report back if everything works. At this point the difference between master and 21.02 is rather small, so I don't expect there to be any issues.

I'll add your forum names to the patch for 21.02 - if you want to be mentioned in a 'formal' Tested-by, you can provide your real name and e-mail address through PM, but that should not be necessary.

I'm asking for testers since the developer who merged support into master would like actual testing before backporting it to 21.02 (which makes sense), but I don't have the device myself.

Thank you!


2 problems in using openwrt on archer c6u v1 (ru):

  1. For some reason, it is no longer possible to update from the stock firmware to openwrt (not so long ago it still worked)
  2. After downloading openwrt to the router, the ethernet port of the router through which the firmware was loaded stops working, the computer cannot get the ip address, it helps to rearrange the network cable to the neighboring port of the router (but not always).

I always collect fresh openwrt from the master branch to the github before flashing.

1 Like

Hey guys, there is a broader backport effort going on, with the C6U v1 amongs the devices. See this mailing list post.

Please test those, @ynezz has built 21.02 images for testing.


I downloaded the source code for version 21.02.0-rc2 and manually applied the patches.
The stock firmware accepted my openwrt build without any problems.
(the version back to the stock is attached)

I have been testing for three days and the only thing that does not work stably is the switch.

1 Like

Can you reproduce the switch issue?

Yes. This issue haunts me in any of my assemblies. No matter how many times I do it again.

Flashed mine with 21.03-SNAPSHOT today and everything seems OK except for PPPOE failed to connect.
I was crying about that in related PR and @Borromini mentioned that its probably related to open bug anybody knows more? Any advice?

Stock firmware TP-Link refuses to accept OpenWrt v21.02.0-rc3 and latest snapshot

Current OpenWrt v21.02.0-rc3 factory image support only EU version. Which version do you have?

@Kovalets In all likelihood they bumped some compatibility number but it might be something different as well. I thought hexdump -C on the image might reveal what's being used now but I'm not seeing it. Might have been some other command.

Either way, you can see the values OpenWrt uses in the tplink-safeloader.c code:

I think the issue here is with .soft_ver; the binary I grabbed mentions version 1.0.4 in the name (image is dated 2020-12-30). So try changing line 1141 to 1.0.5 and see where that gets you, I'd say.

How its going? I want to buy it eventually for daily use. Is switch working or still some troubles?

I successfuly flashed openwrt via oem gui - 21.03-rc3.
PPPOE working fine till now, tried to transfer some big files and all ok.

Just installed it yesterday. Looks to be working fine so far (switch, wifi). Haven't tested some 4g usb card, though (I'll get back).

BusyBox v1.33.1 (2021-07-13 05:58:18 UTC) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 OpenWrt SNAPSHOT, r17119-1236cbe30c
root@OpenWrt:~# uptime
 09:41:07 up 11:47,  load average: 0.06, 0.01, 0.00
root@OpenWrt:~# uname -a
Linux OpenWrt 5.4.128 #0 SMP Tue Jul 13 05:58:18 2021 mips GNU/Linux
root@OpenWrt:~# cat /proc/cpuinfo
system type             : MediaTek MT7621 ver:1 eco:3
machine                 : TP-Link Archer C6U v1
processor               : 0
cpu model               : MIPS 1004Kc V2.15

The assembly for EU works great on the RU version as well.
I see no reason to link to a specific region.

FYI - OpenWrt 21.02.0 support is available now.

Please open new topics for any remaining questions.

Thanks! :slight_smile:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.