Support of Fritzbox 7530

For comparison, keep in mind that the Netgear D7800 is in a similar situation. Available since 2015, QCA IPQ8064 combined with a lantiq VRX320 modem, while the router itself is supported, the modem functionality isn't available. While this (for both devices) shouldn't be impossible to get working, it would require significant work on these specific combinations.

Very interesting what you say. When you say "significant work" could this be a matter of months/years or maybe just of couple of weeks of focused work for an experienced person?
I would be really interested doing this work for all of us if I knew how to do it, even if it took months, but unfortunately my professional expertise lies outside the technology sector. I guess this is not a realistic target for a novice in that field like me, isn't it?

It means diving into the unknown, because it's a previously "unseen[1]" combination.

[1] within the scope of OpenWrt supported devices.

@blocktrron Did you get the serial console of the fb 7530 fully working. I am able to get data from the fritzbox, but cannot send anything to it. I've already tried an 10k pull-up on the rx line without success. Is there anything else to equip apart from the 4-pin-header?

The Serial console works for me without further modifications in both directions.

Are you connecting with the mapping described in the patch?;a=commit;h=95b0c07a618fe5fd93a26931152ced483bba143b

Yes, I'm using this mapping and I also can the data on the rx-pin with my oscilloscope. My thought was now that perhaps still somewhere something must be equipped.

@blocktrron Can you please have a look at your pcb if the marked pads are also open on yours?
The route from "my" Rx-Pin seems to end there.

I can have a look later this week. However, judging fro mthe pictures here suggests this is fine:!Box_7530

Other thought - which USB --> UART adapter are you using? I've found the cheap FTDI knockoffs not very reliable TX-wise in many cases - I've had much better experiences with a CP2102 based adapter.

Hmm... the board looks a little bit different than mine.

I don't use an USB -> UART adapter at all. I use a "real" ttyS0 / UART from my PC with a little MAX3221 adapter for the level shifting.

Is this device NEVER going to get a stable release due to DECT being impossible to support?

If so that seems an interesting stipulation as its been FAR more stable than my Archer C7 v2 was and that WAS in stable, when this is not.

The 7530 will be supported in the upcoming OpenWrt 19.07.0 release (and already is in snapshots), be aware that DECT support is unlikely to ever materialize and that the xDSL modem won't work for the time being either (this is more likely to become supported in the future than DECT, but it's also far from a done deal and will require significant efforts to get working - which might not happen either).

The 4040 might be a better option for running OpenWrt now, as it's basically the same hardware (for just over half the price of the 7530) - except for the functionality (xDSL modem/ DECT/ FXS) not supported in OpenWrt (yet) anyways.

That's good to know, I was just confused what qualifies a device to make the move over as its been in snapshots for quite some time now and performing great. (I use it most as an AP only but have used it as a 4G router too to link my phone into my pfSense router)

I got the 7530 for free from my ISP so cost was not an issue.

Is it possible to change back to AVM-stock firmware? The guy in this post:

had problems. I think, it could be because of repartition the flash. Anyone successful?

Could it be it won't work with new FritzOS 7.12?
when i try to write uboot.bin to /dev/uboot0, it says this file doesn't exists. A ls -l into /dev:

no uboot0, no uboot1.

OK, last post solved. Downloaded newest snapshot and installation was without problems. Also seems i mad a mistake, the write has to be to uboot0, not /dev/uboot0.

I had the same problems. First the message 'Incompatible memory layout'. At some point I tried to load the image with eva_to_memory. That does not work either. So back to the AVM recovery tool. All at once mdt0 was flashed. Another try has flashed mtd1. So I've run the recovery tool several times it worked.

But hey ... I'll be back to OpenWrt immediately;)

Thank you. I want to know it only to be safe i could go back if i need the box' dsl-part. In the moment i'm happy with it under open-wrt. Use it as firewall behind a fritzbox 7390 for a separate network.

Great work! :smiley:

What's the current state of the VDSL modem?
Would it be possible to use the binary AVM VRX518 kernel module against the OpenWRT kernel for now?

What is the procedure to reset to openwrt default config?