Support MA5671A SFP GPON

No, I did not connect the device via UART. I don't have a 20 pin connector. I am waiting for his admission. As soon as I get it, I'll try to connect it.

Can someone upload the latest firmware from right.com.cn (2023.10.20)? I have been trying to create an account on Baidu, but it needs a mobile phone and Spain is not available :frowning:
https://www.right.com.cn/forum/thread-8220173-1-1.html

Good afternoon, how to enable the web interface on the Ma5671a, I mixed up the firmware and in it without a web interface, or how to flash it via SSH

I got the firmware from there

6BA1896SPLQA42_MODDED_ver5-1.img

@Askar, that firmware doesn't come with any kind of web-interface. I should know, I've been hacking on it to try and add one back. >:p

You could try one of the others on that site that does still have one, but be wary of messing up your device.

If you're the sort to dig in deep, you can pull the packages from the same version of OpenWRT that it is running (I think it's a 2017 build? You can double-check it.) and then scp them over one at a time and try to get them running, but like I said, I've been trying myself, and it feels like one hitch after another.

I need help.

When I bought my SFP, it came with OpenWRT firmware already installed, including a web interface. However, when I tried configuring VLAN settings, I couldn't find them, thinking it might be due to outdated firmware. I found a firmware update on a forum and installed it, but afterwards, the web interface disappeared.

Now, how can I restore the web interface? Is there firmware available with a web interface?

HELP....

@Askar, you're asking the same thing again with a slightly different story.

Presuming this is the same stick you posted about 2 days ago, ideally you would have backed up your original firmware before flashing (as most tutorials for flashing custom firmware suggest), presuming you didn't do that.

If you originally had the stock MA5671A firmware, you could attempt to load the rooted variants from the Hack-GPON page, but I'm not sure if they start it by default.

You could also inquire in the Telegram channel, as they're the ones doing the mods and roots.

I did the same error as you did ^^
my issue is that the SFP is now reporting the following :

 module Lantiq           Falcon SFP       rev 0    sn xxxxxxxx dc xxxxx
[ 6685.511622] sfp sfp2: module transmit fault indicated
[ 6690.921602] sfp sfp2: module persistently indicates fault, disabling

and I cant get ssh access to it or even ping it...

I can still use serial to connect.
I've tried reflashing it back to the original with Huawei root fw, but I still get the error...
I think i need to correct the eeprom information but I dont know how to do this without having ssh access...

That said, I do get (thanks to the serial access) to this:

 OpenWrt - (14.07_ltq) --- Lantiq Edition for GPON
 ----------------------------------------------
root@(none):/# sfp_i2c -d yes
EEPROM 0 address 0xFFFFFFFF set failed, ret=80

As you can see the eeprom is not loaded yet, as I am accessing the failsafe mode during boot ^^....
Anyway, I dont really know what I am doing but I am trying to recover my SFP and get it to answer a ping so that I can connect with SSH or other...
Also, I dont know which firmware I should be using... stock fw rooted, or carlito, or well I am giving up on the GPON-ONU-32 Mod FS which screwed up my setup :-p (seems not natively supported by Openwrt)

Hello, Just want to share my update.
My sfp is now up and running. I can connect to it.
Using the FS modified fw.

Quick advice (that got me struggling for few days...), ditch your serial usb adapter... as explained way in this thread, they do not provide enough power to the SFP and reboot constantly which is a pain to handle... Use another device or an RPI (with enough power supply) and you will have a good UART to handle things.

If you use the FS modded FW for the MA5671A or I would think any other fw... do note that the Lantiq default values (who knows why...) are not in the drivers set of the current snapshots... so change your model name after you have modified the FW and you will see that it loads correctly.

Cheers! and than you all for this post that has helped me and many a lot!

anyone found why there is no igmp traffic with this ONT ?? i'm actualy facing the exact same problem here : IPTV / UDP multicast problem - #7 by lleachii