Support for Xiaomi Wifi R3P Pro?


#142

@pjgowtham hahaha i think i understand what went wrong... now that you mention the word "sysupgrade"... that may or not be working (oops... can't say i've tested it myself...)

why don't you try doing a regular installation (good ol' mtd write and all that...) at least that way we'll all be on the same page. in fact, i'll just give you the command (since you say you're coming from RC1):


dd if=factory.bin bs=1M count=4 | mtd write - kernel
dd if=factory.bin bs=1M skip=4 | mtd write - ubi

(and no, don't need to use the kernel.bin file unless you're using tftpboot)


#143
root@OpenWrt:/# dd if=factory.bin bs=1M count=4 | mtd write - kernel
Unlocking kernel ...

Writing from <stdin> to kernel ...  [e]4+0 records in
4+0 records out

root@OpenWrt:/# dd if=factory.bin bs=1M skip=4 | mtd write - ubi
Unlocking ubi ...

Writing from <stdin> to ubi ...  [e]5+1 records in
5+1 records out

Also tried rolling back to the RC1 with MTD and then reinstalling RC1+new drivers again with MTD
Same results. No change.


#144

@pjgowtham ... and then.... did you remember to reboot?


#145

yes i did reboot. Even repeated the process 2 times, just in case. Maybe i should go back to stock and start over again?

Tried the steps mentioned above mentioned to go back to stock. It doesn't seem to work.


#146

Flashed OK
how about stability - let's see


#147

Have you already seen this: MT7615 WIFI chip sources ????


#148

When I try insall xl2tpd - The installed version of package kernel is not compatible, require 4.14.103-1-eb8ed4b9…while 4.14.103-1-a89f6349… is installed.

Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for xl2tpd:
  • kernel (= 4.14.103-1-eb8ed4b9bf234e78fd5debca12157d30)
  • opkg_install_cmd: Cannot install package xl2tpd.
    :sob:
    Help! I need l2tp vpn server!!!:scream_cat:

#149

Welp. I bricked my router. Not because of the firmware but me. I flashed the official firmware mistakenly as factory.bin with mtd.

The flash drive method doesnt work. I get repeated switch on and switch off from my router. The router briefly connects and disconnects.

I don't know what IP address to set and file name to punch in with TFTP. @ilyas help me out. What's this miwifi repair tool available on the official website.

EDIT : Xiaomi router repair tool currently supports Xiaomi router 4, 4Q, 4C brush machine;
Ordered a UART to USB cable just in case.


#150

WiFi speed is very low.:disappointed_relieved: no vpn server. :):disappointed_relieved: go back to RC1 version. No vpn, but wifi is quick...
Whatever, thanx for your work!


#151

Yes, wifi speed from device to router is normal, but device to Internet is stacking at 40Mbit/sec... If you want vpn (server/client), you can just search Google, how to install it with opkg))) you can install anithing you want to openwrt))


#152

@pjgowtham sorry to hear about your troubles... I might have (at some point) also flashed stock firmware by accident. don't worry it's not the end of the world. what you really need though is a UART. once you're on the console it's pretty easy to tftpboot (or change the settings so you boot into the "recovery" partition). without that, i really don't know how you can get it back.


#153

Thanks for your input .It will take a few days for the cable to arrive. Once I get it back up, i'll continue testing for you.


#154

@pellmen yeah the speed wasn't too amazing... i changed some compile-time configuration flags (more or less randomly, i must admit) and i'm getting much better speeds now.... ~115-120mbps on 2.4ghz and ~290mbps on 5ghz...

as for your internet speed being slow... all i get here is 16mbps anyhow (sucks) so i can't really test that. what i did try is to configure the mir3p as a dhcp client and a sub-lan (192.168.2.*) behind it. that should be exercising the "internet access" path. i then ran an iperf3 server on a raspberry pi on my regular network and an iperf3 client from within the mir3p's sub-lan. the speed i get is the same for wired/2.4ghz/5ghz : all around 94mbps (we have a 100mbit lan here).

So I'm uploading the "new" stuff now.

Edit: https://github.com/iscilyas/openwrt-r3p/releases/tag/v0.1-rc1%2Bmt7615e-2


#155

@splash ... actually the kernel versions are compatible (of course)... the packaging system is just being paranoid. if you were to manually extract the files (.ipk is just a tgz under another name) it should all work...

anyway, in the hopes of not losing a customer, i've uploaded some packages that seem like the ones you need (on the latest release page). hope they work.


#156

@ilyas I've tried too update through "flash update" in first screen from web-interface using *sysupgrade.bin and got unlimited reboots))) I'll buy uart tomorrow and try to restore it)) lol)))


#157

@pellmen whoops... are you serious?
i might have botched something... sorry about that. i'll take another look. a uart is a good idea in general, though :wink:


#158

If anybody wants to document the activities to get this device supported by OpenWrt:

https://openwrt.org/inbox/xiaomi/xiaomi_r3p_pro

Feel free to add helpful information regarding hardware data, supporting activities, images to install and how to install them.


#159

@ilyas yes) there's no chance to recover it without uart??? It connects for a few seconds then reboots. I've tried to hard reset it - the same problem. I can't enter ssh because of time, that I have connection to router.


#160

@pellmen when you say "connects for a few seconds"... you mean the lan light turns on? (well... nevermind... it's not like i could do anything with the information anyhow)...

the only thing i can think of (when thinking of @pjgowtham's similar problem) is maybe doing that 30/30/30 reset thing to reset to default settings (not that i know if that works either....) to force the bootloader to boot openwrt (instead of stock at kernel0) we've tricked it into believing that kernel0 (kernel_stock... whatever) is "bad" and so it insists on booting "kernel". if that 30/30 reset thing were to reset the nvram values to their default state, then it would try booting kernel0 and you could do the usb recovery thing....

and i'm really sorry for that sysupgrade.bin botchup... i was hoping to get good news from you that the internet speed is amazing (etc etc)....


#161

Tomorrow it will be so))))

Led is orange always without blinking. I've tried to revert to stock from usb - nothing happend. Dhcp working well and Internet connection's alright, but only for a few seconds. I've tried tricks with reboot button and power, but the same trouble.