Support for Xiaomi Wifi R3P Pro?


honestly i don't know. i don't think this has anything to do with the R3P.. maybe see if there's a support forum for firewall?

Yes. This is what I have to do every time the router restarts. :frowning:


what does /etc/config/wireless look like? (it will also have your wifi password in it, so maybe edit that part before posting it)... but in general, if wifi is disabled it should have something pretty obvious like "enabled = 0" or "disabled" in it)

also, is wifi (wlan0, wlan1) in the bridge? check that (brctl show ... or in the luci interface). it almost certainly is, but i'm having a hard time imagining what could possibly make it do that (there was nothing in the log you sent... maybe it was from too-early boot and there would have been later messages... don't know). channel isn't 'auto' is it? (it shouldn't be)

test with:

uci set wireless.@wifi-device[0].disabled=0; uci commit wireless; wifi

always a problem reset all and reflash with sysupgrade firmware

Hello everyone.
Last year I switched to openwrt 4.14.111. Now I want to upgrade, I downloaded version 4.14.132 from iscilyas and lates official firmware. I tried to upgrade via sysupgrade, but after restarting, the LED lights up yellow, does not even blink. I go to ssh after the update, but there, as before, the kernel version 4.14.111, neither the Internet nor Wi-Fi works. At the same time, returning through sysupgrade back to version 4.14.111 works well. Router is reloaded normally, the LED turns blue, the Internet and Wi-Fi appear.
I was switched to openwrt from a pandora without pdboot. Maybe i need to reflash factory.bin somehow? Or may be i need additionally flash some blocks like: cat kernel1.bin factory.bin | mtd write - firmware

I'm still running @ilyas v4.14.111 build, with uptime >90d without any issues.
Can You give me quick update, how does the upstream OpenWRT (with open drivers) perform against it?
Does the update bring benefits?

Hi Guys!
So being tired of the Xiaomi rom for the R3P I decided to flash the latest snapshot of Openwrt on the router.
After installing LuCi everything seems to work kind of normally, however just like other users reported, the WiFi will not come automatically up after boot. I checked the /etc/config/network and /WiFi and the "disable" options for all the interfaces are set to 0, the only way I have to make the WiFi work after boot is to ssh into the machine and send a ''wifi'' command, that way the SSID starts to be broadcasted correctly and I can use the WiFi as long as the router will not reboot.

Is there anything I can do to make the WiFi work correctly? Thanks a lot!

Do other changes stay after the reboot?

Hi Andrey!
Yes, all the other settings are maintained.
This morning another user of the forum proposed a solution to fix the WiFi issue, basically by disabling the async loading of the WiFi driver. This way I was able to bring WiFi on boot correctly and start using the router :slight_smile:

How to do it? Im with same problem as u.

As reported by the other user:

edit /etc/modules.d/mt7615e , remove the async_probe

1 Like

@anon69880279, I did all as you saad, but do not work.

I reflash again and after reboot, the wifi do not active.

Got it working, thank u bro.

1 Like

Good! Thanks @colmoschin94. Now working correct. Thanks a lot.


I would like to know if Ethernet is supposed to work? Or I should configure it. In my case Ethernet is not working.
I didn't find an exemple to set it. How can I enable Ethernet?


Hey guys, quick question, since I've installed openwrt none of my devices are able to connect to my VPN provider (PureVPN), I guess there is some firewall rules I have to input, but no idea of which one, could you please help me?

In the archive I've found this iptables rule that should solve the problem, hoever if I try to apply it I get an error:

iptables -A PREROUTING -t raw -p tcp --dport 1723 -j CT --helper pptp

I get this error:

iptables: No chain/target/match by that name.

Any Ideas on what to do? Thanks!

I solved this problem like this: added to the '/etc/rc.local' (at the end, before 'exit0') the following lines:
sleep 1
/sbin/wifi up

i think for start wifi:

make a file -> 99_enable_wifi

uci set wireless.@wifi-device[0].disabled=0
uci commit wireless
exit 0

and place in /etc/board.c

you can find in this folder some others files for startup by exemple 01_leds 02_network ….

I was using PandoraBox and all was very well done.

Gave a chance to openwrt, but i think its not good yet. Maybe before i came back.

@maumauns Any Hints on how to pass from OpenWRT to Pandora?