Support for Xiaomi Mi 3C

ok i found the problem ahhaha

@minax007 its gen your problem of not have ip network

That might be the issue :slight_smile:
It seems that there are a couple of bugs with the latest release because @anjmis04 reported bad throughput.

Humm i possible go to other versions if its need ...
With git it's possible.

ok i build openwrt with fix
for nano test pls

Dear @eduardo010174,
sorry for my late response. I was very busy at work.
I have tested your nano build with the fix, and can confirm that it works! :+1:
The port assignment, because it wasn't changed, is the same as with the nano build.

As the next step I would ask you to change the port assignment as I had proposed before, then we can directly develop the correct settings of that one. You don't need to change the name of the build and so on.
Thanks in advance!

ok i found the problem on ports no working
for remape ports is need using first port 0, 1,2,3, ...


Wrong switch port numbering in LuCI - #5 by toerless

Base-files ucidef_add_switch


ucidef_add_switch "switch0" \
			"2:lan:2" "4:lan:1" "0:wan" "6@eth0"


ucidef_add_switch "switch0" \
			"0:wan" "2:lan:2" "4:lan:1" "6@eth0"

solve this problem
i rebuild correct now

1 Like

openwrt nano + new ports fix correct
if its work. only need change name to 3c.

if the version back work test final for r3c with port fixed
i fixed post how to build

Test version 3C with ports fixed


1 Like

Dear @eduardo010174
I have tested both builds:

  1. Nano build:
  • Port assignment is correct for all ports (have checked this under "switch")
  • WiFi has a bug. In repeater mode, when connecting a client to the access point, then the connection to the main router gets interrupted. I assume that the WiFi driver you are using is different to the latest OpenWrt repository.
  1. Mi-3C build:
  • No connection on any of the ports possible. I assume that you haven't modified the DHCP server. Therefore maybe the linking of the settings in the files is wrong. Maybe the naming ("miwifi-3C") is not the same in all files, and therefore it does not find the correct parameters. Please double check this. Thanks!
1 Like

First question:
" * WiFi has a bug. In repeater mode, when connecting a client to the access point, then the connection to the main router gets interrupted. I assume that the WiFi driver you are using is different to the latest OpenWrt repository."
Its only in its build?

Second question:
The wifi bug it's reported back from several testers but i suspected it's bootloader not enable eLNA. Stock bootloader enable by default but breed not. But its possible start from openwrt changed dts.

It's possible create table with wifi stock vs wifi openwrt ?
The stock have mode wall penetration, possible it is.

1 Like

Dear @eduardo010174,

it is not about performance differences. It is about complete loss of connection.
The Nano build of yours leads to complete loss of connection.

The 19.07.5 OpenWrt firmware we both had tested has the same performance (bandwith, latency, signal strength) as the stock firmware.

"Wall penetration" is just a marketing name for maximum Tx power.

I do not think that it is related to BREED. It is just a bootloader, by which you can also flash Padavan. And Padavan works completely stable.

1 Like

humm @minax007 try build with lna enable if its solved?
wait it's only on my builds?

1 Like

Dear @eduardo010174,
I haven't tested any other OpenWrt builds than your builds and the ones for the Nano, which are offered by OpenWrt in the download section.
The firmware for the Nano does not have the loss of connection bug on my Mi-3C.

1 Like

i'm very confused. the setup i use its literaly clone of nano.
first problem of ports swapped its solved

1 Like

Yes, that was the first success! :+1:
The open points are:

  1. Assigning the build to the Mi-3C (naming, linking, ...), and fixing the problem that the ports do not work after assignment
  2. Complete WiFi signal loss when connecting to the router

Maybe the latest source code has a bug. Because OpenWrt has recently changed to 19.07.6. And we figured out the correct functionality with 19.07.5.

@eduardo010174: If it is possible for you to go back to this version please give it a try.

1 Like

hummm i possible go back on commit at openwrt 19.07.0x ...
which version select?

1 Like

The version which runs stable on my Mi-3C is the Mi-Nano build from January 10th, 2021.

1 Like

Hummm openwrt 19.07.05
commit c37eb9a9f9d43aa3231a607387754479886edf0d

for move to openwrt 19.07.05

git checkout
git reset --hard c37eb9a9f9d43aa3231a607387754479886edf0d
git checkout

now i build from this if its solve
Openwrt 19.07.05 nano + ports fix's


1 Like

Dear @eduardo010174
I assume that the port fix was not applied on your latest build. WAN and LAN1 are interchanged.
I have tested WiFi. The first time I had connected a client it got interrupted. But after the second connection it worked fine. Throughput and range are very good.

1 Like

i swapped spaces for tab's ups ahhaah
i reupload


1 Like

LAN1 does not work (it works probably as WAN --> I haven't tested this)
LAN2 works correctly
WAN works as LAN (under "Switch" settings it shows that a cable is connected to WAN correctly)

There is no difference to your previous build.

1 Like