Support for Victure WR1200 (AC1200) firmware

Hi I have the Victure WR1200 (AC1200)

problem is I cannot change the admin password from the web interface?

I am wondering if it is the firmware? and should I update it, would appreciate a little advice thanks.

Not letting you change the password?
Probably.

If you can find one, why not.

1 Like

Not very useful? are you saying I can't update it?

It appears you are using firmware that is not from the official OpenWrt project.

When using forks/offshoots/vendor-specific builds that are "based on OpenWrt", there may be many differences compared to the official versions (hosted by OpenWrt.org). Some of these customizations may fundamentally change the way that OpenWrt works. You might need help from people with specific/specialized knowledge about the firmware you are using, so it is possible that advice you get here may not be useful.

You may find that the best options are:

  1. Install an official version of OpenWrt, if your device is supported (see https://firmware-selector.openwrt.org).
  2. Ask for help from the maintainer(s) or user community of the specific firmware that you are using.
  3. Provide the source code for the firmware so that users on this forum can understand how your firmware works (OpenWrt forum users are volunteers, so somebody might look at the code if they have time and are interested in your issue).

If you believe that this specific issue is common to generic/official OpenWrt and/or the maintainers of your build have indicated as such, please feel free to clarify.


Your question wasn't very clear, so ...

Update to *what" ?

It should be noted that this device is not supported by OpenWrt. @lleachii beat me to posting the topic link where a few people appear to have had some success getting OpenWrt to run. But it doesn't look like any of that work had been fully completed and committed to the code. Therefore, it would currently require a fair amount of knowledge and effort to install OpenWrt on your Victure device.

Therefore, if you're asking about how to gain access to the device and/or update it with the vendor firmware, you'll need to ask in the support channels or user forums that are relevant to that manufacturer since it is not running an official OpenWrt firmware.

There's a CVE in the old WR1200 thread me and @lleachii linked to, it could be worth exploring.

1 Like

Thanks for your effort it appears lleachii actually understood the question :wink:

but again thank you.

We both did, he just interpreted it differently, and told you to seek assistance someplace else ...

NFI how it can be considered helpful, but hey, whatever floats your boat.

Thank you lleachii for all your help :smile:

I recently purchased two of these routers so I could run another two independent networks (i.e. wired separate), they were cheap so thought worth a little experimentation but it maybe starting to get too involved.

off the shelf they have a nice simple interface which is all I want for this project, in saying that they should work with the basic functions, I have logged on as root/SSH and confirms it has changed the password with still no change and as admin/admin is not a good user/password they are useless to me.

will take a closer look but from what you have said I don't think they will upgrade.

thanks
Paul

Thanks psherman

Think I am just going to return them if paying an extra 20 bucks each for a better modal that actually works and saves me time that is the way I should go.

thanks for everyone's help though and will come back in future to learn more about OpenWrt :slight_smile:

thanks

2 Likes