Support for TP-LINK TL-WR940N Ver 6.0

no tplink wr940v6 in list
28%20PM is already in TINY device...

Sorry, but is there any way I can download the final .bin?

Firmware downloads for TL-WR940N v6:[Versions*~]=v6&dataflt[Model*~]=tl-wr940n

Do you happen to know which SoC exactly?

Do we have some pictures of the PCB showing the chips used?
If wikidevi shows wrong specs, this should be corrected.

how to install this sir? because itry it on web ui, i got an error

“Error code: 18005 Upgrade unsuccessfully because the version of the upgraded file was incorrect.

Hi James,
Do you know if the tiny image for devices such as WR940, WR941, WA901 etc would be able to build with coovachilli? I've tried to build using the image builder but I just haven't managed to create an image that would let coovachilli run (when it runs, the process crashes saying it's out of memory)
Luci would be nice to have but I can do without it. I provide a captive portal Saas and most of the devices on the market these days are these ones and it is a big problem for me.

OpenWRT 18.06 RC1 is available for TL-WR840n-v6 with LuCI and its working just fine.

1 Like


1 Like


how much space free if you remove dropbear ? (since serial console is still available)

I wouldnt do that

i just purchase this board from craigslist. it seems to put in bit of situation and seems to be best suited as a repeater or access point rather than main router. it has only 4mb flash and no usb ports to be able to use extroot or external storage. i suppose could always upgrade flash, but probably cheaper just to buy different router

I've deployed over 300 of these since we set up version 6. Amazing router. I've never much needed, wanted, nor liked GUIs, so I can fare just fine with uci and ssh access. I use it as a VPN router to deploy critical applications available only through the vpn subnet for a variety of businesses.

There's so little this router CAN'T do, Yes, I would suppose not having USB is an issue for some, no GUI is a plus for me. mbedtls is a godsend as opposed to openssl.

-tiny- builds are amazeballs.

nice. are there any packages that you have installed?

i tried installing luci last night and didn't have enough space.

Well that's just the thing. Without LUCI, it does the exact same thing than any others. (you just need to control it via uci - which is to say the contents of /etc/config and configure everything via Vim

or use UCI. which are commands. Such as this

uci set system.@system[0].conloglevel=8
uci set system.@system[0].cronloglevel=8
uci set system.@system[0].timezone='CST6CDT,M4.1.0,M10.5.0'
uci set system.@system[0].zonename='America/Mexico City'
uci set system.@system[0].hostname='160622'
uci set
uci set wireless.radio0.txpower=30
uci set wireless.@wifi-iface[-1].encryption='psk2'
uci set wireless.@wifi-iface[-1].mode='ap'
uci set wireless.@wifi-iface[-1].network='lan'
uci set wireless.@wifi-iface[-1].key='90935848'
uci set wireless.@wifi-iface[-1].ssid='yourSSID'
uci set wireless.@wifi-device[-1].disabled=0
uci commit wireless

Or if you feel daunted you can edit the contents of the file via vim, (busybox), such as..


config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/qca953x_wmac'
        option htmode 'HT20'
        option country 'US'
        option txpower '30'
        option disabled '0'

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2+ccmp'
        option disassoc_low_ack '0'
        option max_inactivity '86401'
        option skip_inactivity_poll '1'
        option wpa_group_rekey '0'
        option ssid 'Bla'
        option key 'Bla'

And then just reboot.

is it possible to have it an openvpn?
i try to install but its said "not enough space"

Sure it's possible. Just install openvpn-mbedtls not the openssl

Thanks.. But im newbie here.. What is the code for that to install?