Support for TP-LINK TL-WR802N V4


#62

Hi,

I'm not sure what a PR is, but any chance you would have the files needed to flash on this?


#63

Unsure where that branch went on github. It looks like he synced up with the main openwrt repo but that branch is now gone. It may be getting merged into master.

In the interm, the images I built can be found at https://github.com/drytoastman/scorekeeperrouter/releases/tag/tlwr802nv4


#64

The diff for building can be found at https://github.com/drytoastman/scorekeeperrouter/blob/master/patches/openwrt-TL-WR802Nv4.diff


#65

Thanks for sharing!

is your image stable (without wifi transmit bug)?


#66

Thanks for sharing.
I installed the recovery version drytoastman shared and it seems to work perfectly when the WiFi channel is fixed.
When I changed the channel to 'auto', WiFi SSID never appears.
Did you encounter this issue ?
Does someone know how to workaround ?


#67

Thank you for all the info.

I was able to successfully flash @drytoastman builds using TFTP. Now I want to go back to stock firmware. I tried to flash the stock US firmware via TFTP but it resulted in Uboot loop. I also tried to trim the stock firmware as mentioned previously but no success (skip=256/257). I am still able to flash the openwrt firmware.

Any help to flash the stock firmware would be helpful. I do not have access to the serial pins.


#68

I got new tl-wr802n-v4 device today, is there any stable US image which I can use to install openWrt/LEDE on it through web interface?


#69

No.
This topic is still in the developers section and there's not even an official snapshot image available, let alone an official stable image.


#70

okay..any developer snapshot that I can try?


#71

I have tried images mentioned here https://github.com/drytoastman/scorekeeperrouter/releases/tag/tlwr802nv4 , but I got an error "Error code: 4503 The uploaded file was not accepted by the device." I think I need signed US image to make it work. Where I can get it?


#72

Try via TFTP and use the tftp-recovery.bin image.


#73

Yeah..tried, but I am getting Transfer timeout error all the time. I used the following commands from my mac terminal.

cd /Users/deva/Downloads/
tftp 192.168.0.1
binary
tftp> put openwrt-ramips-mt76x8-tl-wr802n-v4-squashfs-tftp-recovery.bin
Transfer timed out.


#74

You really need to do some reading. Clearly from these post it shows you shouldn't be using a developer image.


#75

Hi,

I am a total noob at OpenWRT and this is not really hard. You download the image, rename to tp_recovery.bin and run a TFTP server on address 192.168.0.66 serving a directory containing the file. After a reboot, the router will connect to your server and download the new image.


#76

Sorry for the double post, but I just wanted to thank you all for the great work. I now have a cheap TL-WR802N extending eduroam coverage for my entire house and serving as the contact point for streaming. The device is 10x more useful than what I acquired with the original firmware and it only took a few hours from "what the hell am I doing here" to fully functional. OpenWrt is amazing!


#77

@dfaranha
I am even more of a total noob. Can you please tell me how you installed openwrt in more detail?


#78

I will try to summarize it here:

  • Download the images below and rename the tftp-recovery.bin to tp_recovery.bin
  • Install a TFTP server in your computer.
  • Connect the computer and router through Ethernet.
  • Assign address 192.168.0.66 statically to your computer.
  • Press the Reset button in the router for a few seconds and release it. Wait a few minutes until it boots and installs the image.
  • Reconnect Ethernet with DHCP configuration and check that the router is now accessible through 192.168.1.1

#79

How did you assign the IP address statically. I assigned it in windows I set it to 192.168.0.66 and I set the gateway to 192.168.0.1 and subnet mask to 255.255.255.0. Then I started tftp server with the renamed file and I pressed the reset button but nothing happened except it reset itself on the normal firmware. Also what tftp server did you use? And what did I do wrong?
@dfaranha


#80

You may need to turn off the router, then turn it on while you're pressing the reset button for 6-7 seconds. The IP address you need to set the PC to depends on the brand and model of your router. Do you have a TL-WR802N V4?


#81

Yes I have that exact model of router. I’ll try it by turning off router and turning it on with reset button pressed.