Support for TP-LINK RE305 V3

Hi everyone!
I am currently using the factory firmware with RE305 V3 and an IPTV mediabox connected. The router is an Archer C7 V5 with Openwrt. IPTV works perfectly, but I can't create a Mesh network. Can IPTV continue to work and can I Mesh network with this firmware?

Did you just flashed the installer provider by strollo?
was there any soldering required?

this "installer" can be used on OEM (stock) firmware update page.
I just tried on mine RE305(EU)_V3_200826 with no issues.
Soldering skills are just required in case of update failure :wink:

1 Like

Hey @strollo thanks for the reply.
So i should be good flashing your installer on RE305(CA)_V3.0_20210416 right?

Sorry not tried on that so cannot give any warranty it works ( but if you're enough brave to waste 30$ extender for the shout - as I did on mine :wink: ... )
Otherwise it's better you wait for more feedbacks on upgrading on stock US/CA firmwares.

There have been conflicts in re305 configs opposed to original master, so I've had to rebase it & change it accordingly for v3 config. (There are other namings like nvmem-cells instead of mtd-mac-address etc..). It has to be tested properly though.. I'll try to test it ASAP, but I'm not sure when it could be. If anyone will have time for that you can test it from this PR: or this branch:
Thanks in advance

Hi @servitkar,
sorry if I didn't started directly from your branch but I preferred to start from standard master and apply patched I used to compile the firmware I'm currently using now.
It is a mixture of your modifications and suggestions reported in this chat from @bmed and others.

Anyway this is the branch I'm currently using by my own if you want to get a comparison.

in particular here the relevant commit

Now, differently from your current merge request

in my case no target/linux/ramips/dts/mt7628an_tplink_re305-v1.dts or
target/linux/ramips/dts/mt7628an_tplink_re305.dtsi modifications are needed.


1 Like

Eh... maybe a stupid question: Is it possible to revert to stock firmware (yes, I know: OpenWRT is far superior) by just flashing a TP-LINK firmware? Or do I have to solder?

Anyway: Strollo's version works like a charm here on my v3 RE305.

Hi @linaro1 never tried to revert to stock firmware.
But probably a first constraint should be starting from a openWRT firmware having .soft_ver < 2 (the current value) in order to pass version validation checking made by stock fw.

It this case if needed I can compile a new openWRT with lower version e.g. .soft_ver=1 in order to allow the "downgrade".

But still don't know if it is enough.

OK, clear! Thnx for your reply. I think I am going to create a connector to be able to hook up the serial port anyway. No guts no glory, so maybe it's just a matter of trying.

1 Like

Noob question, how to make a new build for the RE305 V3 ?
In menuconfig what are the necessary settings for the RE305 V3 ?
Thanks for the help.

Hello! adschm on GitHub needs the MAC address assignment for our model to wrap things up. Unfortunately I bricked my device while trying to revert to the stock firmware and won't be able to attach serial soon due to time constrains.
Can someone else provide him the table?
Their original message:

I rearranged some stuff and put the result here:;a=shortlog;h=refs/heads/re305

The only thing missing IMO is the correct MAC address assignment for the v3. Can somebody please post a table like described here, so we can choose the correct addresses and get this done:

sorry for 'hijacking' a bit : anyone else here has received a v4 ? Got it fresh from Amazon! Shall I try a V3 enabled firmware and see how it goes?

Major revisions often mean hardware changes in TP-Link's numbering scheme. I would not try to flash v3 firmware without doing due diligence first.

1 Like

@Borromini yes sure, yet as "The only and important difference between v1 & v3 is in flash memory
layout, so pls don't interchange these 2 builds!" I was hoping something similar would happen.

How can I check the hardware is the same? Visual inspection? serial connection?

Both would be good, yes, check boot log for pointers on flash and RAM, flash layout, but a physical look at the innards never hurts (if you can open it without voiding the warranty).

Even flash memory layout changes can brick your device, if you were to overwrite e.g. radio callibration data etc.

I wouldn't recommend. The RE305 v3 stock firmware image (.bin) size is about ~7MB, while the RE305 v4 stock firmware image size is about ~2.5MB (less than a half).

This might be an indication that they are different hardwares.

I just ordered one RE305 to replace a RE200 (with the expectation I could run OpenWRT on it since OpenWRT on RE200 is broken).

It will arrive next week, hopefully it will be a v3. If it is a v4 I will be very disappointed since there is no OpenWRT support to v4 yet. If it is a v4 and it is easy to take it apart, I will try to find out which hardware v4 has.

1 Like

I just received my RE305 v3 today. Below are the MAC addresses from the stock firmware (I've redacted one portion for privacy reasons but I believe it is sufficient for understanding the MAC addresses order). I will post this information at github as well:

5.0 Ghz: 00-31-92-XX-7F-D0
2.4 Ghz: 00-31-92-XX-7F-D1
Ethernet: 00-31-92-XX-7F-D2


Good news everyone. Thanks to @adrianschmutzler merging of my commit into master, we can now use pre-built snapshots for this device:
So feel free to try it (but again at your own risk..)

1 Like

Hey cheers for getting this through. I'm having an issue with mesh networking where my speeds are halved even though router (archer C7) and extender are right beside me.
Is there any way to restore original tp-link firmware. I've tried TFPT on and with no luck but TFTP seems to work with the Archer C7. Wireshark is also not picking up anything :frowning:
I'm hoping to revisit this over the xmas hols but for the moment I just need the Onemesh back up and running until then. Any help would be appreciated