Support for TP-Link EAP225 Outdoor v3

When will you bring the changes into the base release?

@yksflip it would be nice if you could submit the required patches to OpenWrt for review. Your changes seems to work and there is obviously demand for device support.

sorry there wasn't so much activity in the last time, I couldn't find the time to work on this
Actually I wanted to investigate and try out some more stuff before doing the PR, but if you think it's okay with the feedback from andyduncan and paddybk, I'll try to submit it.

I saw the same error message when I ported the changes from the latest release to openwrt master. The tplink_safeloader was moved to a separate firmware-utils.git package.

I found it difficult to build openwrt with the changes in that package, but I was able to test it by modifying tools/firmware-utils/Makefilelike this


having that, it seemed to fix that warning

It is also possible to add patch files to tools/firmware-utils/patches/. These will then be applied when building the OpenWrt tree, so can be used to more easily test new devices in tplink-safeloader.

1 Like

The firmware-utils tool has been updated, and changes pulled into OpenWrt. This allows building EAP225-Outdoor v3 (and EAP225 v4) images using the EAP225-V3 board ID.


Hey, you need to use


in This should make your patchset work with latest master. Just a note, I've successfully made an EAP225v4 work with essentially the same fix as well. Thanks for your work on this!

Edit: Just found your PR. Hopefully it gets pulled soon.

Can anybody with a device on their desk check if gpio 11 is actually used to reset the RTL8211FS? @sven1 had a shot at tracing out the EAP225v4, but it seems that gpio 11 is not (directly) connected to the phy.

Has anyone tried the new release 22.03 on the EAP family?
with regard :blossom:

This means, the board ID is the same for eap225-v3 and eap225-outdoor-v3?

That's correct. The partition layouts are identical, and TP-Link is also providing unified firmware images for:

  • EAP225 v3
  • EAP225 v3.20
  • EAP225-Outdoor v1
  • EAP225 v4
  • EAP225-Outdoor v3

Thanks, build was successful. Maybe I can try to test gpio 11 on the EAP225-Outdoor-v3, but how?

@hussein I will test the new image as soon as I am on the device location.

1 Like

I have sucessfully done a sysupgrade to the new 22.03 test image.

You could drop the reset-gpios property from the phy node, and then try toggling the GPIO manually from userspace (sysfs interface at /sys/class/gpio). Earlier test by @sven1 have indicated that gpio 11 isn't connected to the phy on the EAP225 v4, but a second check for this device wouldn't hurt.

If gpio 11 doesn't do anything, it can be left out of the DTS. Otherwise, pulling it low (I assume) should put the ethernet phy in reset and prevent the wired connection from working.

A quick look at the GPL sources for the EAP225 v4/EAP225-Outdoor v3 doesn't seem to indicate any reset GPIOs at all.

Hi, I have got my hands on a EAP225-Outdoor-v3 and would like to run openwrt on it. Can I help to test some open items? Do I need to build some test images?
Or where could I find the image to test on this device.

Thank you very much paddy, I test this version.
but the problem is: when I set txpower above 18 and connect more phones and laptops, the device keeps rebooting

Toggling gpio11 on eap225-outdoor-v3 seems not to change anything.

1 Like

tplink_eap225-outdoor-v3 is upstream:

many thanks to everyone who contributed their time and brains

1 Like

wow! also thanks again for all the help to actually bring this upstream!
It's been a great experience of collaboration - keep this spirit up <3

1 Like

Cool to see this merged.
Did somebody already use the factory image successfully? I just tried with the nightly (, d264fc393d3b801117e0f8ec76dc57cd97507d1f2aba7f4b8c2e14fb0ec9f552) and it failed with "firmware is incompatible" - both with stock firmware 5.0.6 and 5.0.7