Support for Tp link CPE210 v2.0


#13

Adding support for Freifunk is also one of my intentions with the CPE210. I also got version 2 by accident, because I didn't do any research about newer versions of the CPE210. According to the TP-Link website there is also a CPE210v3, which I have never seen. Maybe this will be the non-EU version?

I never tried to add LEDE support to a new device, but the commit for supporting CPE210v1 looks quite logical. Anyway I would be glad if someone experienced could provide us with some tips. One thing that could cause trouble is TP-Links SafeLoader.

//edit: This is the actual partition table read from /dev/mtd1:

partition fs-uboot base 0x00000 size 0x20000
partition partition-table base 0x20000 size 0x02000
partition default-mac base 0x30000 size 0x00020
partition product-info base 0x31100 size 0x00100
partition device-info base 0x31400 size 0x00400
partition signature base 0x32000 size 0x00400
partition device-id base 0x33000 size 0x00100
partition os-image base 0x40000 size 0x170000
partition soft-version base 0x1b0000 size 0x00100
partition support-list base 0x1b1000 size 0x01000
partition file-system base 0x1c0000 size 0x600000
partition user-config base 0x7c0000 size 0x10000
partition default-config base 0x7d0000 size 0x10000
partition log base 0x7e0000 size 0x10000
partition radio base 0x7f0000 size 0x10000

#14

Hi Guys,

Is any progress or guiadance to do the firmware?

Regards


#15

If there is someone to send/donate/contribute a sample to get it into LEDE/Gluon please let me know.

Michael


#16

Hi Michael,

No problem, what is you need? or how I can contribute?

Regards


#17

Actually.. I don't have this router... But if you have 2 devices, please give me one :joy:

http://www.kuchikamizake.net


#18

Anybody made any progress?


#19

I still be waiting the device.


#20

v1 is based on the AR9344, v2 on the QCA953x (x=1?). Maybe more similar to the WR810N or EAP110?


#21

Its QCA9533, which is pretty much the same as QCA9531.
There has been some progress but serial console does not work.


#22

Anybody else had issues with writing to console?
I cant get it write,RX works without issues


#23

Is anybody interested in helping?
I have managed to get flashing over WEB UI working, but unfortunately serial is not working after the kernel is loaded.


#24

Unfortunately TP Link has yet to release GPL for V2.
GPL source that they have released for V2 now is the same one for V1 with configuration only for V1 so that is useless


#25

Any interest on helping me?
It aint gonna fix itself.
Pretty much everything is ready(In theory) but still as soon as kernel starts loading serial output dies.
Even when I manually load kernel over tftp and boot it serial works till just after it is enabled in log.


#26

Please tell me have you solved it already?


#27

No, unfortunately, I cant get serial to work and without that I cant go any further


#28

I also have Tp Link. Looking for a solution


#29

There is a brand new post from someone that was able to post the serial logs


#30

Добрый день!
Вот ссылка на страницу с GPL for V2:

http://www.tp-link.com/us/download/CPE210.html#GPL-Code

А тут ссылка на сам файл:

http://static.tp-link.com/resources/gpl/v2_hipap_gpl_code.tar.bz2


#31

Также ссылка на GPL for V2 для CPE510:
http://nl.tp-link.com/download/CPE510.html#GPL-Code


#32

Характеристики железа:
https://wikidevi.com/wiki/TP-LINK_CPE210_v2.x

Надеюсь поможет!