Support for TP-Link Archer C2 V1

It just merged to trunk, but due to it's needed rtl8366-smi patch can bring regression to other routers, it's unlikely to be merged to 18.06 before release.

For installation:

2) Extract u-boot from the binary file:
     #> dd if=c2v1_stock_firmware.bin of=c2v1_uboot.bin bs=1 skip=512 count=131072

Excuse my ignorance but how do you get the input block size?

Binwalk gives me this:

DECIMAL       HEXADECIMAL     DESCRIPTION
--------------------------------------------------------------------------------
95648         0x175A0         U-Boot version string, "U-Boot 1.1.3 (Aug 31 2015 - 16:32:16)"

Thanks for reading.

How can I install the official nightly build?

I am using a build that I compiled from @orangepizza source. When I compiled from the openwrt source I got a sysupgrade file with 4Mb instead of 8Mb from before. I wasn't sure if this is correct, so I didn't flashed. What the factory image is for?

As official nightly version wont changed boardname from c2 to c2-v1 it won't allow sysupgrade.
And don't backup and migrate settings from one to another, as switch number changed, it will screw up wired lan because it will look for wrong switch at official trunk
get oldest(2016 feb one) stock image, rollback to it,and use trunk factory image to flash it. this rollback and flash is because newer stock firmware don't allow 3rd party firmware.

Well, I managed to flash the nightly on my C2. Is it supposed to come without luci and uhttpd or did I make something wrong? Because I could only access the official nightly I downloaded via ssh. In the end, I just compiled a build myself with these packages, and it worked. Thanks for your help!!

You did nothing wrong. Nightly SNAPSHOT does not contain LuCI. Simply:

opkg update
opkg install luci

Hello, guys!

I'm currently using the April 21st build or the newer one from @orangepizza, I'm sorry, I can't remember exactly which one, but everything is fine, except that I can't mount a NTFS external HDD because it seems that the kernel doesn't have the module. When I try to install ntfs-3g or evend kmod-fs-ntfs, I end up with the following error:

Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for ntfs-3g:
 *   kernel (= 4.4.140-1-b59b55b7bceeb6ba7d5cd45a27c59465) * 
 * opkg_install_cmd: Cannot install package ntfs-3g.

I successfully mounted and shared over the network, a flash drive formatted as FAT32 and it was possible because vfat came built-in. I would try the snapshot build just to see if it has support, but I think I'll have to roll back my C2 to the stock firmware first and then do the update, but, since 5 GHz is not supported yet, I prefer orangepizza's build.

My question is, can I modify the kernel to include fuse? I suppose I'll need to build it from source, right?

Thank you for your work!

Felipe A.

Ok, so, I'm currently compiling a build with fuse and ntfs modules. It's actually easy and intuitive when you use menuconfig. I hope it works.

I cloned orangepizza's repository.

Thanks!

It worked!

If anyone wants the build, just let me know.

Thanks!

orangepizza, are you also planning to release an 18.06 version with working 5GHz wifi?

no. 5g driver won't complie with kernel 4.14
(single line change, but mediatek driver's license doesn't allow me to change)

Will be 18.06 version without 5GHz wifi? or 17.01.6 OpenWrt/LEDE v17.01.6 service release)

Yeah, a more recent version of 17.01 with 5GHz support would be great with 18.06 is not feasable :slight_smile:

Would Kernel 4.9.120 from 18.06 be an option without license problems?

I'll try at weekend but don't expect much as I really isn't programmer, and the semester started.

and how to use kernal 4.9 on 18.06? , 4.9 will compile as the breaking change imported at 4.12

ah. and possetti's mtk wifi config patch doesn't competiable with 18.06 luci

Ah, ok.

I'm not sure about 4.9.120. I have a TPLink WR841N and it uses 4.9.120 by default.

Any chance of getting possetti's patch working? @possetti?

If you are going to give it a try and 18.06 fails, an updated 17.01.6 release would also be great since some applications need a newer version when trying to download them via opkg.

1 Like

Currently I am using the latest build available with 4.4.131 kernel and I am not using the wifi from the router at all.

Is there a way to create a build with the 18.06 luci with the latest kernel without wifi support? Works for me...

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.