Support for TL-WR841N v14

It may be too far fetched but, is it possible to get the [squashfs-factory.bin] kinda like version for the v14? It doesn't have to be latest, can be any old version that fits and works.

Also, do you know why the default firmware keeps giving the error 4503 while trying to load a factory firmware?

https://openwrt.org/faq/error_code_4503

I saw that, also another thread regarding the wr840.

I mean, are the chinese so... bad? why country-lock a cheap router? unless grabs tinfoil hat they are planning something with those devices having vulnerabilities all over the planet. Is the only possible explanation so far.

Now, back to planet earth, so tftp is the only way to go?

Tried to install openwrt-ramips-mt76x8-tplink_tl-wr841n-v14-squashfs-sysupgrade.bin version from [ulbricht-inr] with tftp but does break the router.
Seems to need still the squashfs-tftp-recovery.bin version for tftp...

1 Like

Have now downloaded last snapshot (2 days ago) and built with config file above in thread from ulbricht.
Compile worked but can anyone confirm that this config and compiling worked for V14?
I don't want to brick another router...
Any comments please?

Hello all tank

Is there a version for it 841 v 14 OpenWrt

See Does OpenWrt support TP-Link TL-WR841 v14 Router?

1 Like

I am not an expert, will it be supported?
841 v14

Short answer: No.

I've compiled my own version and seems to build an image for v14.
My problem is now that my v14 version does not enter in tftp mode...
Pressing reset button and power on does not work on this equiment I have
but I tought I installed an other v14 version with tftp.
Reset button seems to work... What could be the problem?

TFTP is in the bootloader. Some stock firmware includes a new bootloader, if you upgrade to that (while running stock), it should install.

Riskier would be to copy the bootloader from the newer one you have to the old one.

How can I do that? Were is any information? The new bootloader comes from TPLink or OpenWRT?
Upgrading the bootloader must be done in OpenWRT or not? Can I save the old one, how?

Anyone worked on a flash/ram upgrade?

I upgraded a WR841N v14.0 with 64MB Ram and 16MB Flash. I compiled openwrt with above config and patched for 16MB flash size. Flash upgrade is working. If anyone is interested, I can share how to upgrade. Ram upgrade does not work yet.

it would be interesting to see how you upgraded the RAM chip at least - do please share - this is what openwrt is about :slight_smile:
...
I'll also share my 18.06 built images:
https://www.dropbox.com/s/u14j8en3xgehepa/openwrt-ramips-mt76x8-tplink_tl-wr841n-v14-squashfs-tftp-recovery.bin?dl=1 (initial tftp flash image)
https://www.dropbox.com/s/9a0wrysxampxddn/openwrt-dnscrypt-mt76x8-tplink_tl-wr841n-v14-squashfs-sysupgrade.bin?dl=1 (dnscrypt built in)
https://www.dropbox.com/s/7u1ty2y4a37vzlq/openwrt-DoH-mt76x8-tplink_tl-wr841n-v14-squashfs-sysupgrade.bin?dl=1 (https-dns-proxy built in)

I'm trying to backport this device into my 17.01 fork ( [Testing] lede-17.01 security backports for 4/32 devices ) but currently built images enter reboot loop so I'll need a serial console debug...)

16M/64M upgrade was successful. My devices are running with 16MB flash and 64MB RAM now. One with latest OpenWrt and one with gluon (Freifunk Stuttgart firmware).

I used the following devices:
RAM: Hynix HY5DU121622DTP-D43
Flash: Winbond 25Q128FVSG

Ram upgrade procedure:

  1. Desolder old RAM
  2. Solder new RAM
  3. Now test the device. If you soldered the ram correctly, it works as before.
  4. RAM size is hard coded in boot loader. To use the 64M you need to flash a modified boot loader. Either
    a) use a modified OpenWrt image (with boot partition writable) and write it from OpenWrt
    or
    b) use serial console and flash with u-boot and tftp

I will upload modified u-boot binary and source later.

Flash upgrade is easier to solder but more firmware changes:

  1. Save your ART partition. It is individual for every hardware.
  2. Desolder old Flash
  3. Write bootloader, firmware and ART partition to new Flash.
    I use a cheap ch341a programmer with SOIC-8 clip.
  4. Solder the new Flash.

ART partition can either be saved from OpenWrt or read with ch341 programmer after desoldering flash.
It can then either be added to firmware image before writing the new flash or written with modified OpenWrt later.

OpenWrt with 64MB target is here: https://github.com/timowi/openwrt

1 Like

Forgot two points:

tftp recovery:
tftp recovery works on v14. press and hold reset button after power on. Device IP is 192.168.0.2, Server IP is 192.168.0.66, Filename: tp_recovery.bin

Serial console
I used the internal serial port for modification. It's 115.200 8N1 3,3V TTL, so use a ftdi adapter. Strangely I need a pullup resistor on RX (router side). Otherwise it does not get my inputs.
Pressing 't' after reset enters bootloader.
Original recovery commands are: ""tftp 0x80060000 tp_recovery.bin;erase tplink 0x10000 0x3d0000;cp.b 0x80070000 0x10000 0x3d0000"

I currently have v14.1 and it seems it's a lower cost variant as it uses normal ram chip (not BGA as in v14) see TP-Link WR841N v14.1 vs v14

Mine are V14.0 and look exactly the same. I think the BGA RAM chips are wr841 <v13. v14 have a TSSOP66 RAM chip.

1 Like

do you know how I can boot a initramfs image? "bootm" doesn't seem to get recognized - not even help

4: System Enter Boot Command Line Interface.

U-Boot 1.1.3 (Jan 14 2020 - 17:47:19)
MT7628 # bootm
Unknown command 'bootm' - try 'help'
MT7628 # help
Unknown command 'help' - try 'help'