Support for TL-WR840N(ES) Ver 5.0 (EU)


#61

Great,you have bootloader with working TFTP.
You cant flash sysupgrade image,you need TFTP image that has first 128k padded.
I will prepare one today,I did not include that image because there are 840N v5 with bootloader that will.completely wipe your flash when trying to TFTP.

Stock firmware also has padded images like that for TFTP


#62

Flashed via TFTP with your image - worked just fine! now if only to build it myself with my packages as a next step to test productive environ.


#63

Flashed, worked out of the box with TFTP on my version. Sadly, WiFi keeps presenting the dreaded issues.

Here is wireless config

config wifi-device 'radio0'
option type 'mac80211'
option channel '11'
option hwmode '11g'
option path 'platform/10300000.wmac'
option htmode 'HT20'
option country 'US'
option disabled '0'

config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option encryption 'psk2'
option key '704F5738DF8E'
option ssid 'HelloThere-TestingNow'

And here is the log when Clients connect

Tue Nov  7 08:30:49 2017 daemon.notice hostapd: wlan0: AP-ENABLED 
Tue Nov  7 08:31:14 2017 daemon.info hostapd: wlan0: STA 74:8d:08:1b:61:f1 IEEE 802.11: authenticated
Tue Nov  7 08:31:14 2017 daemon.info hostapd: wlan0: STA 74:8d:08:1b:61:f1 IEEE 802.11: associated (aid 1)
Tue Nov  7 08:31:14 2017 daemon.notice hostapd: wlan0: AP-STA-POSSIBLE-PSK-MISMATCH 74:8d:08:1b:61:f1
Tue Nov  7 08:31:15 2017 daemon.notice hostapd: wlan0: AP-STA-POSSIBLE-PSK-MISMATCH 74:8d:08:1b:61:f1
Tue Nov  7 08:31:16 2017 daemon.notice hostapd: wlan0: AP-STA-POSSIBLE-PSK-MISMATCH 74:8d:08:1b:61:f1
Tue Nov  7 08:31:17 2017 daemon.notice hostapd: wlan0: AP-STA-POSSIBLE-PSK-MISMATCH 74:8d:08:1b:61:f1
Tue Nov  7 08:31:23 2017 daemon.info hostapd: wlan0: STA 74:8d:08:1b:61:f1 IEEE 802.11: deauthenticated due to local deauth request
Tue Nov  7 08:31:38 2017 daemon.info hostapd: wlan0: STA 74:8d:08:1b:61:f1 IEEE 802.11: authenticated
Tue Nov  7 08:31:38 2017 daemon.info hostapd: wlan0: STA 74:8d:08:1b:61:f1 IEEE 802.11: associated (aid 1)
Tue Nov  7 08:31:38 2017 daemon.notice hostapd: wlan0: AP-STA-CONNECTED 74:8d:08:1b:61:f1
Tue Nov  7 08:31:38 2017 daemon.info hostapd: wlan0: STA 74:8d:08:1b:61:f1 WPA: pairwise key handshake completed (RSN)
Tue Nov  7 08:36:50 2017 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED 74:8d:08:1b:61:f1
Tue Nov  7 08:36:50 2017 daemon.info hostapd: wlan0: STA 74:8d:08:1b:61:f1 IEEE 802.11: disassociated
Tue Nov  7 08:36:51 2017 daemon.info hostapd: wlan0: STA 74:8d:08:1b:61:f1 IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Tue Nov  7 08:36:52 2017 daemon.info hostapd: wlan0: STA 74:8d:08:1b:61:f1 IEEE 802.11: authenticated
Tue Nov  7 08:36:52 2017 daemon.info hostapd: wlan0: STA 74:8d:08:1b:61:f1 IEEE 802.11: associated (aid 1)
Tue Nov  7 08:36:52 2017 daemon.notice hostapd: wlan0: AP-STA-CONNECTED 74:8d:08:1b:61:f1
Tue Nov  7 08:36:52 2017 daemon.info hostapd: wlan0: STA 74:8d:08:1b:61:f1 WPA: pairwise key handshake completed (RSN)
Tue Nov  7 10:20:12 2017 daemon.info hostapd: wlan0: STA 80:e6:50:06:03:74 IEEE 802.11: authenticated
Tue Nov  7 10:20:13 2017 daemon.info hostapd: wlan0: STA 80:e6:50:06:03:74 IEEE 802.11: associated (aid 2)
Tue Nov  7 10:20:13 2017 daemon.notice hostapd: wlan0: AP-STA-CONNECTED 80:e6:50:06:03:74
Tue Nov  7 10:20:13 2017 daemon.info hostapd: wlan0: STA 80:e6:50:06:03:74 WPA: pairwise key handshake completed (RSN)
Tue Nov  7 10:20:17 2017 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED 80:e6:50:06:03:74
Tue Nov  7 10:20:17 2017 daemon.info hostapd: wlan0: STA 80:e6:50:06:03:74 IEEE 802.11: disassociated
Tue Nov  7 10:20:18 2017 daemon.info hostapd: wlan0: STA 80:e6:50:06:03:74 IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Tue Nov  7 10:20:45 2017 daemon.notice hostapd: wlan0: STA 80:e6:50:06:03:74 IEEE 802.11: did not acknowledge authentication response
Tue Nov  7 10:20:55 2017 daemon.info hostapd: wlan0: STA 80:e6:50:06:03:74 IEEE 802.11: disassociated
Tue Nov  7 10:20:55 2017 daemon.notice hostapd: wlan0: STA 80:e6:50:06:03:74 IEEE 802.11: did not acknowledge authentication response
Tue Nov  7 10:20:59 2017 daemon.info hostapd: wlan0: STA 80:e6:50:06:03:74 IEEE 802.11: disassociated due to inactivity
Tue Nov  7 10:20:59 2017 daemon.notice hostapd: wlan0: STA 80:e6:50:06:03:74 IEEE 802.11: did not acknowledge authentication response
Tue Nov  7 10:20:59 2017 daemon.info hostapd: wlan0: STA 80:e6:50:06:03:74 IEEE 802.11: associated (aid 2)
Tue Nov  7 10:20:59 2017 daemon.notice hostapd: wlan0: AP-STA-CONNECTED 80:e6:50:06:03:74
Tue Nov  7 10:20:59 2017 daemon.info hostapd: wlan0: STA 80:e6:50:06:03:74 WPA: pairwise key handshake completed (RSN)
Tue Nov  7 10:21:03 2017 daemon.notice hostapd: wlan0: STA 80:e6:50:06:03:74 IEEE 802.11: did not acknowledge authentication response
Tue Nov  7 10:21:06 2017 daemon.notice hostapd: wlan0: STA 80:e6:50:06:03:74 IEEE 802.11: did not acknowledge authentication response
Tue Nov  7 10:21:18 2017 daemon.info hostapd: wlan0: STA 80:e6:50:06:03:74 IEEE 802.11: disassociated
Tue Nov  7 10:21:19 2017 daemon.info hostapd: wlan0: STA 80:e6:50:06:03:74 IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)

I checked out commit 617e1e047e2016798d0151df9a1b38042b3be7e5 of tftp 840v5 git.

I wonder if installing the proprietary Mediatek driver will do anything to help. Stock works rock solid.


#64

You can try setting it to not disconnect on low ACK.
Altough for MT7628 drivers are really bad


#65

Here's a logread -f from an iPhone I connected with log_level 0 (verbose) in the wireless config.

Tue Nov  7 10:36:38 2017 daemon.notice hostapd: wlan0: interface state COUNTRY_UPDATE->ENABLED
Tue Nov  7 10:36:38 2017 kern.info kernel: [ 8039.404806] br-lan: port 2(wlan0) entered blocking state
Tue Nov  7 10:36:38 2017 kern.info kernel: [ 8039.410266] br-lan: port 2(wlan0) entered forwarding state
Tue Nov  7 10:36:38 2017 daemon.notice hostapd: wlan0: AP-ENABLED 
Tue Nov  7 10:36:38 2017 daemon.notice netifd: Network device 'wlan0' link is up
Tue Nov  7 10:36:47 2017 daemon.info hostapd: wlan0: STA 74:8d:08:1b:61:f1 IEEE 802.11: authenticated
Tue Nov  7 10:36:47 2017 daemon.info hostapd: wlan0: STA 74:8d:08:1b:61:f1 IEEE 802.11: associated (aid 1)
Tue Nov  7 10:36:47 2017 daemon.notice hostapd: wlan0: AP-STA-CONNECTED 74:8d:08:1b:61:f1
Tue Nov  7 10:36:47 2017 daemon.info hostapd: wlan0: STA 74:8d:08:1b:61:f1 WPA: pairwise key handshake completed (RSN)
Tue Nov  7 10:36:47 2017 daemon.info dnsmasq-dhcp[952]: DHCPDISCOVER(br-lan)  
Tue Nov  7 10:36:47 2017 daemon.info dnsmasq-dhcp[952]: DHCPOFFER(br-lan) 192.168.6.228 74:8d:08:1b:61:f1 
Tue Nov  7 10:36:48 2017 daemon.info dnsmasq-dhcp[952]: DHCPREQUEST(br-lan) 192.168.6.228 74:8d:08:1b:61:f1 
Tue Nov  7 10:36:48 2017 daemon.info dnsmasq-dhcp[952]: DHCPACK(br-lan) 192.168.6.228 74:8d:08:1b:61:f1 iPhone-ANG

Tue Nov  7 10:37:31 2017 daemon.info dnsmasq-dhcp[952]: DHCPRELEASE(br-lan) 192.168.6.228 74:8d:08:1b:61:f1 
Tue Nov  7 10:37:31 2017 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED 74:8d:08:1b:61:f1
Tue Nov  7 10:37:31 2017 daemon.info hostapd: wlan0: STA 74:8d:08:1b:61:f1 IEEE 802.11: disassociated
Tue Nov  7 10:37:32 2017 daemon.info hostapd: wlan0: STA 74:8d:08:1b:61:f1 IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)

Not an isolated issue - http://forum.vocore.io/viewtopic.php?f=16&t=3800


#66

Yep I have that, actually. I've been playing around with it for quite some time since version 4.
My default setting that causes the LEAST issues (but still a lot), is

uci set wireless.@wifi-iface[0].disassoc_low_ack=0
uci set wireless.@wifi-iface[0].max_inactivity=86401
uci set wireless.@wifi-iface[0].skip_inactivity_poll=1
uci set wireless.@wifi-iface[0].wpa_group_rekey=0
uci commit wireless

with txpower at 20 (100mw, horrible range).

Is it feasible you think to build it with the mediatek blobs? (lede thread I started above)


#67

I doubt you will be able to use Mediateks blobs.
I think that Mediateks drivers don't use mac80211 and cfg80211 like the mainline kernel does for anything 802.11 as standard.
They use patched old kernel version in which they basically completely bypass them.


#68

This guy made it work. http://vonger.cn/?p=14290


#69

Well he most likely had to make a lot of patches and also it looks like he was using older build of LEDE.
I doubt it will ever be merged in LEDE


#70

Yes :slight_smile: I have made MTK wifi driver blob work, I want to run it on my VoCore2 and other LEDE device. But currently it still have critical bugs, its speed will become low after minutes. I am still working on this but I guess the process is a bit slow.. There are ten thousands of code need to clean up. If you are interesting help boost this, email me at support@vocore.io. Later I will public a firmware on my blog so everybody could test the blob...I was planing to make it perfect then public :stuck_out_tongue:


#71

That's great news Vonger, thanks so much for chiming in.

Yes, interested in boosting. I'm sure several people in here as well.


#72

is there alreadt a firmware for tplink ver5 eu...is it compatible with an openvpn like the other v4...which runs smoothly..


#73

PR for 840N v5 was just merged so tommorow there should be official LEDE images


#74

shout out to master robimarko...at last...it is done...
testing tommorrow for v5 at its vpn...


#75

Sucks donkey balls on WiFi though. Very stable in wired.


#76

sad.... hope there will be a fix soon


#77

can someone help me teach me how to revert back to stock firmware?

or

teach me how to setup wlan from another wlan to install luci...
im new to lede please thank you


#78

how sucks is wifi...is there no fix with this


#79

I have put the blob driver to vonger.cn, if anybody want have a try, just call insmod and use iwpriv setup the paramters it will work. :slight_smile:


#80

Hey! Will try right away! could you link to the post? cant see it.