Support for TL-WR840N(ES) Ver 5.0 (EU)

Too bad - do you know one that we could contact for assistance? haha. Thanks!

Unfortunately not
Maybe @pepe2k can help us since he added support for v4

Hi Robert Marko,

It's great to see some work on this device. I tried your firmware however it does not work. Anything moved ahead?

No, I am busy working on CPE210 v2.
I have not tried anything new for this device

@pepe2k Hi Piotr! so, any pointers would be greatly appreciated based on the info above.

I went to basically all the outlets in my country including large wholesalers. TL-WR840N Ver 5.0 is all they have. Ver 4.0 is out the window.

(CPE210v2) I got a couple of these a few days ago. They work rather well. I wish there was a way for me to make WiFi go "everywhere" as opposed to so pinpointed. in Stock, you have to be almost in front of the thing to get good speeds. I want to permeate a 2 acre area with one or a couple of these, omnidirectioanlly . I saw yesterday's commit for the 25mhz, awesome! - Is it booting?

Wrong thread,but yes it boots and works normally

Whoops. sorry. I thought I was on the cpe210 one.

is there already a firmware for wr840n v5...

No, there isnt. And its sorely needed.

Here we go with cat mtd proc and partitions for V5

~ # cat /proc/cpuinfo
system type             : MT7628
processor               : 0
cpu model               : MIPS 24Kc V5.5
BogoMIPS                : 386.04
wait instruction        : yes
microsecond timers      : yes
tlb_entries             : 32
extra interrupt vector  : yes
hardware watchpoint     : yes, count: 4, address/irw mask: [0x0ffc, 0x0ffc, 0x0ffb, 0x0ffb]
ASEs implemented        : mips16 dsp
shadow register sets    : 1
core                    : 0
VCED exceptions         : not available
VCEI exceptions         : not available

~ # cat /proc/mtd
dev:    size   erasesize  name
mtd0: 00020000 00010000 "boot"
mtd1: 00100000 00010000 "kernel"
mtd2: 002c0000 00010000 "rootfs"
mtd3: 00010000 00010000 "config"
mtd4: 00010000 00010000 "radio"

~ # cat /proc/partitions
major minor  #blocks  name

  31        0        128 mtdblock0
  31        1       1024 mtdblock1
  31        2       2816 mtdblock2
  31        3         64 mtdblock3
  31        4         64 mtdblock4

Maybe with this data we can elicit the help of @pepe2k who gave us support or V4, or @robimarko who just ported CPE210V2 (awesome work by the way, tested, works perfect)

I would love to help, but I don't have access to 840N v5.
It is not easy or practical to attempt anything without having physical access.

Send me a private message with your address and I'll get you a router from Amazon in the next 24 hours thank you so very much for your willingness to assist us

Send me your address via private message and I will more than gladly send
you one over from Amazon in the next 24 hours

robimarko is our last hope

Received 840N v5 today and started working on it.
Currently, I am stuck on not being able to flash image on the router in order to test it.
It looks like the issue is in layout for 4MB devices, more precise lack of it.
I made one but there is an issue that when I try to TFTP flash image router gets hard bricked and only rewriting SPI flash with a dump that I made recovers it.
That really slows down any attempt to flash.
And without flashing I really cant to any further

Actually just managed to flash sysupgrade image through WEB UI.
It booted, WAN and LAN work.
WLAN needs testing.
MAC address is read correctly, gotta check if radio calibration data location is correct.
There is only one LED and it uses green as default in bootloader and stock uses orange when booted, gotta look into that.

WLAN works and corrected its calibration partition since performance without it was terrible.
As far as LEDs go there is only one dual color but the gpio-led driver in LEDE does not support changing two values at once so only green one is used.
I have also registered the orange one so if you want to use it later you can.

If someone wants to test just contact me, it would be great to test on a couple of devices and if there are no bugs I will open PR to merge it in LEDE.

1 Like

Want to test definitely!!