Support for TL-WR810N v2

I was wondering if anyone has a TL-WR810N v2 and was able to successfully flash LEDE on it. I looked into the LEDE source code and it looks like only v1 is supported.

Link to GPL Source:
Link to FCC Data:

EDIT: I think it should work, I've compared the \build\products_config*hwrevision*\basic.config files for v1.0 vs v2.0 -

export PRODUCT_ID=0x08100001 is identical in both, which matches the TPLINK_HWID value in the LEDE source code:, along with unchanged physical locations, file sizes, and board types between the two revisions.

EDIT 2: I'll go ahead and flash LEDE v17.01.2 tonight; I will post again here with an update.

Back with an update: it didn't work.

Error code: 18005
Upgrade unsuccessfully because the version of the upgraded file was incorrect. Please check the file name.

I tried renaming the LEDE .bin file to a TP-Link-like filename (wr810nv2_us_3_16_9_up_boot(160509).bin), and something simpler (e.g. flash.bin). I did this for the latest stable LEDE and also development snapshot. I even tried to flash the factory-to-ddwrt firmware for v1 from

Info from the stock TP-Link firmware upgrade page:

Firmware Version:
3.16.9 Build 160509 Rel.49605n
Hardware Version:
WR810N v2 00000000

Can anyone provide any guidance on how to proceed? Thanks!

So is anyone working on this ?

You can download the GPL code for V2 and V1 and compare the differences (e.g. with diff). Then it may be easy to figure out how to get it to work.

Error 18005 is an easy fix. It has to do with the region codes on mktplinkfw. A while back I posted a how to on openwrt forum where I had a similar issue on 710v2. Matthias schiffer helped me back then. Easy as pie.

Let me know if you can find it. On my cell so I can't look for it now.

Another ping here for this. Just bought one to take on a trip next week, was listed as working on LEDE site.... but I didn't realize they're now selling v2 devices.

I'm guessing that for the person with the right knowledge, such as whoever built the v1 image, this would take like an hour if they had the hardware to fiddle with, but I have no idea what is required, and now I'm afraid I should have bought the more expensive Mikrotik device I was considering.... sigh

Like always it is really hard for any developer to develop for a device they dont have at hand.
I think that nobody can keep up with TP-Links revision policy these days

1 Like

A good solution is to donate devices. Haha.

If someone can give specific instructions as to what info would be needed, and how to test this I have a device brand new and just opened here. I can follow instructions to set up tftp from my laptop, or flash on the web interface with no problems. I'm unlikely to be able to debrick this thing through taking it apart in any way, not because I don't have the skills, just because I have two small children and a crapload of other things to do, so with that in mind... I'm sort of offering to help remotely a bit over the next few days if that is of any help to anyone.

Here we go, found the old thread.

In a nutshell, all it does is add this line:
IMAGE/factory.bin := append-rootfs | mktplinkfw factory -C US
right before "endef" inside target/linux/ar71xx/image/
Example Before for TL-WR710N:

Example Before for TL-WR710N:

define Device/tl-wr710n-v1
  DEVICE_PACKAGES := kmod-usb-core kmod-usb2
  TPLINK_HWID := 0x07100001
  CONSOLE := ttyATH0,115200

Example After:

define Device/tl-wr710n-v1
  DEVICE_PACKAGES := kmod-usb-core kmod-usb2
  TPLINK_HWID := 0x07100001
  CONSOLE := ttyATH0,115200
  IMAGE/factory.bin := append-rootfs | mktplinkfw factory -C US

Hm,I can take a look at WR810N v2 profile tommorow.
Gotta check if GPL sources have changed

I don't think this is a regional issue, I think the factory firmware expects a particular file name, I just have no idea what it would be. I mean I could guess that the tftp which used to want wr810nv1_tp_recovery.bin would now want wr810nv2_tp_recovery.bin but there's no reason TP would do something rational :wink:

I haven't tried to force a tftp load, but it won't take a file with that name over the web admin:

Here's the old OWRT page for the version 1 device:

I doubt that it is filename issue.
TP Link newer checked for specific file name,they only have name lengh limit.

TFTP flashing does not check regional code or anything else so that would pass.

But you dont want to do that until you are sure that everything is the same.
Can you open it and take pictures of SoC,Flash and RAM.

In my experience you can't Tftp a 710v1. At least I never figured out how. Normal way doesn't work. I think 810 being nearly identical has to be the same.
Identical in the form factor that is. Inside I know it's quite different.

18005 is most definitely region. It was a headache of mine for hundreds of 710s I used before I switched to another model. Matthias Schiffer was kind enough to help me fix with what I just posted in the above thread and the original open wrt thread

Filename length can be an issue but it can be named whatever you want as long as its relatively small. The names a stock lede uses shouldn't be an issue tho

I don't think opening it is going to work for me, the instructions from the original owrt page suggest it's a nontrivial and destructive task (breaking some fused plastic for the LED etc). I'll scour the web to see if someone's done it before though... be back in a bit.

I dont think it is identical hardware wise.
That should be confirmed before flashing v1 image,also TFTP does work on WR810N.

Well,can you at least get dmesg from SSH?
That should include bootlog

ssh into the stock firmware and dmesg? I can do that, it's just admin/admin password login?

Yes,dmesg should be available if TP Link did not remove it like they did with DD lately.
It should be admin/admin if you did not change the credentials

Really? I've never been able to ssh into a stock without serial. I think you need a specific Mac address. Granted I've never tried to do it for every model I've ever used. A couple I've tried don't work with admin admin over ssh