Support for RTL838x based managed switches

Only if there are hardware differences. If the device is fully supported with the current image, then I don't see the need to add what is essentially an alias. If you insisted, the DTS could be updated to explicitly reflect v1+v2 support, with associated DEVICE_ALTx_* variables in the Makefile.

1 Like

At the time support was added for the PoE version of the switch (GS1900-8HP) it covered both V1 and V2 versions. The support for non-PoE (GS1900-8) landed a couple of months later and likely only covered V1 as that was what the developer had access to.

Thank you for the explanation.

Submitted PR #14967 for review.
Thank you for any feedback on this.

Just to understand, did you flash openwrt on a gs1900-8/b1 with no apparent problem?

Thanks

Yes, 23.05.2 and now .3

Only errors I see repeatingly in the kernel log:

rtl83xx_fib_event: FIB_RULE ADD/DEL for IPv6 not supported
rtl83xx_fib_event_work_do: FIB4 failed
1 Like

How would one go on about creating a backup from u-boot?

Dd the MTD device.

Thank you very much for catching this Richard! This reboot issue was bothering me since the switch from 21.02 to 22.03, where it started occurring. After some suggestions in here I had compared the dts files from 21.02 and recent branches and had not discovered any differences.

I now tried 23.05.3, but it seems the fix has only been added to the master branch. So I tried the latest snapshot and I finally can reboot my router again without power cycling it. As 24.xx should soon start, I think I can live without a stable release until then.

THANK YOU!

I've backported the patch to the openwrt-23.05 branch, so it will be in the next time there's a release.

3 Likes

oh very nice, thanks Sander!

This topic is regarding RTL838x managed switches. The RTL8198C SOC is not a switch SOC, so you may need to search for other forum topics.

Ok, I have a GS1900-8 B1 on my hands. Haven't modded it yet, I just noticed that its webui is painfully slow when using https: is that the case with openwrt as well?

Did not find it slow with 23.05.3. but yes the zyxel UI is slow.

Looks like 802.1X support for wired network authentication has briefly been discussed on this thread before. Does anyone know if any supported switches include hardware support for MACsec? It looks like some newer PHYs like the RTL8221B-VM-CG do include it, but a quick search didn't turn up switches which are using these. In a different context I posted here MACsec (802.1AE) with 802.1X (EAPOL) key management with wpa_supplicant on the topic of adding 802.1X plus 802.1AE (MACsec) support to the OpenWrt hostapd, wpa_supplicant, wpad packages.

The RTL9301 supports 24 or 48 gigabit port configurations, with 4x SFP+. Around here you can buy a Zyxel XGS1930-28 (24x 1G + 4x SFP+) for a little under €300 excluding sales tax.

1 Like

Whenever I'm working on something like I make sure I'm using a digital isolator as an add-on to a "normal" USB to UART adapter. e.g. one of these:

Unlike a lot of stuff on AliExpress, the seller is reputable, design all their own stuff, and know what they are doing.

As a bonus it will also act as a level-shifter - either side can operate between 2.5V to 5.5V. In fact, I usually use one of these for all UART connections, even if I'm using something which uses a low voltage power DC power supply input. It'll stop things getting fried if one of the connected devices has a voltage that you're not expecting.

Another option (for devices which will take a wide range of voltage inputs) is to power the equipment through construction site transformers. These give a 110v output, with a "centre tapped" earth. This means that the maximum voltage present relative to ground is (110v / 2) * sqrt(2) = 78v. Still not a voltage you'd want to willingly transmit, but a lot better than the 311v peak voltage that you get from a 220v (TN) AC supply.

Has anyone else on master snapshot faced any issues accessing the switch, when the lan interface is not on vlan1?

At least with my DGS-1210-16 there seems to be a problem:

When using 23.05.x all works fine and I can use whatever vlan I want for lan.

Not sure if this is a a general OpenWrt issue on master, on realtek target, on all D-link switches or only on my specific device.

I got my hands on a Zyxel XGS1250-12 switch and installed OpenWrt 23.05.3 on it.
I can reach the upstream network from the switch, but clients connected to it, do not receive any DHCP from the upstream router.
Upstream and Clients are both connected to a port on the LAN vlan1 (untagged).

The only thing I changed was the switch ip, added gateway and upstream DNS.

I found some very old posts in this thread having similar issues. Is this issue not yet fixed in stable? Would it work when switching to the latest snapshot? Or would there be any other work around?
Thanks in advance.

Could you share your /etc/config/network file in a preformatted text block for us? Also, have you disabled dnsmasq on this switch?

The unmodified image does not contain dnsmasq.

/etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'xxx::/48'

config device 'switch'
        option name 'switch'
        option type 'bridge'
        option macaddr 'xxx'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        list ports 'lan5'
        list ports 'lan6'
        list ports 'lan7'
        list ports 'lan8'
        list ports 'lan9'
        list ports 'lan10'
        list ports 'lan11'
        list ports 'lan12'

config bridge-vlan 'lan_vlan'
        option device 'switch'
        option vlan '1'
        option ports 'lan1 lan2 lan3 lan4 lan5 lan6 lan7 lan8 lan9 lan10 lan11 lan12'

config device
        option name 'switch.1'
        option macaddr 'xxx'

config interface 'lan'
        option device 'switch.1'
        option proto 'static'
        option ipaddr '192.168.40.12'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.40.1'
        list dns '192.168.40.1'
        option broadcast '192.168.40.255'