Support for RTL838x based managed switches

@colton.conor An attempt at a helicopter view:

  • @svanheule is the main team member looking after the Realtek target.
  • Both @blocktrron and @daniel have worked on the target to some extent (with the former mostly on a generic PoE implementation I believe).
  • @mrnuke and @hurricos have both worked on the realtek-poe package which implements PoE control for the Broadcom PSE chips found on many Realtek PoE+ switches.
  • @musashino Has been instrumental in porting the target to 5.15 as well as other improvements.

This will be incomplete by definition and I did not intend to give anyone short shrift, apologies to the people I forgot.

2 Likes

After flashing 22.03.3 to my DGS-1210-16 it gets stuck in boot (power LED flashes fast and constantly). Only a cold boot brings it up normally. I flashed 22.03.2 with "keep data" and it is the same.
If I recall that issue was discussed here some time ago, but I was not able to find it anymore.
Will probably try a factory reset next weekend to see if it is a broken config.

No problem, I don't mind feeling left out :smiley:

This is fully hardware controlled. When the SoC powers up, that is the default state of the led/pin.

So you are saying a 'reboot' causes it to fail to boot? Do you have any logs?

You were the first I pointed him to for free hardware and you said 'Thanks but no thanks' :stuck_out_tongue_closed_eyes:.

I meant from the birds-eye-view ;p

anyway, I've sent connor a message, I'd be interested in an 9311 as we lack those, but even a 9303 would be cool to put in a CI like-setup.

1 Like

I replied. I only have 9301's and 9311's at the moment, so no 9303.

Thanks. Now if only I had screen names to actual people. Anyone on this list identified by @Borromini , please reach out to me by PM, and I should be able to get you a free switch in exchange for development. These switches aren't cheap!

3 Likes

typo on my end :slight_smile: As long as its not a 9302 :stuck_out_tongue: which is what I have

Yes, a reboot via GUI or ssh causes it do fail booting.
I don't have the serial connected and the case is closed at the moment. I guess serial would be the only way to get the log, as all logs are in ramdisk and hence deleted after rebooting.
Let me see, if I find the time to connect the serial cable sometime next week.

Alright chaps and chips? Can anyone summarize where the support is for a Zyxel 1900 series switch? I have some 24 port devices I might flash: has anyone noticed whether we sacrifice any capabilities to be able to run openwrt?

The original firmware has STP, LLDP, LACP, IGMP and a few other useful bits - do these appear in the openwrt firmwares (whether built in or via pkgs)?

My understanding is:
LACP support is there, but no GUI config is merged yet.
IGMP works
STP ...?

@plappermaul can you re-open the LACP GUI PR, and address the fixes? If bonding turns out to be a better solution in the long term, then fix those later.

I finally connected the serial console to the switch and issued the reboot command.
It seems it already gets stuck during shutdown.
Please see the log serial log, from the moment I issued the reboot command: https://haste.tchncs.de/olubosaxoh.yaml

addition in case you haven't followed the conversation: D-link DGS-1210-16 G1 with 22.03.2 (I had flashed 22.03.2 after I discovered that issue with 22.03.3, but the issue remained after the downgrade)