Support for RTL838x based managed switches

bmork, I added your 7 patches to master and compiled it.

On my 1000Base-T SFP I see now "TP" as supported and can set the modes supported by the module:

root@OpenWrt:~# ethtool -s lan9 speed 10 duplex full
Cannot set new settings: Invalid argument
  not setting speed
  not setting duplex
root@OpenWrt:~# ethtool -s lan9 speed 1000 duplex full
root@OpenWrt:~# ethtool lan9
Settings for lan9:
	Supported ports: [ TP MII ]
	Supported link modes:   1000baseT/Half 1000baseT/Full 
	                        1000baseX/Full 
	Supported pause frame use: Symmetric Receive-only
	Supports auto-negotiation: Yes
	Supported FEC modes: Not reported
	Advertised link modes:  1000baseT/Full 
	Advertised pause frame use: Symmetric Receive-only
	Advertised auto-negotiation: Yes
	Advertised FEC modes: Not reported
	Link partner advertised link modes:  10baseT/Half 10baseT/Full 
	                                     100baseT/Half 100baseT/Full 
	                                     1000baseT/Full 
	Link partner advertised pause frame use: Symmetric Receive-only
	Link partner advertised auto-negotiation: Yes
	Link partner advertised FEC modes: Not reported
	Speed: 1000Mb/s
	Duplex: Full
	Port: MII
	PHYAD: 22
	Transceiver: external
	Auto-negotiation: on
	Supports Wake-on: d
	Wake-on: d
	Link detected: yes

Installed poe package. Now I can also see power consumption:

root@OpenWrt:/tmp# ubus call poe info
{
        "ports": [
                "enabled",
                "enabled",
                "2.2W",
                "enabled",
                "enabled",
                "enabled",
                "enabled",
                "enabled"
        ],
        "power_budget": "77W",
        "power_consumption": "2.2W"
}

That's awesome. Thanks to all for support!

I see official support for Zyxel GS1900-8 has been merged. Any plans to do the same for GS1900-16 please? Thank you.

I am not aware that anyone among the developer who has that device already. If you got one yourself, then we can help you get it supported. You should go to https://www.biot.com/switches/models and add a description of the device. Important would be a photo of the interior, plus the output of the "show tech-support" command in the OEM shell, which gives the complete PHY and GPIO mapping of the device. Finally, to build an image the layout of the flash as shown in u-boot. With this information it is usually only about half an hour's work to make a .dts.

1 Like

Many thanks for the explanation, @bmork ! Didn't know that.

It's documented in the device's wiki page.

As is seems there are a lot of devs here, I'd like to ask for your ideas on how to find the reason for my lan1 not being accessible from the device directly connected to it.

Setup:

  • D-Link DGS-1210-16 rev. G running OpenWrt master r16153
  • 4 VLANs (1=internal, 2=IoT, 3=guest, 4=internet-only), switch itself bound to VLAN 1
  • Internet router (192.168.[1-4].1) serving these 4 VLANs connected to lan1
  • WLAN-AP (Netgear R7800) with 4 SSIDs corresponding to the 4 VLANs) connected to lan5
  • Desktop computer connected to WLAN-AP on untagged port with PVID 1

Problem:

  • Everything works as intended, with one exception: I cannot access the DGS-1210-16 from the router. It does not answer pings or SSH login requests, instead runs into timeouts.

Fun facts:

  • lan1 seems to work because traffic is flowing through it. I can reach the router through lan1, browse the internet and so on. Only packets coming in on lan1 targeted for the switch itself are ignored.
  • When plugging the router from lan1 to any other port of lan2..lan8 on the DGS-1210-16, the problem disappears. I don't understand that because lan1..lan8 are using the same configuration in my setup (see below).

What should not be the the reason for this:

  • iptables (firewall, ip6tables and iptables are omitted from my build)
  • ebtables (not installed)
  • different configuration of lan1 (which does not work) and lan2..lan8 (which do work)

See below the output of uci show network.

I'd be very thankful for any hint on how to track down the problem.

network.loopback=interface
network.loopback.ifname='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.globals=globals
network.switch=device
network.switch.name='switch'
network.switch.type='bridge'
network.switch.macaddr='e0:1c:fc:12:02:34'
network.switch.ipv6='0'
network.lan_vlan=bridge-vlan
network.lan_vlan.device='switch'
network.lan_vlan.vlan='1'
network.lan_vlan.ports='lan1:t lan2:t lan3:t lan4:t lan5:t lan6:t lan7:t lan8:t lan9 lan10 lan11 lan12 lan13 lan14 lan15 lan16 lan17 lan18 lan19 lan20'
network.lan=interface
network.lan.ifname='switch.1'
network.lan.proto='static'
network.lan.netmask='255.255.255.0'
network.lan.ipaddr='192.168.1.241'
network.lan.gateway='192.168.1.1'
network.lan.dns='192.168.1.1' 
network.lan.dns_search='intranet'
network.lan_switch_1_dev=device
network.lan_switch_1_dev.name='switch.1'
network.lan_switch_1_dev.macaddr='e2:1c:fc:12:02:34'
network.eth0=interface
network.eth0.ifname='eth0'
network.eth0.proto='none'
network.eth0.ipv6='0'
network.iot_vlan=bridge-vlan
network.iot_vlan.device='switch'
network.iot_vlan.vlan='2'
network.iot_vlan.ports='lan1:t lan2:t lan3:t lan4:t lan5:t lan6:t lan7:t lan8:t'
network.guest_vlan=bridge-vlan
network.guest_vlan.device='switch'
network.guest_vlan.vlan='3'
network.guest_vlan.ports='lan1:t lan2:t lan3:t lan4:t lan5:t lan6:t lan7:t lan8:t'
network.inetonly_vlan=bridge-vlan
network.inetonly_vlan.device='switch'
network.inetonly_vlan.vlan='4'
network.inetonly_vlan.ports='lan1:t lan2:t lan3:t lan4:t lan5:t lan6:t lan7:t lan8:t'

That not the case with ALL-SG8208M, right?

The ALLNET ALL-SG8208M is supported as Proof of Concept:
[…]
To install, upload the sysupgrade image to the OEM webpage.

1 Like

I stand corrected. I have no experience with the ALLNET switches.

What I do know is that the Netgear GS108Tv3 will allow you to flash any image with a matching U-Boot image header, but will cut off the file at the size given by that header. Which means that it will write only the kernel part of an OpenWrt sysupgrade image, silently dropping the rootfs, and therefore brick the device.

The ZyXEL GS1900-10HP on the other hand, will only accept images with a ZyXEL specific trailer indicating that it is intended for that specific hardware (using a ZyXEL version number with a 4 letter hardware code). It cuts off the file like the Netgear firmware, so it can't write a kernel+rootfs sysupgrade image either. But it cuts the file before validating the trailer. Which means that we have to include the trailer in the kernel part of the image (inside the size covered by the U-Boot header). This should only be done for the initramfs images, thereby preventing the sysupgrade images from being flashed directly from stock firmware.

I'm totally confused on how to actually access the switch after getting the initial image installed! I've started with a GS108Tv3. Uploaded the initramfs image via the OEM Web access. I can see from the serial port access that OpenWrt is running, but I can't seem to access it from any of the Ethernet ports! From what I've read it should be available at 192.168.1.1 from ports 2-8.

After using Borromini's posted UCI defaults above I was successful in connecting to the switch. Perhaps the default should be changed to something similar so that initial login won't be a crap shoot if you don't have serial access!

Currently, the management interface (luci, ssh, etc.) is only available on port 1 and VID 100, so you need to connect your computer to port1 and configure your computer's network card to use (tag all packets with-) VLAN ID 100 (then you can connect to 192.168.1.1).

Certainly not my favourite either, but it works. I'd be very much in favour of changing the defaults as well, but it is a bit more complex to get this 'right', as it's still a switch and not really a router with routing, NAT, and a DHCPd running - somehow I don't think change this in the last minute (for 21.02.0) would be the best idea (personally I'd favour it to be configured for DHCP-client, but then it gets very special, with even more default assumptions that might go wrong…).

How many people are going to know how to set up their computer's network card to tag all packets with a specific VLAN ID? It would make more sense to set up all ports to the same IP address just like most of the OEM firmware does.

1 Like

I'm not arguing against that at all, on the contrary, but I do see problems in trying to rush a change (keeping in mind that the realtek target looks like being present in openwrt-21.02) - as a bodged attempt may be more problematic than considering the current state a technology preview with known quirks.

2 Likes

This is definitely a bit late, but I still believe it's better to fix it now before the very first release of this target. A number of advanced early adopters have already been bitten by the issue. There is no doubt that it will cause endless confusion for end users trying to flash an official 21.02 image without having console access.

I'll see if I get around to cook up something later today.

We should also fixup default configuration for switches with more than one mac address, storing the full range in "u-boot-env2" like the ZyXEL GS1900 does.

And the PoE package should go in. It's working very well, and is required for the PoE feature. I see no reason to keep that out of 21.02. It will just confuse and annoy users who have to jump through burning hoops for no reason at all.

4 Likes

Seriously, I have been advocating this from the beginning of Realtek switch support. And I will bring it up once more, and then never again:

If you create OpenWrt for a device, make it an OpenWrt device.

This means using the same default config and the same default packages as any other device. Even if it doesn't look like other devices, or was a different device before (as if that was a factor anyway.)

As much sense as it makes to you to have some pre-configuration that moves it closer to the device it once was, it makes your device "based on OpenWrt" rather than "running OpenWrt." Case in point: It is easier to introduce a VLAN than to remove it. It is easier to disable the default dhcp server and firewall than to recreate it if you need it. It is easier to set an interface to DHCP from the default static adress than the other way around (yes, unfortunately this actually happens on some devices/targets.)

3 Likes

I'm trying to add support for the Netgear GS308T and GS310TP, but because of the horrible default network setup I'm having difficulty determining whether the issues I'm having is related to my total misunderstanding of using tagged VLANS or if there is an issue with the actual device! I get link lights on both the switch and the connected device, but can't get a response from ping or any other service! How exactly must the connected device be configured to access the switch?

# ip link add link enp2s0 name enp2s0.100 type vlan id 100
# ip link set dev enp2s0.100 up
# ip addr add 192.168.1.10/24 dev enp2s0.100

on your client will give you full access to the management interface (well, at least if plugged into port 1), including ssh/ luci, etc.

2 Likes

Important part to note: It will only work on port 1. That's the only port where VLAN 100 is configured.

(another reason this is a bad idea: port 1 is special on the PoE powered devices like the GS108Tv3, and using it for even temporary management might be a problem if you can't easily reconfigured the PSE)

2 Likes

Late as usual, but submitted now: https://lists.openwrt.org/pipermail/openwrt-devel/2021-April/034652.html

Not tested as hard as I'd like, so I'd appreciate testers adding Tested-by. I guess support of 21.02 backporting is important too..

The resulting default config on my Netgear GS108Tv3 is:

root@OpenWrt:/# cat /etc/config/network 

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd1a:643c:5c9c::/48'

config device 'switch'
        option name 'switch'
        option type 'bridge'
        option macaddr 'bc:a5:11:9f:e1:23'

config bridge-vlan 'lan_vlan'
        option device 'switch'
        option vlan '1'
        option ports 'lan1 lan2 lan3 lan4 lan5 lan6 lan7 lan8'

config interface 'lan'
        option ifname 'switch.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device 'lan_switch_1_dev'
        option name 'switch.1'
        option macaddr 'bc:a5:11:9f:e1:23'
1 Like