Support for qMp on gl-ar300m?

I hope I'm writing in the right place, and I can find somebody who can help!

I am trying to install qMp firmware on a g-inet ar300m-lite router.
I downloaded this version:
and tryed to install lede-17.01.4-qmp-tiny-ar71xx-generic-gl-ar300m-squashfs-sysupgrade.bin, and installation looks good.


After installation I can find the admin page and it looks working, but once logged in I get this error:

/usr/lib/lua/luci/dispatcher.lua:460: Failed to execute function dispatcher target for entry '/'.
The called action terminated with an exception:
/usr/lib/lua/luci/dispatcher.lua:460: Failed to execute template dispatcher target for entry '/qmp'.
The called action terminated with an exception:
/usr/lib/lua/luci/template.lua:74: Failed to load template 'admin_status/index'.
Error while parsing template '/usr/lib/lua/luci/view/admin_status/index.htm':
No such file or directory
stack traceback:
	[C]: in function 'assert'
	/usr/lib/lua/luci/dispatcher.lua:460: in function 'dispatch'
	/usr/lib/lua/luci/dispatcher.lua:141: in function </usr/lib/lua/luci/dispatcher.lua:140>

Thank you very much for the help!

For support with your device, contact qMp:

It's their firmware.

Also, per the Community Guidelines, please refrain from signing your posts.

While not specifically answering you QmP issue.

You could try Libremesh ?

Stable build

Online builder (experimental)

Especially as (a) you're having problems, (b) 17.01.4 is nearly EOLed, and (c) qMp isn't OpenWrt, I would consider either OpenWrt itself or GL.iNet's OEM (v3) firmware which is effectively 18.06.1 with their applications and wide range of packages running "next to" LuCI and OpenWrt beneath (with NAND drivers). I run both OpenWrt and GL.iNet both on my AR300M-Lite and AR750S.

1 Like

Thank you for your answers.
qMp is based on openWrt, that's why I tried to ask here, there is no community about that! :pensive:

I shoult try to run qMp because University asked me to make some research about that, but alternatives you mentioned are really interesting, thank you anyway!

They never answer :persevere:

Unfortunately one of the challenges with open-source software is that it is often used for the basis of other projects that may not have the same level of code quality and/or support as the "upstream" sources do.

1 Like

I tried both qMP and Libremesh and prefer Libremesh