Support for new Archer c5 v4

Because the branch is specific for TP-Link Archer C5 v4 DSA, i suppose the necessary patches are included and the switch support is enabled when select the same model. Am I right?

i think this device isn't officially supported by openwrt
the releases available here https://github.com/benwht/openwrt/releases which work well, use a realtek switch patch

i remember bec i used the patch for building for my c5 v4 few years ago

Yes, I also used benwht's patch and know that his patch works. But because that patch is not applicable for OpenWrt 21.02, I decided to switch to luizluca's https://github.com/luizluca/openwrt/tree/tplink_c5v4_dsa_5.15up to try it.
And that's why I asked if anybody tried to compile luizluca's specific branch to help me set it correctly.

You need "Use the testing kernel version" (Global build settings), not "Enable experimental features by default"

1 Like

@luizluca, "Enable experimental features by default" auto-selects "Use the testing kernel version". The wan and lan ports don't work with neither tplink_c5v4_dsa_5.15up nor tplink_c5v4_dsa branches. There is Rx activity, but no Tx traffic.

1 Like

It should have worked. You do need to have packages kmod-switch-realtek-mdio installed. If is selected by default in a clean config but nothing prevents the user to unselect it.

I just refreshed my branch with equivalent results https://github.com/luizluca/openwrt/tree/tplink_c5v4_dsa

The issues I current have with that branch are:

  1. forwarding is done in SW (current driver limitation)
  2. only one LAN port works at a time (maybe because of 1)
  3. only one wireless card recognized
  4. I still need to disable all resets (there is an unknown issue with reset and 5.15)

And there is an unfixable limitation with any mediatek+realtek DSA: no TCP checksum offload.

1 Like

Greetings. I have a few setup questions.

  1. Did I do the right thing when I combined all the interfaces of the router into one bridge? Without this, nothing worked stably on the internal network connected to the router.
  2. How to view all packets passing through all ports of the router to the outside and entering from the Internet? Is it possible to configure a SPAN port on this router?

Hello,

I believe the port is finished. Again the repo is the same.

It requires testing kernel (CONFIG_HAS_TESTING_KERNEL=y) and it might automatically select CONFIG_PACKAGE_kmod-switch-realtek-mdio (menuconfig does not prevent you from removing it). Everything I tested worked as expected, even failsafe.

It include dozens of pending patches, but only for OpenWrt. Many of those patches for OpenWrt are related to mediatek network driver for mt7620. I might start to submit them soon. All required upstream changes are already merged (backported from 5.16 .. 5.19/net_next). However, I'm not sure it is safe (for other devices) to have that much of backported patches. DSA is still evolving upstream and the changes I picked might also break another DSA driver. Anyway, time is our ally and we'll get them for free as soon as OpenWrt goes to the next LTS kernel (post 5.15).

Changes since the last update:

  1. Resets started to work (not fixed by me). I removed the hack and USB and both wireless started to work
  2. The issue with only 1 LAN client was the internal mediatek switch not happy with realtek forwarding frames in CPU. I disabled the source mac learning and it now works as expected.

I don't believe the port can get much better than this. Except from a better switch driver (that actually does forwarding in HW) or a better 2.4G wifi (yes, it still sucks as before), there is no more room for large improvements. The mix "mediatek Soc + any non-mediatek DSA switch" might be slower than swconfig because mediatek cannot handle TCP checksum offload with a DSA tag. I didn't evaluated if an 802.1Q DSA tag might work better but the driver might need to improve before we try.

I didn't do a performance compassion between DSA, swconfig and factory but I expect DSA to be the slowest one. And don't expect good LAN to LAN performance until we get a proper fowarding in HW.

As I said, I might start to send some preliminary patches to the list soon. Even if all of them get merged, I might still wait for the next testing kernel before submitting the device port. The required backported patches might also be submitted by someone willing to use that Realtek driver for another device. @hauke submitted some upstream patches indicating he is working on another Realtek device. There are plenty of them already in OpenWrt.

Once all generic patches are applied, the device patch is a boring DTS declaration (with a minor LED config).

Have fun!

2 Likes

compiled the latest firmware

OpenWrt v21.2
OpenWrt v22.3

2 Likes

Hi, thanks for share. The wifi 2.4g was solved?

How can i install? Can you make a tutorial?

Download the "openwrt-ramips-mt7620-tplink_archer-c5-v4-squashfs-tftp-recovery.bin`

  1. rename the openwrt-ramips-mt7620-tplink_archer-c5-v4-squashfs-tftp-recovery.bin* to tp_recovery.bin
  2. start a TFTP server from IP address 192.168.0.66 and serve the image named tp_recovery.bin
  3. select the firmware file and press "enter"
  4. connect your device to the router LAN port (1-4)
    to start the TFTP recovery process on the router, press and hold the “Reset button” and then power up the router. Keep the “Reset button” pressed until the WPS LED turns on (it's the LED with two arrows pointing in different directions)
  5. If everything went well, you should see a read request on your TFTP server
1 Like

Thank for share. I have The brazilian Archer C5(W) V4, where i can find the imagen?

Thank you very much for sharing.

My c5v4 started with a git clone compiled previous version.

I use your v22.3 sysupgrade image, upgrade via Luci keeping config.

Works smoothly.

System
Hostname	owrtap
Model	TP-Link Archer C5 v4
Architecture	MediaTek MT7620A ver:2 eco:6
Target Platform	ramips/mt7620
Firmware Version	OpenWrt 22.03-SNAPSHOT r19446-f393581f66 / LuCI openwrt-22.03 branch git-22.167.28394-8a4486a
Kernel Version	5.10.120

Issues find in this build:

  • The WIFI is not stable, will stop working completely after a few hours. (SSID stop broadcasting. New association cannot be made. Existing associations will drop. LAN router is working normally.)

It is the same. And the 2.4ghz is still as bad as before.

hi
did you managed to flash openWRT firmware on ur router (provided by ACT ) ?
I just want to get rid of that tr069 thing

@anbuchelva

Yes. use tftp method. I tried the old firmware which had issues in 2.4G band. So i flashed stock and keep using it. I haven't got time to flash the new version.

running tftp server on 192.168.0.66 ip is required to boot the router into recovery mode ?
I tried but can't get it to boot into recovery mode
kept the wps button pushed but still the wps led won't blink @anbuchelva

Greeting all.
Is anyone working on 21.xx branch? When is it expected to be available?

Thank you for your attention.