Support for new Archer c5 v4

Hi I have recently flashed the act router, let me know what help you are looking for..I am happy to help :slight_smile:

1 Like

Hi @mirobiala , could you please compile openwrt latest build for me. I installed below build in my Archer c5 v4 router , but i cannot install kmod-usb-storage,ntfs-3g packages as it shows cannot satisfy dependencies error .if I forcefully install it then also I cannot mount any usb devices

Could you please help me

No. You'll need to use the firmware recovery procedure or a serial connection.

The instructions are here ( If they are not detailed enough, maybe you should avoid OpenWrt in C5v4 for now while the support for it is not merged.

I don't know and I never looked for it. OpenWrt is a requirement for me.

The device support is not merged. It requires an ethernet switch driver that is currently only used by mediatek target ( derived from my PR). If that gets merged (or another driver variant), the C5v4 port would be a more classical process and easier to get merged. I'm working on this for years and there is no ETA. I think that, as more devices requires that same ethernet switch driver, it will eventually touch one of the developers with commit access.

So, before that, you'll either apply the patch yourself and built it locally or use one of the unofficial images distributed here. Most packages will work and you'll be able to update them from the project as there is no "device specific package". However, kernel fixes will require a new image built by yourself or others. Also, as you will use a slightly different kernel, opkg will blame you if you install a kmod package as dependency mismatches the expected kernel signature (but forcing it might work).

You can replace your C5v4 with OpenWrt but you'll have some difficulties during package install (kmods) and firmware updates. And wifi 2.5g performance is terrible. If you are not a dev or a tester, stick with the original firmware for now.


Hi @ananthu04 , i also had the same problem on oldest version.
Look here openwrt forum topic.

So I own a C5 V4 and was wanting to install openwrt on it.
What are the issues that it currently has , and can I get a link for the files as well.


There is no new development.

I have one C5 V4 running 19.03 as my main router/wifi ap. The 2.4GHz radio is very bad - so I basically disabled it and use 5GHz radio only.

It is working fine for me.


What needs to be done in order to build 19.07.8 for Archer c5 v4?

You can use this patch in 19.07.8:

This patch is for master, but can be applied to the 19 branch....
Basically, the problem is with the Realtek Giga Switch driver that is not supported by Openwrt yet. We are working with Openwrt to include support for this chip.


Not really "working" but actually "waiting" for someone to review/reject/accept the PR

Hi guys, some information about firmware 21.02 for archer c5v4?? Thank’s.

We are still waiting for the someone to review/reject/accept the PR.

The Realtek Chip for the gigabit switch driver is not supported by Openwrt yet , all of us are waiting on it too.

If you want to install it now , the 2.4ghz radio wont work and only 5ghz is usable.

1 Like

I'm a newbie here using Archer C5 v4 provided by Act Fibernet.. can you pls share the full guide?

1 Like

update: successfully updated openwrt using TFTP recovery mode.

@gaspare I tried compiling the firmware using this patch; but the firmware doesn't seems to work.
can you help me if i am missing something.

Steps followed:
installed dependencies from here

git clone
cd openwrt
./scripts/feeds update -a
./scripts/feeds install -a

downloaded this patch then

git apply 4327.patch
make defconfig
make menuconfig

set Target System: MediaTek Ralink MIPS
set Subtarget: MT7620..
set Target Profile: TP-Link Archer C5 v4
saved as archerc5v4.config

make -j4 V=s

This patch worked for building a current firmware, based on v21.02.1, really awesome.

1 Like

can you share the binary files to update?

The files and instructions you provided work just fine, the only adjustment required is that the patch complains about the permission of two files not being 644.

I fixed this by issuing something like this before applying the patch:

chmod 644 target/linux/ramips/mt7620/base-files/etc/board.d/01_leds
chmod 644 target/linux/ramips/mt7620/base-files/etc/board.d/02_network

When doing git apply 4327.patch is is silent and returns nothing.

So I do not have the permission errors?

Update 2:

Basically, the current config from 19.07 do not work fully.

For the first boot up, there is switch0, with no ports active. Switch 1, which is the active switch.

After install of luci, any change of Interface config will result in failed when apply. Need to manually remove switch0 entries in /etc/config/network, reboot, then edits in luci will work.

Update: I proceeded to force upgrade. And it works so far.

I can generate the rom file after cp archerc5v4.config .config .

When flash the file with sysupgrade, I got:

Screen Shot 2021-11-05 at 17.26.56

Should I force upgrade?

Glad that worked for you. I don't know it didn't work how many times I tried building / flashing; not sure it is because the router is provided by my ISP (Act Fibernet from India).

After flashing the firmware using tftp the router reboots and doesn't connect to LAN. So, no way for me to access it.

1 Like

I remember when I do the first sysupgrade after build, I opt to keep existing configuration.

Then I can use the previous IP and Admin/password to access the router.

Only when I find the extra switch0 / switch1 issue, then I proceed to manually do a reset to factory vi ssh .

And, I think I build with the latest development snapshot, as I don't know how to select a tagged version using git, yet.

1 Like