Support for new Archer c5 v4


Include C5 with C20, C50, etc ...

Olá! amigo, não é possível queimar os firmware do openwrt na relação do melhoramento dos firmware de TPLINK. Você tem que usar um ferro elétrico para destacar o FLASH, a seguir usa o CH341A para queimar os firmware.

c5v2 has no 5GHz.

I recently discovered openwrt.
I have installed it in a Nucom R5010UNv2 and it is awsome.
I had previously used DD-WRT in a TP-link 1043N v1.2, but I prefer openwrt interface and its modularity.

Recently (a few days) I have bought an Tp-link Archer C5.
It was supposed to be he model with 2 usb, black and with two antenas (v2 I think).

But when it arrived it is a v4 model with four antennas an 1 usb.

I was reading in your forum and it seems it is not supported yet.
But is somebody working in it? May I expect to get it working with openwrt in the not so far future?

If not, I think I will be able to return it (they promised 2 usb ports in the announcement, which I think is v2 version and compatible with openwrt).
Is Archer C5 v2 fully compatible with openwrt? (the hardware list names it as compatible with current stable version).

Which other router wireless AC in this price tag may be compatible with openwrt with similar specs?

My needs are not very high. I need a clean and usefull interface, with basic router funcionality, I need VPN, I need being able to config a DNS in it to resolve internal resources, and wireless 2.4 and 5G access point.

propietary Firmwares in home router don't provide me some of the services, like DNS (dnsmasq configuration) and in some cases VPN.

Thanks a lot for your attention and thanks for this great soft.

thanks for the advice, wulfy23 should be supportable, but given its older SOC (mt7620 instead of mt7621, small flash and RAM), it's not particularly interesting (meaning I wouldn't expect anyone to jump for it).

Support for new devices is, to a large extent, provided by non-regular contributors (that could even be you), who want to get OpenWrt working on their new, currently unsupported, device and submit their changes to OpenWrt. Accordingly there are no predictions possible which devices will get the attention and land on the desk of anyone capable to add support for a new device - it may happen tomorrow, or never at all.

1 Like

Thanks a lot for your answer.

I have mistakenly thought that Archer C5 was supported, as it is listed in the wiki as compatible.
I did not even know that there were a v4 version, I thought it was v2.

The problem is that when you buy it they don't specify the version of the router.

And oddly tp-link seems to sell quite different routers under the "Archer C5" umbrella.
I have had a tp-link router the 1043N that was quite a good one for the price, and is supported (but just wifi N).

Probably the last tp-link router i would buy as if they change the complete hardware and sell them with the same name.
They even tell you it has 2 usb ports and send you a new model with 1 usb port.

Which router in the same price tag may I buy with a doog wifi n/ac 2.4 and 5 Ghz?
I have been reading the posts here but there are many routers and lots of info that may be obsolete.

My needs are not so demanding, just a router with good wifi access and that I can control and configure with openwrt (the firmware in the archer c5 does not even resolv dns names and you cannot configure dnsmasq in any way).

At the moment I cannot contribute as I have not enough expertize with openwrt.
I can provide info about the router, its hardware and settings if somebody provides me guidance, in order to facilitate openwrt running in it.

v2 would have been completely unusable (unsupported Broadcom wlan), only v1 is supported.

You can identify the version you got via the backside label:

Yes it is version v4, but they do not specify it when they sell it.
The announcement displays a router with two antennas and says it has two usb 2.0 ports (and that is the v2 version).

Thanks shl, you are right.
I had seen the v1 and v2 router in the compatibility list, but did not realized that wifi 2.4 and 5 is not supported.

The router is OK, but has no way to configure dnsmasq in it, and I need DNS resolving.
It worked perfectly with my tests with openwrt and the old NuCom R5010UNv2/DSL-2750B.T1, but it is too old and wifi too poor.

I am going to return it, as I am still in time.

What about the linksys EA6350-EJ.
It is a bit more expensive (79€ against 33 I have paid in an offer).
It seems it is not yet supported by the official release of openwrt, but the snapshot seems to be fully compatible.

Are there more recent versions of this router than v3, which is the supported version?
Does linksys change the brand of the cpu and chipsets between versions as tp-link does?

I am looking for 4 or 5 port Gigabit lan, and wifi n/ac (800GB/s would be enough) compatible with openwrt and in the 80 € price more or less.

Please open a new topic for questions regarding which hardware to buy.

1 Like

OK, thank you, you are right, it seems mor apporpiate.

@LGA1150, is this the patch you have tested:

Is everything working with this patch?

Yes. Almost everything. Have not tested all the LEDs or WPS button because I'm actually testing it on a slightly different hardware model

1 Like

Could you please help us out with the binary?
I cant seem to compile it from the source :\

@LGA1150, if it is not much trouble, as you made it work, can you submit a PR with your patch? I believe we are few people interested in having it supported in openwrt.

I doubt they will accept the patch. Here are some reasons:

  1. Archer C5 v4 uses a different firmware header, which cannot be generated by mktplinkfw2. Currently one has to disassemble it to connect UART or SPI programmer to flash OpenWrt.
  2. The switch driver cannot be adapted into OpenWrt as-is because it has too many unnecessary parts. Instead we might reuse the current RTL8366S/RTL8366RB driver code (if someone can do that... I have tried the unmodified RTL8366RB driver, but all it reads from MDIO are 0x0070 s)
  3. And again, I have not tested all the LEDs or WPS button because I'm actually testing it on a slightly different hardware model

Make sure you have cherry-picked the RTL8367S commit as well

the problem is something with the build scripts (i have no experience with openwrt tho), from what i read online, my build environment is too new basically, so if you have a build please do share it, because i know that some of us here really want a working one

You should first install needed packages, see