Support for new Archer c5 v4

thanks for your response any tutorial or steps to do the same?

Not able to Login to act fibernet

I was using modified version of this script to login to act portal. It worked fine for long time.

Today I was getting low speeds, so i opened the portal page and clicked logout and now the router refuses to connect to the page.

Anyone knows how to fix this?

Hello I installed the OpenWrt firmware on my Archer C5w V4 with the TFTP program, but I wanted to go back to the original TP-Link firmware.
For that I have to do a procedure that I can't, because I use Windows 10 and I'm bad with these things.
Could someone get me a BR firmware with this procedure already done?

The procedure I can't do is the "2. the stock firmware will not work directly! Cut 512 bytes from the beginning, e.g.:" for this small tutorial:

restoring back to the stock firmware via TFTP (Recovery mode)

To flash the original TP-Link factory image:

  1. extract the image and rename the Archer_C5(EUWISP)v4_3.16.0_0.9.1_up_boot(181119)_2018-11-20_13.35.25.bin to tp_recovery.bin

  2. the stock firmware will not work directly! Cut 512 bytes from the beginning, e.g.:

dd if=Archer_C5(BRWISP)v4_3.16.0_0.9.1_up_boot(190404)_2019-04-04_09.56.27.bin of=tp_recovery.bin bs=512 skip=1

  1. start a TFTP server from IP address and serve the image named tp_recovery.bin

  2. connect your device to the router (LAN port 1-4)

  3. to start the TFTP recovery process on the router, press and hold the “Reset button” and then power up the router. Keep the “Reset button” pressed until the WPS LED turns on (it's the LED with two arrows pointing in different directions)

  4. If everything went well, you should see a read request on your TFTP server

Here is the link to the stock firmware I want to put back:

Sorry my bad English I'm using Google Translate.

1 Like

here: is stripped firmware to back to stock.

1 Like

can we get ur modified branch repo for the 19.07.3 build Archer C5 v4 ...?
I compiled a build from 19.07.5, added required patches for this device support....everything works except wifi...

dmesg says

mt76x2e Firmware version 0.0.0 firmware failed to start...

i have included all required kmodules for wifi

just cant get wifi to work 2.4 as well as 5ghz in 19.07.5

Archer C5v4 can now support hardware flow offloading. I can get gigabit nat speeds in ipv4.
Just need testing....

1 Like

Hi Naveen,
I'm having trouble login into the router given by ACT Fiber,
I'm connecting with serial connection using cp2102 and jumper wires but before i can pass command to install openwrt I'm unable to login, tried the combination of "admin:admin", "admin:act@123" and even changed the password through the default homepage under Administration but that failed too, it says incorrent password in the putty console.
please help @Naveen @shankar4kv

I switched my connection to tikona as i moved from ahmedabad to mumbai but this router isn't working on dhcp or pppoe either.

For those not following, there was an effort to add C5 v4 to master at However, after more than a year maintaining the PR updated, the author lost interest and closed the PR. That PR was updating existing rtl8367b driver to also support rtl8367s. That switch driver change could be what has preventing the PR to get merged.

I created a new PR based on the same driver @benwht has been using since 18.06. That driver is already merged into master but only for mediatek target. For C5v4, we just need to copy it to ramips or move it to generic target. Besides that, the port should be a harmless DTS+profile+leds+network change.


nao consigo fazer tambem

teria arquivo pronto tp link c4 v4 ,usar tftp,nao sei fazer arquivo bin

Olá Instalei o firmware OpenWrt no meu Archer C5w V4 com o programa TFTP, mas queria voltar para o firmware TP-Link original.

Het zou erg handig zijn om verder te gaan in het engels, zodat iedereen mee kan lezen.


portugues,brasil,,Hello I installed the OpenWrt firmware on my Archer C5w V4 with the TFTP program, but I wanted to go back to the original TP-Link firmware.,teria como enviar para mim,nao sei fazer flash tp link c5 v4

I have downloaded the two versions and Removed the first 512kb from the beginning, because the Hungary Version didnt allowed me to use the channels from 48 and above.

So there are two versions 1- Intermediária updated up to 2020-05-21 and 2- Final updated to 2020-05-07

I used that one for Colombia, because the other versions were not good as I mentioned Before, it works for Brasil too. Link Below. Use TFTP.

1 Like

Hi Naveen,
Can you please help me. I want to install openwrt in tp link aracher c5 router provided by ACT network

@luizluca @Rxxar Dear all,

Few basic questions. You are all coders / developers. I'm being an end-user who owns an Archer C5 V4 model.

  1. I'm on stock TP Link firmware. Can I update to open-wrt or any other firmware from the direct "upgrade firmware" page of stock firmware? If yes, please share the link to the file which needs to be directly upgraded.

  2. If the above question is NO, then re-direct me to link or multiple links where-in **** VERY DETAILED**** instructions (along with downloads) are given for doing the above activity of moving from stock firmware to custom firmware.

  3. Open from OpenWRT, are there any other custom roms available for this router?

  4. Is the above model part of Open WRT master roster list? If not, any ideas / practical thoughts when it would be? I'm not demanding, but, it will help me to decide whether to proceed with the upgrade (so that in future I'm assured of updates) or to replace the router.

Thank-you in anticipation, for your patience in responding and taking time off to help me understand.

Please refer to the link / URL above. Can I use any of the files given in the link to upgrade my device to OpenWrt? If yes, how....If possible, detailed approach, please. PLEASE!

Thanks-in advance.