Support for new Archer c5 v4

what software (and version) is running on the device ?

It imagem

i just checked and for me it's working. Are the cable connection OK on both ends ?


I am talking about WIFI performance.

Impossible, I've tried all the ways.
The driver of this version has a problem.

2G with 30 megs.
5G with 297 megs, don't get over it

The developer doesn't know the solution to this problem.

I do not mean cables and yes the WIFI should have 80 90 megs in 2.4 but no more than 30

A post was split to a new topic: Setting up p910nd print server

you help to use OPENWRT , solution for BUG??

Cut the first 512 bytes from stock firmware before trying to use as tftp_recovery. I added that info to wiki:

dd if=Archer_C5\(BRWISP\)v4_3.16.0_0.9.1_up_boot\(190404\)_2019-04-04_09.56.27.bin of=tp_recovery.bin bs=512 skip=1
2 Likes

Nice job guys.
The 2.4ghz wifi seems to be using only one chain as it is only 30mbps while the original firmware gets 60mbps or more.

Other functions are working very well.

Did you choose 40MHz bandwidth and enable "Force 40MHz"?

For me the version OpenWrt SNAPSHOT r10114-a1210f8888 / LuCI Master (f138fc93) was more stable.

In next image release you can please include qos package and usb share support(maybe torrent too)?

Yes, but it still shows 20mhz in the wifi status.

Hello.
Need new fullflash dump with worked stock firmware(from worked device with this flash).
Previous shared stock dump does not work for me - rebooting loop while firmware boot process.
(may be something with the config partition)
Please help me.

it is same for me

People, if it's hard for you to make fullflash, I think it's enough to make "Backup settings" from Web-interface of stock firmware (if you don't worry about confidential info like MAC-address and password for AP).
And please share it here or send it on my email: dioptimizer@hotmail.com.
I can not install stock firmware on my Archer C5v4 because I have corrupted partition named "config".

I probably started badly, sorry.
In order to make fullflash - NO need to have a programmer.
Just installed OpenWRT is enough.
You just need to open the ssh console on the router and execute the commands sequentially:

root@OpenWrt:~# cat /dev/mtd0 > /tmp/fullflash.bin
root@OpenWrt:~# cat /dev/mtd1 >> /tmp/fullflash.bin
root@OpenWrt:~# cat /dev/mtd5 >> /tmp/fullflash.bin
root@OpenWrt:~# cat /dev/mtd6 >> /tmp/fullflash.bin
root@OpenWrt:~# cat /dev/mtd7 >> /tmp/fullflash.bin
root@OpenWrt:~# cat /dev/mtd8 >> /tmp/fullflash.bin
root@OpenWrt:~#

You can download the file from the /tmp folder named fullflash.bin with WinSCP.
Please help, I really need a dump.

Hi guys, based on @benwht 's patch, I built OpenWRT v19.07.1 for Archer C5 V4.

Included packages: block-mount kmod-fs-ext4 kmod-usb-storage e2fsprogs kmod-usb-ohci kmod-usb-uhci fdisk luci luci-app-openvpn openvpn-easy-rsa openvpn-openssl relayd luci-proto-relay luci-ssl.

Here is link for the images and modified patch file for 19.07.1: Archer C5 V4 - OpenWRT 19.07.1

2 Likes

@mirobiala Thanks for your build. You can explain how you apply this patch to openwrt build? I make an build for other router but it was in stock openwrt(which has an great tutorial), and I don't know how to apply these patchs(i google it but don't find any easy explanation).

Apparently, the new driver RTL8367S does not use maximum link speed(1GBit).
I have 1000Mbit Internet, and here are my parameters:
Direct Connection Ethernet(ISP) to the my motherboard:

ISP Connected to the router(with OpenWRT(19.07.0)) WAN and from LAN to motherboard:

Also tried with this options:

Try-enabled-HW-NAT
Not affected in any way ...